WordPress.org

Ready to get started?Download WordPress

Forums

Invisible links only in Firefox (3 posts)

  1. Mithrustt
    Member
    Posted 6 years ago #

    http://www.think-theory.com

    For some reason, when viewing the site in Firefox, I get some invisible links that shouldn't be there. You can see the headline I have, where there are five images. The images are automatically posted if the post is of a certain category and the image is added in the custom fields. It works.

    However, if you have your cursor over one of the images and move to the bottom of it, and slide the cursor down so it's just off the image, the link goes away, as it should. But if you continue down just a few more pixels, the link returns for a few pixels.

    HEADLINE CODE FROM HEADER:

    <div id="headline_bg">
    
    <?php $the_query = new WP_Query('cat=37, 39, 40&showposts=5&orderby=post_date&order=desc');
    
    					while ($the_query->have_posts()) : $the_query->the_post();
    
    					$do_not_duplicate = $post->ID; ?> 
    
    						<div class="headline_spacing">                             
    
    <?php if ( get_post_meta($post->ID, 'headline_img', true) ) { ?>
    
    						<div class="headline_img"><a href="<?php the_permalink(); ?>" rel="bookmark" title="Permanent Link to <?php the_title(); ?>"><img src="<?php bloginfo('stylesheet_directory'); ?>/images/headline/<?php echo get_post_meta($post->ID, "headline_img", $single = true); ?>" alt="<?php the_title(); ?>" /></a></div>
    
    <?php } ?>
                                    </div>	
    
    					<?php endwhile; ?>

    HEADLINE CSS:

    #headline_bg {
    background-image: url('images/bg/featured.gif');
    background-repeat: no-repeat;
    background-position: top center;
    height: 138px;
    width: 1000px;
    margin-left: -20px;
    }
    
    .headline_spacing {
    float: left;
    height: 130px;
    margin: 0 -8px 0 0;
    padding: 4px 0 0 12px;
    }
    
    .headline_img {
    height: 130px;
    width: 192px;
    margin-bottom: 0;
    }
  2. haochi
    Member
    Posted 6 years ago #

    It's actually the img{margin:0 0 1.5em 0;} in compressed.css that's doing it. You can remove that code to solve this problem but I am not sure if it does anything else so you will have to play with a it a bit.

  3. Mithrustt
    Member
    Posted 6 years ago #

    That was simple. And yeah, it didn't affect anything else. Thanks a bunch!

Topic Closed

This topic has been closed to new replies.

About this Topic