WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
Invictus theme homepage fullsize gallery not working in another language (8 posts)

  1. mbanvill
    Member
    Posted 1 year ago #

    Permalinks settings:
    - Post name
    - Example: http://www.fotomart.ca/sample-post/

    ---------------------------------------

    I am not using a static front page. I am rather using Invictus theme homepage fullsize gallery (slideshow).

    ---------------------------------------

    Polylang settings:
    - Default language: Fran├žais
    - Detect browser language: "When the front page is visited, set the language according to the browser preference" is checked
    - URL modifications: The language is set from content. Posts, pages, categories and tags urls are not modified. Remove /language/ in pretty permalinks. Example: http://www.fotomart.ca/en/. "Hide URL language information for default language" is checked. "When using static front page, redirect the language page (example: http://www.fotomart.ca/en/) to the front page in the right language" is not checked.
    - Synchronization: "Allow to synchronize categories, tags, featured image and other metas between translations of a post or page" is checked.

    ---------------------------------------

    My web site: http://www.fotomart.ca

    ---------------------------------------

    Hi,

    First, I want to say that I really love your plugin. It really does a great work!

    Now, the problem that I have is that the Invictus theme homepage fullsize gallery will only load when language "Fran├žais" is used. Otherwise, the images will not show. Same is for all the pages (accessed through the menu) using this fullsize gallery as a slideshow background. I have created photos and galleries for both french and english languages. I don't use this site for blogging and posts but rather as a photography site.

    Please let me know if you need further information from me in order to support this issue I'm having.

    Thanks for your consideration.

    Regards,
    Martin

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Your theme claims to be compatible with WPML. Hopefully, it will help. Have you a file "wpml-config.xml" in your theme directory?

  3. mbanvill
    Member
    Posted 1 year ago #

    Hi Chouby,
    No, there's no such file.
    Is there any hope :o)?
    Thanks,
    Martin

  4. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    If you are ready to dive into the php files of your theme...
    You have to look for lines containing

    icl_

    The WPML functions always start by "icl_" so finding them will help to adapt your theme to Polylang

  5. mbanvill
    Member
    Posted 1 year ago #

    Hi Chouby,
    I'm at work. I will look into this when I get home tonight.
    Thanks for your prompt support!
    Regards,
    Martin

  6. mbanvill
    Member
    Posted 1 year ago #

    Hi Chouby,
    I've gone through all the files on my web server and none contains the string "icl_". Is there something else I should look for? What are the next steps?
    Thanks for your help.
    Martin

  7. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    That's not good news. I know only these two ways for adapting a theme to WPML. Could you ask the theme authors how they adapt their theme to WPML?

  8. mbanvill
    Member
    Posted 1 year ago #

    I will certainly do. Can you keep this post opened until I get back to you. I will shortly.
    Thanks Chouby for your support!
    Martin

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic