WordPress.org

Ready to get started?Download WordPress

Forums

MailChimp List Subscribe Form
Invalid URL Provided When User is Already Subscribed (8 posts)

  1. iubjohnson
    Member
    Posted 1 year ago #

    The form is returning an invalid URL for users that are already subscribed to the list. I get the error message just fine (That email address is already subscribed to the list. Click here to update your profile), but the URL does not work. My list name is "Great Fermentations". Here is the first half of the URL returned:

    great%20fermentations.us7.list-manage.com/subscribe/......

    As you can see, it is putting a %20 in the URL (I'm guessing to deal with the space in our list name). This does not work. However, when I manually remove the %20 value from the URL, it works just fine and I receive the update profile email as expected. Any ideas?

    I'm running v1.2.14 of the plugin.

    http://wordpress.org/plugins/mailchimp/

  2. mc_tak
    Member
    Posted 11 months ago #

    Hey there,

    Thanks for posting! That definitely sounds a bit odd! Would you be able to provide us with the name of your browser and the specific version of that browser that you're running, so we can take a closer look?

  3. darciemg
    Member
    Posted 11 months ago #

    I just came to support for the same issue. New MailChimp account, imported mailing list, just added the plugin and tried my email. I got the same:
    ยป That email address is already subscribed to the list. Click here to update your profile.

    The linked words give the custom subdomain as my list with %20s for spaces. Removing the %20 in the URL is a valid address.

    I'm running Chromium (Version 23.0.1240.0 Built on Joli OS 1.2) but I don't believe this looks like a browser issue.

  4. Brandon Clark
    Member
    Posted 11 months ago #

    I'm having the same issue with users signing up that are already on the list. Subdomain has %20's for spaces, makes URL invalid.

    Site: http://www.RMMoore.com (widget is on bottom left)
    Browser: Chrome 28.0.1500.95 m
    WordPress: 3.6
    Theme: U-Design 2.0.1
    MailChimp WP Plugin: Version 1.2.14
    http://wordpress.org/plugins/mailchimp/

    I've added a dummy email to the list that you can use for diagnostic purposes: dummy@rmmoore.com

    Thanks,

    Brandon Clark

  5. iubjohnson
    Member
    Posted 11 months ago #

    @mc_tak - Sorry for the delay. I was on vacation. Here is the browser info you requested. I tested on all the 3 main ones (chrome, ff, ie) and got the same result.

    Google Chrome Version: 28.0.1500.95 m
    Internet Explorer Version: 10.0.9200.16635
    Firefox Version: 23.0

    Also, I realized that I did not post my WP version last time. We are on 3.6.

    Thanks!

  6. mc_tak
    Member
    Posted 11 months ago #

    Hey all,

    Thanks for providing us with this additional info. On my end, I was able to replicate the interaction in both Firefox and Safari. Oddly enough, it was working for me just fine in Chrome, but I'll continue to test to see if I can replicate it there as well.

    Ultimately the issue being seen is related to how the 'update profile' link is populated currently by the plugin code, which uses the MailChimp account name to generate that beginning portion of the URL/link in question. In doing so, it seems like the scenario in which a MailChimp account name uses spaces, that there are some issues that occur with opening that link in certain browsers and environments. For the time being, the best bet is to use one of two options:

    1) Edit the MailChimp account's name in the Account Settings area of your MailChimp account and ensure that it does not include spaces. To do this, log in to your MailChimp account, click on your name on the left-hand side in the sidebar, and click Account Settings. Then, go to Account Settings > Users & account details. On that page, scroll down to change your 'Company/organization name'. Removing any spaces from that name will ensure that the link will work as expected in all browsers.

    2) Edit the plugin code and manually change the problematic portion of the URL. To do this, log in to your WP-admin area, then go to Plugins > Editor and select the MailChimp plugin. Edit the mailchimp.php file and locate the portion in the code that uses "http://$username". Replace $username with text of your choosing. Keep in mind that this will be visible in the URL that your subscribers click, so you may consider something like your company name (without spaces!).

    As I'm seeing a few reports of this come into the forum, I'll be sure to escalate this to our developers to take a closer look to see if this can be handled any differently. Thanks to all that have taken the time to provide us with the info that you have. If you run into any issues in utilizing the workarounds I mentioned above, or are seeing any other symptoms/effects as a result of this issue, please feel free to post back here and I'd be happy to take a look.

  7. iubjohnson
    Member
    Posted 11 months ago #

    I went with option 2 (manually changing the problematic code) and it worked for me. Thanks for the help!

    I think its probably best to keep this topic open for now though until a fix is found in a next release.

  8. miceman18
    Member
    Posted 10 months ago #

    Just had the same issue on my end.

    I actually just had to apply the fix on mailchimp's end. For some reason when the account contains spaces the information is not being passed accordingly to the variable $username.

    Hope this helps.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic