WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
Invalid shipping method error (16 posts)

  1. fionaR
    Member
    Posted 1 year ago #

    Hi,

    I'm almost done setting up a WooCommerce store for a client and have been testing the checkout.

    I can add items to the cart and select my shipping method, then proceed to the next screen (checkout) to fill in my shipping and billing address but when I click on Place Order I get an error message of "Invalid Shipping Method".

    It doesn't seem to recognise that I've just put in an address as the order summary further down the page still shows "Please fill in your details above to see available shipping methods".

    Has anyone come across this error before/know a solution?

    Thanks,
    Fiona

    http://wordpress.org/extend/plugins/woocommerce/

  2. Sam
    Member
    Posted 1 year ago #

    same issue... I posted a similar questions.
    Anyone out there who know? I read a few older similar threads/problem. they provided no solution to my/our problem.

  3. Roy
    Member
    Posted 1 year ago #

    Do this as a test. First save all your theme files. Then delete the woocommerce folder from within the theme folder. This will make WooCommerce plugin pull from it's default templates without overrides. Now test this again. Don't worry about the styling for now and just test if the function is working. If it works, it would mean the templates you deleted were pre 2.0 templates and you would need to port them over to 2.0. Ask your theme developer to do this for you.

    I am also doing this to my own themes as some files could be missed by accident.

  4. Sam
    Member
    Posted 1 year ago #

    hi splashingpixels, I realize you answered FionaR but.. where does she mentions 'deleting templates'? I am a similar problem. I am new to all this. I recently downloaded WP, then wooCom, then upgraded to the latest WP (the host did not have the latest version... go figure) but I have not deleted any templates.
    if you look at my thread "wooCommerce Shipping error (1 post)", I have described what I have done to test. Not sure if your recommendation should apply to me as well. And if so, why?
    thanks a bunch.

  5. Roy
    Member
    Posted 1 year ago #

    Yes it applies as well. Many themes are still in the process of transitioning to WooCommerce 2.0. So if the templates are of pre 2.0, issues may arise.

    The other easier way to test is simply switch to 2012 theme and if it works, then you know it is related to the theme you're using which most probably are using older WooCommerce templates.

  6. Sam
    Member
    Posted 1 year ago #

    sorry... that that does not seem to solve the problem. you can revisit the site. wwww.mannamilk.co.nz/wordpress
    i upgraded to 2012 theme. which seems to have made some other funny changes... I had 'Cart' in my menu. that's gone. but that's OK, because I have the cart plugin.
    The orange button 'proceed to checkout' is now stretched...

    but mainly the issue with the shipping not fixed yet.
    Any other ideas?

    Thanks

  7. Roy
    Member
    Posted 1 year ago #

    @sammazza what shipping method do you have setup? Did you double check your settings are correct?

  8. Sam
    Member
    Posted 1 year ago #

    yes I did check. I have 'local delivery' and 'local pickup'. cost of both is 0. When I uncheck 'enable shipping' i have no problem. and then with your comment, i decided to I set up 'free shipping' (even though we don't ship, we deliver) - it works!
    So I think local delivery and local pickup are not considered as 'shipping' methods. and when 'enable shipping' is on, things break down.

    Thanks for the tips. My problem is solved but maybe the plug in needs some touch ups.

  9. Roy
    Member
    Posted 1 year ago #

    @sammazza - well what if you put atleast 1 dollar in the shipping cost and re-test?

  10. acesj
    Member
    Posted 1 year ago #

    Try 0.00 as I had same issue.. For some reason it was not reading a plain 0

  11. Sam
    Member
    Posted 1 year ago #

    answer to both comments above:
    if I set shipping to $1 it works fine... except my default shipping options is set to 'local delivery' and the checkout selected the $1 shipping.
    I tried setting shipping to 0.00 got the problem back on.
    I tried setting local delivery with 0.00 and flat rate disabled - not working.
    I think: if the enable shipping is on, it's not enough to have local pickup or local delivery on. these two are not considered shipping and are not selected as default methods as per the setting on the main shipping page.
    so I have two solutions:
    1. not check enable shipping and offer 0.0 local delivery
    2. offer free shipping even if we don't ship, we deliver.
    I think this is counter intuitive and maybe someone will fix this. if this was the intended behavoir, than all is OK.

  12. Roy
    Member
    Posted 1 year ago #

    @sammazza - the plugin authors are around so perhaps they can chime in on your issue.

  13. Sam
    Member
    Posted 1 year ago #

    one other thing, if Enable shipping is OFF, then the second address in the checkout is not shown, which means the shopper can't choose a different delivery address than the billing one.

  14. malechitech
    Member
    Posted 10 months ago #

    If you have Free Shipping checked as a method you're making available, go to the free shipping tab and be sure to select the "Free Shipping Requires..." drop down and make sure not to choose an option that requires a coupon to be used at checkout unless you're using coupons.

    This happened to me and that was the solution. I wasn't using coupons, but it was requiring a coupon code to be used, so I got the error. Hope that helps.

  15. Nimesh
    Member
    Posted 8 months ago #

    @splashingpixels.com, you are right, what u say, like to delete the woocommerce template and than chek. yes after deleting it, the shipping method option can work good. but styling are mashup. what i do?

    any help please.
    thanks you.

  16. Jek-fdrv
    Member
    Posted 5 months ago #

    I solved it with use settings wooComerse => General => Allowed Countries -> All Countries. Good luck!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic