WordPress.org

Ready to get started?Download WordPress

Forums

WPtouch Mobile Plugin
invalid argument supplied for foreach() in ...... on line 1350 (8 posts)

  1. schobeleth
    Member
    Posted 2 months ago #

    So I installed the WPTouch app and it was working beautifully. Then I tried to activate custom posts on it, and I got this error:

    invalid argument supplied for foreach() in ...... on line 1350

    In the header of the theme. Any ideas/suggestions?

    https://wordpress.org/plugins/wptouch/

  2. mkuplens
    Member
    Posted 2 months ago #

    Hi there,

    Could you post the URL for your site and reactivate the custom post type? We'd like to help get to the bottom of the problem you're running into.

    Thanks!

  3. schobeleth
    Member
    Posted 2 months ago #

    Hey,

    My website is Niche Gamer, and I deleted a bit of code from that line and the error went away. I'm thinking the custom theme that I've been using just had some bad or garbled code.

    When I activate the two custom post types my website has, they just 404, and suddenly the settings page unchecks them as well? Is it that custom post types are not supported in the free version? If this is the case I'll be glad to pony up to the paid version, as this theme has been amazing so far.

  4. schobeleth
    Member
    Posted 2 months ago #

    Oh and here's an update.

    So deleting that code actually removed the tags on my one custom theme template. When I couldn't remember what line it was on another PC, I simply just replaced it with a backup file that wasn't touched and it everything was ok. Fixed???

  5. irepairbybk
    Member
    Posted 1 month ago #

    I'm having this same problem, I implemented some code to hide it on the desktop site but it can still be view on my mobile site right now.

    http://www.godofsoles.com is the website, if anyone can help me out on removing this error that would be great!

    Thanks!

  6. Stamatakis
    Member
    Posted 1 month ago #

    Hi there! There is a new update available. First I deleted the plugin with ftp connection. !Take care to delete the wptouch folders from the following directories: wp-content/wptouch-data/backups/wptouch-backup-..........txt & /public_html/wp-content/themes/. And then I re-installed the new version. Then the problem has been resolved to me.

  7. Duane Storey
    Member
    Plugin Contributor

    Posted 1 month ago #

    Hi guys,

    Yes there were some bug fixes with regards to custom post types in the last release. Thanks for all the feedback.

    Regards,
    Duane Storey
    BraveNewCode Inc.

  8. irepairbybk
    Member
    Posted 1 month ago #

    @Duane Storey any update to fixing this? I tried to delete the plugin via FTP like @Stamatakis suggested and reinstall but the same error still comes up above the header...

    This is really bothering me now, any help would be greatly appreciated!

    Thanks

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.