WordPress.org

Ready to get started?Download WordPress

Forums

Google Analyticator
[resolved] Invalid argument supplied for foreach() in google-analyticator.php on line 1048 (17 posts)

  1. Peter Le C
    Member
    Posted 1 year ago #

    Warning: Invalid argument supplied for foreach() in /home/whichfon/public_html/news/wp-content/plugins/google-analyticator/google-analyticator.php on line 1048

    http://wordpress.org/extend/plugins/google-analyticator/

  2. joanneburgess
    Member
    Posted 1 year ago #

    I am getting this and other similar errors as well. Please fix this soon. It appears to be a problem with new GA accounts. I have 30+ others who have this plugin installed and it's not a problem on their sites.

  3. SmoothAssault
    Member
    Posted 1 year ago #

    Yep, same problem for me too.

    - WP 3.5.1, multisite. GA plugin 6.4.2.

  4. Peter Le C
    Member
    Posted 1 year ago #

    I've had a string of problems on Analyticator.
    Across over 60 blogs hosted on different servers, different hosts but same themes. Sometimes it works sometimes it doesn't.

    Have tested with identical themes out of the box. Can't see rhyme nor reason with the instances of not working, so tested out the competition and found one which, installed now across 55 of the blogs works first time.

  5. Michelle
    Member
    Posted 1 year ago #

    Same here - I've tried resetting and saving and get the same error.

    I also see on the GA settings page in WP that the tracking "remove admin" checkbox is unchecked after saveing and the user roles that can see the dashboard widget settings all get unchecked every time I save.

    This is a new Analytics account too if that matters. Thanks!

  6. ebiz98
    Member
    Posted 1 year ago #

    Showing same problem here as well.. Hopefully it will be resolved soon.

    Warning: Invalid argument supplied for foreach() in /.../wp-content/plugins/google-analyticator/google-analyticator.php on line 1048

  7. Razorfrog Web Design
    Member
    Posted 1 year ago #

    Same issue here. Hosting on Dreamhost.

  8. Jeremy Clarke
    Member
    Posted 1 year ago #

    Hey guys, I fixed the issue that causes the invalid argument error. You can find the patched file here:

    https://gist.github.com/jeremyclarke/4718385

    Read the description for details. Hopefully the plugin will integrate this or a similar fix soon.

  9. macky2013
    Member
    Posted 1 year ago #

    I have Version 6.4.2 too and same problems.
    I went to the link you provided, kind of new at this: what am I supposed to do with all the code?

  10. Video User Manuals
    Member
    Plugin Author

    Posted 1 year ago #

    Hi all.

    Terribly sorry for the slow reply here. We've identified this bug and how released an update (6.4.3) - please let us know if you have any other issues.

  11. webventuresllc
    Member
    Posted 1 year ago #

    Have updated to 6.4.3 & error remains. Any suggestions?

  12. webventuresllc
    Member
    Posted 1 year ago #

    deleted & reinstalled plug-in (previously had upgraded) & problem fixed

  13. Rawkley
    Member
    Posted 1 year ago #

    Still have this bug, tried deleting plugin and reinstalling but did not work for me. WordPress 3.5.1, plugin 6.4.3. Thanks.

  14. Ellis Benus
    Member
    Posted 1 year ago #

    Same here:

    Still have this bug, tried deleting plugin and reinstalling but did not work for me. WordPress 3.5.1, plugin 6.4.3. Thanks.

  15. maj_ic
    Member
    Posted 1 year ago #

    I have the same problem. An authenticate() method is failing; ga_get_analytics_accounts() returns and sets $uids = false, and code tries to iterate over $uids.

    The exception thrown in authenticate() mentions /etc/curl/curlCA CAPath.

    I am running on a Solaris machine, is this a platform issue?

    I don't have a /etc/curl directory, but I'm also unfamiliar with the exception message, or curlCA

    Using WP 3.5.1 & plugin 6.4.3

  16. webworks
    Member
    Posted 1 year ago #

    We also are unable to use this plugin, using WP 3.5.1 and Version 6.4.4.3. Curl (ssl) is definitely enabled, on a cpanel server.

    ~~~~~~~~~~~~~~~~~~~

    (cas:72) Google Analyticator was unable to authenticate you with Google using the Auth Token you pasted into the input box on the previous step.

    This could mean either you pasted the token wrong, or the time/date on your server is wrong, or an SSL issue preventing Google from Authenticating.

    Try Deauthorizing & Resetting Google Analyticator.

    Tech Info 0:HTTP Error: (0) Protocol https not supported or disabled in libcurl

  17. netizenpro
    Member
    Posted 8 months ago #

    I was having the same issue and the reason was I was entering the UA-########-1 code instead of the AUTH CODE.

    To get your AUTH CODE, go to your Plugins and click on Google Analyticator / Settings

    Then near the top of the Google Analyticator settings page you will see the following notice... (click on the "Click Here" text link)

    You need to sign in to Google and grant this plugin access to your Google Analytics account

    Click Here - Or here if you have popups blocked

    You will get a popup that says...

    Google Analyticator for WordPress
    This app would like to:
    View your Google Analytics data

    Next: click Accept

    On the next screen, you will receive the following notice including your AUTH CODE:

    Please copy this code, switch to your application and paste it there: (it will be a very long code)

    This should solve the issue. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.