WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] Invalid argument supplied for foreach / class.nextgen_style_manager.php (26 posts)

  1. slabbi
    Member
    Posted 11 months ago #

    New error in v2.07 when calling Gallery -> Other options:

    Warning: Invalid argument supplied for foreach() in /www/htdocs/v105915/wordpress/wp-content/plugins/nextgen-gallery/non_pope/class.nextgen_style_manager.php on line 205

    Warning: Invalid argument supplied for foreach() in /www/htdocs/v105915/wordpress/wp-content/plugins/nextgen-gallery/non_pope/class.nextgen_style_manager.php on line 205

    Warning: Invalid argument supplied for foreach() in /www/htdocs/v105915/wordpress/wp-content/plugins/nextgen-gallery/non_pope/class.nextgen_style_manager.php on line 205

    Warning: Invalid argument supplied for foreach() in /www/htdocs/v105915/wordpress/wp-content/plugins/nextgen-gallery/non_pope/class.nextgen_style_manager.php on line 205

    Warning: Invalid argument supplied for foreach() in /www/htdocs/v105915/wordpress/wp-content/plugins/nextgen-gallery/non_pope/class.nextgen_style_manager.php on line 205

    http://wordpress.org/plugins/nextgen-gallery/

  2. Hasel29
    Member
    Posted 11 months ago #

    I have the same error.

    Is there a solution available?

    kind regards
    Hasel

  3. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    @slabbi, @Hasel29: would either of you be willing to submit a bug report with WordPress and possibly FTP login credentials so we can see this. We've had numerous reports so resolving this is fairly high priority. We can't duplicate it, so being able to see it would help us solve it faster. Thanks. Erick

  4. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    I've seen at least 4 reports with this same error message. I'm going to go ahead and stick this to the top of the forum so others with the issue will be able to see it / find it. If anyone else has this, please post details and, again, consider submitting a bug report with credentials.

    Forgot to add the link for bug reports:
    http://www.nextgen-gallery.com/report-bug/

  5. chrisHe
    Member
    Posted 11 months ago #

    This may be related, as it is a stylesheet issue:
    I see 404 errors because slashes between directories are missing - it is trying to load the following:
    /wordpress/wp-contentngg_stylesnggallery.cssver=3.6

    Running NextGen 2.0.7 with WP3.6 on WAMP stack.
    (Fortunately I don't have custom css styles in this file, so my site is ok, but if I DID it would be messed up!)

    HTH
    Chris

  6. chrisHe
    Member
    Posted 11 months ago #

    Oh, P.S. to above,
    Changing the file via Gallery -> Other Options DOES update the file correctly, (so NextGen knows where it is) but just creates the malformed URL when the web site home page is loaded.
    Chris

  7. slabbi
    Member
    Posted 11 months ago #

    @photocrati:
    Could you post an email I can send the login credentials to? I will check if I can setup a secondary login for your tests.

  8. Inkuda
    Member
    Posted 11 months ago #

    Same Problem here. Using NextGen 2.0.7 with WP 3.6 on GoodNews Theme from Themeforest.

    Rollback and the Gallery are good again.

  9. AndersPH
    Member
    Posted 11 months ago #

    I also rollbacked and the gallery start showing again but I cant add new images, doesn't matter if I use NexGent or Photocrati gallery. Anyway to make it work?

  10. chrisHe
    Member
    Posted 11 months ago #

    Re Stylesheet issue - This was on my dev. pc (Windows/apache etc on Localhost). Have now installed v2.07 onto my staging server (linux shared host) this does _not_ show the same issue - the nggallery.css URL is correctly formed!
    Sorry if this was a red herring.

  11. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    Thanks for the info everyone. @slabbi: you can send to nextgen@photocrati.com. Thanks.

  12. fliwatuet
    Member
    Posted 11 months ago #

    Same error message. Additional i can't add images to a gallery - after uploading/resizing i get no dimensions. Think there is link between the error and resizing images automatically? Mem limit is 64MB.

  13. Jack
    Member
    Posted 11 months ago #

    Same error here. Latest WP and NextGen version, working with Genesis/Dynamic Website Builder combination. Also none of the lightbox options are working now, but did just an hour ago. I did install and delete a few 'feature page' widget plugins, nothing more.

  14. bigiaim
    Member
    Posted 11 months ago #

    @Jack Tummers - I had a problem with the lightbox on one of my sites too - for now deactivating W3 Total Cache has gt the user facing side of the gallery working - I'm still getting the "Warning: Invalid argument supplied for foreach()" errors described at the beginning of this thread in admin though.

  15. terryrook
    Member
    Posted 11 months ago #

    Hi I have the same issue with warnings in the gallery settings in other options.

    Warning: Invalid argument supplied for foreach() in...........wpmain/wp-content/plugins/nextgen-gallery/non_pope/class.nextgen_style_manager.php on line 205

    I deactivated all plugins cleared the cache switched NextGen back on and warning still there.

    WP version 3.6

    I have reported the bug

    Anyone fixed this issue without rolling back

    Thanks
    Terry

  16. nakieken
    Member
    Posted 11 months ago #

    Hi - I got the same problem. I hope the rollback will fix this problem for the moment.
    best wishes,
    Juergen

  17. nootkan
    Member
    Posted 11 months ago #

    I am also seeing this warning above the options but I am able to still upload images.
    Warning: Invalid argument supplied for foreach() in /home/mywebsite/public_html/wp-content/plugins/nextgen-gallery/non_pope/class.nextgen_style_manager.php on line 205

  18. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    Hi all: we've introduced a fix for this and released at part of our latest informal mini-release. If you are comfortably with FTP and manually updating your plugin files, you can download the new zip here:

    http://www.nextgen-gallery.com/nextgen-gallery-latest-beta

    Otherwise the fix will be included in the next official release, which we're expecting to push out roughly on Monday.

  19. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    If anyone tried this and the issue is resolved for you, can you let us know here?

    I'd like to mark this as resolved if we know there is a fix available now as well as included in the next update. But I don't want to do that until we confirm with more users.

  20. nootkan
    Member
    Posted 11 months ago #

    Tried to download the beta from the

    DOWNLOAD THE LATEST BETA: NextGEN Gallery 2.0.10 link

    at the bottom of the page you link to and received a 404 error.

  21. wbread
    Member
    Posted 11 months ago #

    upload beta, problen solved

  22. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    Hi all - there was an issue with the download link this morning. That's been resolved. Thanks.

  23. nootkan
    Member
    Posted 11 months ago #

    Beta uploaded and everything seems to work fine, warning message has disappeared and no other issues so far.

  24. alex1982
    Member
    Posted 11 months ago #

    I can confirm, that the warning messages disappeared using 2.0.10 with wp 3.6 on all-inkl.com-hoster with 256M WP_MEMORY_LIMIT.

  25. pitou
    Member
    Posted 11 months ago #

    Problem described above disappeared after the installation from version 2.0.10. Thank you!

  26. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    Thanks again for the confirmations!

    I'm going to go ahead and mark this as resolved now. If anyone still has it, please let us know or open a new thread.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.