WordPress.org

Ready to get started?Download WordPress

Forums

Etsy Shop
[resolved] Invalid argument error (33 posts)

  1. lunamalena
    Member
    Posted 1 year ago #

    I'm having trouble including this syntax in a page:
    [etsy-include=lunamalena;11494118]

    It refers to a valid Etsy category, as seen here:
    http://www.etsy.com/shop/lunamalena?section_id=11494118

    My API key is valid, but when the page renders I get the following error:
    Warning: Invalid argument supplied for foreach() in /home/content/j/m/s/jmschilling/html/lunamalena/wp-content/plugins/etsy-shop/etsy-shop.php on line 96

    The error can be seen here:
    http://jessicaschilling.com/lunamalena/accessories/

    Any light you might be able to shed on the situation would be greatly appreciated!

    http://wordpress.org/extend/plugins/etsy-shop/

  2. fsheedy
    Member
    Plugin Author

    Posted 1 year ago #

    I get

    Etsy Shop: API reponse should be HTTP 200

    Investigating now why...

  3. fsheedy
    Member
    Plugin Author

    Posted 1 year ago #

    It's ok now from my side, wich version of WordPress you are using?

  4. fsheedy
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, you are using 3.4.2...

  5. lunamalena
    Member
    Posted 1 year ago #

    Thanks for checking this out! I'm on 3.4.2. Does that help at all?

  6. fsheedy
    Member
    Plugin Author

    Posted 1 year ago #

    Could you please update to Etsy Shop version 0.9.1 and enable Debug Mode in the Etsy Shop Options page.

    Results will be on http://jessicaschilling.com/lunamalena/accessories/

  7. lunamalena
    Member
    Posted 1 year ago #

    Done and done. Thank you!

  8. fsheedy
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, forget to tell to flush the Etsy Cache files, located in

    /wp-content/plugins/etsy-shop/tmp/

    Should give result now!

  9. lunamalena
    Member
    Posted 1 year ago #

    Thanks! I deleted the cache files, and took the plugin out of debug mode, but unfortunately I have the same error. I'm sorry for the trouble!

  10. fsheedy
    Member
    Plugin Author

    Posted 1 year ago #

    Flush the cache, but keep in Etsy Debug Mode!

  11. lunamalena
    Member
    Posted 1 year ago #

    Sorry! Cache files deleted and back in debug mode.

  12. fsheedy
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, published a new version 0.9.2, Debug mode is more in verbose mode.

    Could you please: update to last version and stay in debug mode?

  13. lunamalena
    Member
    Posted 1 year ago #

    Updated and in debug mode. Thanks!

  14. fsheedy
    Member
    Plugin Author

    Posted 1 year ago #

    I think I found the problem, you have a space before you Etsy API Key.

    To fix, go to Etsy Options Page, and remove the firt caracter (space) of the API Key.

    Should work, I hope!

  15. lunamalena
    Member
    Posted 1 year ago #

    Sadly no - removed the space, pulled out of maintenance mode and error still there. :( Apologies for the space - it said the API key was valid so I didn't double-check. Could there be another issue with the API key?

  16. fsheedy
    Member
    Plugin Author

    Posted 1 year ago #

    Don't forget to flush cache file (important!)

  17. fsheedy
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, get out of Debug mode, should be the good one.

  18. fsheedy
    Member
    Plugin Author

    Posted 1 year ago #

    Version 0.9.3 will remove spaces from Etsy API Key, as the Etsy API give no special error with spaces, weird...

  19. lunamalena
    Member
    Posted 1 year ago #

    Awesome! All is good. Thank you so much for all your time and help!

  20. lunamalena
    Member
    Posted 1 year ago #

    Marking as solved :)

  21. fsheedy
    Member
    Plugin Author

    Posted 1 year ago #

    Version 0.9.3 now remove spaces for Etsy API Key!

  22. jalabiso
    Member
    Posted 1 year ago #

    I am having a similar problem.

    I am on v.0.9.3, on wp 3.4.2-
    on the plugin Option page, I inserted my API KEY, which looks valid.
    but i get the "Warning: Invalid argument supplied for foreach()"

    http://awesomescreenshot.com/037n8gpe3

    I don't have spaces in the KEY, I flushed the TMP folder and tried debug active and none.

    My only doubt is on Etsy's page, it says my API key is active only for sandbox mode?
    http://awesomescreenshot.com/0b4n8h6b8

    any hint on how to fix it?
    thank you!

  23. fsheedy
    Member
    Plugin Author

    Posted 1 year ago #

    Seem to be a bug on the options page only.
    You API Key is valid, except that you a a limit of 5000 requests per day.

    Is the store work except the options page?
    I'm not able to reproduce that bug.

  24. 8-bitcrowd
    Member
    Posted 1 year ago #

    Hi fsheedy!

    I am having a similar problem.

    I am on v.0.9.3, on wp 3.4.2-
    on the plugin Option page, I inserted my API KEY, which looks valid.
    but i get the "Warning: Invalid argument supplied for foreach()"

    I try to follow the instructions above, i have the last update, able and enable Debug mode, check for the space in my API Key number, its correct. My temp folder is empty, noting to erase.

    i try to look for a solution before, but i cant find any. :(

    Any hint on how to fix it?

    Hope you can help me

    Thanks for the amazing plugin! :)

    Have fun!

  25. fsheedy
    Member
    Plugin Author

    Posted 1 year ago #

    Hi 8-bitcrowd,

    I will need:

    1. Please activate debug mode and:
    2. Screenshot of the options page with the error;
    3. Screenshot of the page/post with the etsy-include bracket;
    4. URL of the page/post (to see source code)

    I will maybe not be able to reproduce, so I will need to seed you special instructions after that (if required).

  26. 8-bitcrowd
    Member
    Posted 1 year ago #

    Hi, thanks for the help!

    So ok,
    the debug mode is active.

    here is the screenshot og page with error
    http://awesomescreenshot.com/0bfq15a37

    This is the screenshot of the post with the brackets
    http://awesomescreenshot.com/099q1626b

    Here the screenshot and the link fo the post URL of the post in the wordpress
    http://awesomescreenshot.com/001q15jcb
    http://www.8-bitcrowd.com/?p=241

    I hope this will help, if something its wrong or you need more info please let me know!

    Thanks again

    Have fun!

  27. fsheedy
    Member
    Plugin Author

    Posted 1 year ago #

    Try with section ID: 12655421

  28. 8-bitcrowd
    Member
    Posted 1 year ago #

    Hi!

    I try, still the same error :( sorry :(

    http://awesomescreenshot.com/021q66q01

    If theres anyway i can help just tell me, thanks!

    Thanks for your time and help.

    Have fun!

  29. fsheedy
    Member
    Plugin Author

    Posted 1 year ago #

    Another problem now, maybe the last one...

    You have html code in the bracket etsy-include.
    So go in text mode and remove html code from the bracket.

    This will be auto filter in next version.

    Tell me if this works!

  30. 8-bitcrowd
    Member
    Posted 1 year ago #

    Hey, i change it,

    Still not working but the error message change as you can see here:

    http://www.8-bitcrowd.com/?p=241

    thanks again!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.