WordPress.org

Ready to get started?Download WordPress

Forums

wpMandrill
Invalid API Key (8 posts)

  1. iurisilvio
    Member
    Posted 1 year ago #

    My valid API key is not accepted. :/

    http://wordpress.org/extend/plugins/wpmandrill/

  2. Mandrill Kaitlin
    Member
    Posted 1 year ago #

    Are you getting an error that the API key is invalid or some other error?

    Can you make sure that there aren't any extra spaces on either side if you're pasting the API key? If that still doesn't work, if you set the WP_DEBUG constant (defined in your wp-config.php file) to true, you'll see some messages added by the plugin in key parts of the process for the logs.

  3. iurisilvio
    Member
    Posted 1 year ago #

    Yes, I'm sure the key does not have extra spaces. Running in debug mode, I didn't found any debug message. :/

  4. haxxxton
    Member
    Posted 1 year ago #

    I am getting the same issue.. Created new API key on Mandrill.com then straight copy and paste into the wpMandrill plugin.. getting the same error message.. Invalid API key.

  5. MC_Will
    Member
    Plugin Author

    Posted 1 year ago #

    Can you get in touch with me at will (at) mailchimp com ?

    Send me the API and a few details about your platform: OS, wp engine if apply, etc...

  6. Bruno Braga
    Member
    Posted 1 year ago #

    the SSL certificate http-request response is invalid due to an invalid certificate error (we should catch this as an exception and log it instead or maybe be a bit more verbose to the user why this happens), I added:

    curl_setopt ($ch, CURLOPT_SSL_VERIFYHOST, 0);
    curl_setopt ($ch, CURLOPT_SSL_VERIFYPEER, 0);

    to the file wpmandrill/lib/mandrill.class.php after line 429, solved my problem. :) I applied this on my dev env, I will check again once I deploy the original mandrill plugin on production to make sure it works there as expected.

  7. otravers
    Member
    Posted 1 year ago #

    I'm running into this issue too in my local dev environment which is a Windows 7 PC running the XAMPP stack with PHP 5.3.8. In our staging environment which runs Centos and PHP 5.3.18, the same Mandrill API key was accepted without a hitch. Both WP installs are similar (local dev has a few extra plugins) with WP 3.5 and wpMandrill 1.23.

  8. tigransloyan
    Member
    Posted 1 year ago #

    hi Will, I have the same issue, I e-mailed you at will (at) mailchimp com with screenshots and more details, can you please let me know if you are still maintaining this plugin?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.