WordPress.org

Ready to get started?Download WordPress

Forums

intro is skipped when reading article (10 posts)

  1. freechris
    Member
    Posted 8 years ago #

    Hello,

    i use the (more) tag to display a read more link on my website so that my articles are not displayed completely on the frontpage.

    But the problem is that when somone clicks on readmore to read the complete article,
    wordpress will skip the intro that is displayed on the first page. I think it uses an anchor to skip the intro because most people will read the intro on the frontpage. But i think it is annoying and i would like to remove it. How could i remove this option?

    best regards,

    Christian.

    PS you can check it here:

    http://www.appleblog.nl

  2. nearlythere
    Member
    Posted 8 years ago #

    have you tried using the excerpt field in the post editing form?

    this does the same as the 'more' tag, but does not put in an anchor, nor link to the anchor.

  3. freechris
    Member
    Posted 8 years ago #

    no there is no such field in my wordpress write menu. But maybe that is because i translated my theme into another language? anyway i have never seen any field which i could use as an intro the an article. (so that you will only get a teaser on the frontpage)

    how can i activate this? are there other solutions? because another problem i have is that the wysiwyg plugin does not work in firefox or safari on my mac. And the plugin that does works, does not have an icon to insert a more tag (to include a teaser)

    so i need a good solution that works browser independent to create a teaser that does not link to an anchor

    :D

  4. Beel
    Member
    Posted 8 years ago #

    change the_content() to the_excerpt() in your file. You can read up on both in the codex.

  5. freechris
    Member
    Posted 8 years ago #

    where can i find this information?

  6. TechGnome
    Moderator
    Posted 8 years ago #

    More info in the Codex: http://codex.wordpress.org/Template_Tags

    However, if you don't even see the excerpt field box when writing a post, odds are you are using the Simple Controls setting. From your admin screen, click "Options", then "Writing" and select "Advanced Controls" from the first set of radio buttons. Scroll down and click "Update Options". Now when you go to Write Post, you'll have an excerpt field you can fill in.

    -tg

  7. freechris
    Member
    Posted 8 years ago #

    thanks a lot!

    oke and i am trying to find in the css code where i can align the:

    Geplaatst in Games | Wijzig | 3 Reacties »

    to the left of the page instead of the center
    where could i change this?

  8. Beel
    Member
    Posted 8 years ago #

    Well, looking at your source shows a class of postmetadata, so one might conclude this to be the appropriate place in the css:

    .narrowcolumn .postmetadata {
    text-align: center;
    }

  9. megolla
    Member
    Posted 8 years ago #

    if you want to customize the "<-- more -->" and its behaviour (jumping to anchors or not and thus skipping the intro) you might be interested in the following article:

    http://codex.wordpress.org/Customizing_the_Read_More#Link_Jumps_to_More_or_Top_of_Page

  10. freechris
    Member
    Posted 8 years ago #

    if you want to customize the "<-- more -->" and its behaviour (jumping to anchors or not and thus skipping the intro) you might be interested in the following article:
    ---

    that's the freakin shit!
    i changed it now

    many thanks to all of you!

Topic Closed

This topic has been closed to new replies.

About this Topic