WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] Internet Explorer jQuery bug (7 posts)

  1. Nick
    Member
    Posted 3 years ago #

    Hello!

    I am having a problem with some of the jQuery functions that Easy Fancybox uses in Internet Explorer. Firefox, Chrome and Safari all work fine. The problem is here:

    http://nickstevens.me/portfolio/photos

    When I visit the page in IE a dialog pops up and says "Stop running this script? A script on this page is causing Internet Explorer to run slowly. If it continues to run, your computer might become unresponsive." If I hit "No" everything works perfectly fine, but if I hit "Yes" Easy Fancybox stops working.

    According to the IE Developer tools the errors are in the jQuery script on line 97, character 23; line 97, character 50; and line 91, character 121.

    I have no idea how to fix this and get the dialog box to go away. Any help is greatly appreciated! Thanks!

  2. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    I see nothing wrong with your page source code... The only thing I can think of is that there might be something 'wrong' (in the eyes of IE) with the minification and/or compression that is done by W3 Total Cache.

    Can you test with turning caching completely OFF for a moment? Then, if that gets rid of the error, recommence with switching parts of the complex W3TC tool set back on and each time check to see if the error comes back...

  3. Nick
    Member
    Posted 3 years ago #

    RavanH, thank you for your reply. Unfortunately, this problem existed before I installed W3 Total Cache and deactivating it did not help.

  4. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    As far as I can tell, only FancyBox and Contact Form 7 are using the jQuery library on your site. Does the problem persist when you switch one of these two plugins off and leave the other one running?

    Another thing you might try is use the latest jQuery library from Google CDN by installing the plugin http://wordpress.org/extend/plugins/use-google-libraries/ or configure W3TC to use the latest (1.5.x) http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js instead of jQuery library (1.4.4) included with WordPress.

    I'm sorry I can not offer any real help here, only suggestions. I cannot reproduce the error... Anyone else?

  5. Doug Smith
    Member
    Posted 3 years ago #

    Yes, I just had a user report the same thing on a site and I've been able to reproduce it in IE 7. It goes away when I disable Easy Fancy Box.

    I had been force-loading the latest jQuery from Google CDN, which recently changed to version 1.6. I went back to jQuery version 1.5.2 and the problem is went away.

  6. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks for reporting, Dough.

    There is a related discussion on http://groups.google.com/group/fancybox/browse_thread/thread/910ea1e40f53553e where it's said to be a bug in jQuery 1.6 which should be fixed in 1.6.1

    Let's hope that will be the case soon :) but if you cannot wait, there is a temporary workaround suggested on http://pastebin.com/1CxG62aB

  7. Nick
    Member
    Posted 3 years ago #

    Thanks guys for all your help! The temporary workaround sometimes worked and sometimes didn't, but I was able to jump back to jQuery version 1.5.2 and that fixed it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic