WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
International shipping showing as free (4 posts)

  1. taml
    Member
    Posted 1 year ago #

    When selecting International shipping it is not showing a price and lets the customer process as if it's free.

    In General Settings, Allowed Countries is set to All.
    In Shipping Settings, International is enabled, Availability is set to "Excluding selected countries" and the countries field is blank i.e. don't exclude any countries.
    Default cost is set as 1.5.

    I'm running latest versions of WP and WooCommerce.

    Can anyone help?

    http://wordpress.org/extend/plugins/woocommerce/

  2. pconner9
    Member
    Posted 1 year ago #

    I have the same problem with no solutions either. Before the update, everything was great, now, after the update that international shipping is a problem.

    I have a flat rate of $8.00, but when I test it, it shows International Delivery (free). What?!?!

    Worse, I have a potential customer who wants to order, but I can't get it to work and will either lose business or eat the cost.

    Have you had any success? I see you posted two weeks ago.

  3. taml
    Member
    Posted 1 year ago #

    I'm afraid it still isn't working for me. The only way I have got round it for now is to set a negative amount for a voucher code and ask international customers to enter that code. For example, international orders may be £10 delivery, so I set a voucher code for -£10 (as they are a negative amount by default so entering a negative amount in there will turn it in to an addition to the cost). Then I edited the page to add a message to prompt the user to do that.

    Hope that helps!

  4. pconner9
    Member
    Posted 1 year ago #

    I didn't want to lose a customer over a programming issue like this, so I added a product called "International Delivery $8 Flat Rate" and I emailed the potential customer explaining that the recent upgrade caused a problem in that area and although it says "free" there really was a charge. I worked around it until it's fixed and added a product to cover some of the costs. So, very similar to what you did.

    Luckily, we figured out a way to work around the issue.

    Thank you for your response and know you are not alone. Hopefully a resolution will find its way to us shortly, however, you have been waiting 2 weeks, so I guess patience is called for in the process.

    Personally, patience is not one of my virtues.

    :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.