WordPress.org

Ready to get started?Download WordPress

Forums

Internal Service Error when trying to update a post (7 posts)

  1. greenandchic
    Member
    Posted 5 years ago #

    I responded to a previous post not long ago about the same issue, but I think I should start my own. When I try to update a post, I get this error message:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@greenandchic.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    --------------------------------------------------------------------------------

    Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.7a mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/5.2.6 Server at http://www.greenandchic.com Port 80

    It all works otherwise, just not when I'm trying to update a post.

  2. techdx69
    Member
    Posted 5 years ago #

    i have the same problem on my WP Wall plugin, anyone care to help?? :(

  3. gazouteast
    Member
    Posted 5 years ago #

    I'm getting a similar error - WP 2.6.3 on PHP 4

    Begin a new post - create title and start typing content.
    FIRST auto-save works (usually around 3rd paragraph)

    continue typing for an hour or two, insert graphics etc.
    add tags
    create excerpt
    add bits with Amazon reLoaded plugin
    schedule post

    all the while the auto-save is dimming the Save and Publish buttons to say it's auto-saving periodically.

    Then hit either Save or Publish (doesn't matter which) and I get a white screen with similar error to first post above - refresh doesn't clear it, waiting 20 minutes and refreshing doesn't clear it.
    Before refreshing, hitting back button gives empty new post page and all work after first auto-save is lost.

    Only the post as at the FIRST auto-save has been saved - everything created after that has disappeared, i.e. only the title and first few paragraphs are saved.
    No errors show during the subsequent auto-save dimming of the save and publish buttons.
    There are no incremental save records after that first auto-save.

    This has been happening consistently for me since upgrading to 2.6.3 from 2.6.2.

    In the last 5 days it has lost over twelve hours of post creation for me, and is a MAJOR BUG from where I'm sitting - every time it happens I have to live-chat with my hosts and get them to unlock the SQL server so I can get back into WP admin.
    (public side is generally not affected for some reason - though it was once, on Thursday last, the second error after this all started).

    I have multiple sites on multiple hosts, and so far it's just one site on a UK host that's causing this - it's the only one still running PHP 4 All the others are on PHP 5 and not suffering this.

    Does anyone have any clue what is causing this?
    By the way, manually saving in steps of under 2-3 minutes does not get hit by this - could it be some form of server connection time-out caused by apparent inactivity (i.e. not manually connecting to the server for X minutes? And if so, is it WP or the server causing this?)

    Really need this sorted, and fast
    Gaz

  4. techdx69
    Member
    Posted 5 years ago #

    I fixed this problem already by changing all file attributes to 777.. :)

  5. garethooper
    Member
    Posted 5 years ago #

    High Risk changing to 777, you are essentially allowing the World to write to those files.

  6. oberazzi
    Member
    Posted 5 years ago #

    any solution?

  7. crystalcopywriting
    Member
    Posted 5 years ago #

    I have the same problem even after completing uninstalling, clearing database and reinstalling wordpress 2.7

    I even changed the permissions to 777 and this - somewhat risky - has not corrected the problem

    If I so much as try to change my email address I get this message:

    You don't have permission to access /wp-admin/options.php on this server.

    Anyone have an idea - APART FROM CHANGING TO 777 ????

    Gratefully,
    Steve

Topic Closed

This topic has been closed to new replies.

About this Topic