WordPress.org

Ready to get started?Download WordPress

Forums

Internal Server Error - While attempting to insert image from gallery (3 posts)

  1. w0rdpresssucks
    Member
    Posted 5 years ago #

    I'm sure many of you have seen this, searched for countless hours, reinstalled 500 times, switched hosts, etc etc and havent figured it out. Perhaps there's a bug in the downloaded zip, so you get the old version, nope that didnt work problem is still there, so you copy the complete setup from another working site over to your existing site and the problem still arises. You clear browser cache, switch pc's, do everything humanly possible aside from strangling the people responsible for coding wordpress.

    So after creating an .htaccess file, the flash uploader works. HURRAY!!
    Too bad its ultimately useless because when you attempt to add the image to the post via "INSERT IMAGE" button provided, you get a beautiful screen saying "Internal Server Error" which it goes on to say additionally, a 404 blah blah error. So. I google the hell out of every possible combination of keywords to no avail.

    Has anyone ever experienced this crap, if so, could you please take a few minutes of your life to bestow upon us poor idiots who are forced to use wordpress with the assistance on how to fix this crap?

    Thanks

  2. w0rdpresssucks
    Member
    Posted 5 years ago #

    PUT THIS IN .htaccess IN WP-ADMIN FOLDER.

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

    FIXED IT. god what a freaking hassle to figure this stupid crap out. woohoo! gonna go smoke some crack now

  3. tlr87
    Member
    Posted 4 years ago #

    I just installed WordPress Version 2.8.3 this morning after installing I got this message when I was adding an Image to a post

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, XXXXX and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/XXXX Server at XXXXXXXXX.com Port XX

    Thank you w0rdpresssucks for this solution as it works.

    As after I added this code to my wordpress .htaccess file (located on the root directory) If you cant find it look up this tutorial.

    http://www.intrepid.com.au/how-to-view-htaccess-with-filezilla/

    It began working again.

    in the end my .htaccess looked like this.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /updates/wp-admin/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /updates/index.php [L]
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>
    # END WordPress

    Could wordpress developers please address this issue as it is annoying as this solution to this problem was not easy to find.

    Again thank you w0rdpresssucks for this solution.

Topic Closed

This topic has been closed to new replies.

About this Topic