WordPress.org

Ready to get started?Download WordPress

Forums

BulletProof Security
[resolved] Internal Server Error after secure ht access (12 posts)

  1. kisiell
    Member
    Posted 1 year ago #

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, support@one.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    http://wordpress.org/extend/plugins/bulletproof-security/

  2. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    First off delete the .htaccess file in your website root folder so that you can get back into your site.
    Example website root folder: /public_html/.htaccess.

    Next provide the System Information below about your website/Server. You will find this info on the BPS System Info Tab page.

    Server Type:
    Operating System:
    Server API:

    For general troubleshooting steps see this help post >>> http://www.ait-pro.com/aitpro-blog/297/bulletproof-security-plugin-support/bulletproof-security-wordpress-plugin-support/

    I tried looking at the help and support pages for one.com and found pretty nothing about what they do and do not allow so not much help there. ;)

  3. kisiell
    Member
    Posted 1 year ago #

    Hi thanks for quick answer. I have override .htaccess so my site its working again . The some info about my server provider
    Thank You
    Website Root Folder: http://lottomaniak.co.uk
    Document Root Path: /customers/c/e/7/lottomaniak.co.uk/httpd.www
    WP ABSPATH: /customers/c/e/7/lottomaniak.co.uk/httpd.www/
    Parent Directory: /customers/c/e/7/lottomaniak.co.uk
    Server / Website IP Address: 10.246.64.11
    Host by Address: web01-01
    DNS Name Server: ns01.one.com
    Public IP / Your Computer IP Address: 86.175.80.203
    Server Type: Apache
    Operating System: Linux
    Server API: cgi-fcgi - Your Host Server is using CGI.
    Zend Engine Version: 2.3.0
    Zend Guard/Optimizer: A Zend Extension is Not Loaded
    ionCube Loader: ionCube Loader Extension is Not Loaded
    Suhosin: The Suhosin-Patch is installed
    APC: APC Extension is Not Loaded
    eAccelerator: eAccelerator Extension is Not Loaded
    XCache: XCache Extension is Loaded and EnabledXCache Extension is Not Loaded
    Varnish: Varnish Extension is Not Loaded
    Memcache: Memcache Extension is Not Loaded
    Memcached: Memcached Extension is Not Loaded

  4. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    I looked for help and FAQ pages on your Host and did not find any information about .htaccess files. I did a Chat Session with one.com Hosting support and one.com Hosting does not allow the Options directive to be used in .htaccess files so you will need to comment it out by adding a # sign in front of that Directive in your Root .htaccess file.

    # DO NOT SHOW DIRECTORY LISTING
    # If you are getting 500 Errors when activating BPS then comment out Options -Indexes
    # by adding a # sign in front of it. If there is a typo anywhere in this file you will also see 500 errors.
    #Options -Indexes

    Chat session with one.com Support (great support):

    You are now chatting with 'Niksaan'
    Niksaan: Thank you for using One.com 24/7 Interactive Online Support. My name is Niksaan. How may I assist you?
    you: Hello do you allow .htaccess files and do you allow the htaccess file permission to be set to 404 instead of 644 file permissions?
    Niksaan: Hello
    Niksaan: yes, we do allow .htaccess file, but it depends on the script you will place in the .htaccess file
    Niksaan: and you can set its permissions to 404
    you: I am assisting one of your customers here - http://wordpress.org/support/topic/internal-server-error-after-secure-ht-access?replies=3
    you: Ok then do you allow the "Options" directive in htaccess files? example Options -Indexes?
    Niksaan: no, we do not allow Options
    Niksaan: you need to comment out all options line
    you: ok yep i thought that might be the issue. great thank you
    Niksaan: by placing a # infront of these lines
    Niksaan: You are welcome. Feel free to contact us again for any further assistance. Bye and hope you have a nice time : )
    you: yep i will inform your customer to do this. # DO NOT SHOW DIRECTORY LISTING # If you are getting 500 Errors when activating BPS then comment out Options -Indexes # by adding a # sign in front of it. If there is a typo anywhere in this file you will also see 500 errors. Options -Indexes
    you: have a nice day!!!!!!
    Niksaan: yes, this is correct :)

  5. kisiell
    Member
    Posted 1 year ago #

    Thank You very much. Now will try again and will let You know how it goes
    Thanks again

  6. kisiell
    Member
    Posted 1 year ago #

    right??? where do I need to put # ???????? #.htaccess ?????

  7. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    1. Go to the Security Modes tab page and click the AutoMagic buttons.
    2. Then go to the Edit/Upload/Download Tab page and click on the secure.htaccess tab.
    3. Scroll down in the file until you see this code and add a # sign as shown below:

    # DO NOT SHOW DIRECTORY LISTING
    # If you are getting 500 Errors when activating BPS then comment out Options -Indexes
    # by adding a # sign in front of it. If there is a typo anywhere in this file you will also see 500 errors.
    #Options -Indexes

    4. Go back to Security Modes and activate BulletProof Mode for your Root folder.

  8. kisiell
    Member
    Posted 1 year ago #

    great!!!!!!!!!!!!!!!!
    everything working
    thank you very very very much!!!!!!!!!!!!!!!!!!!!!!

  9. kisiell
    Member
    Posted 1 year ago #

    Hi I have the same problem again on the another website but this
    # DO NOT SHOW DIRECTORY LISTING
    # If you are getting 500 Errors when activating BPS then comment out Options -Indexes
    # by adding a # sign in front of it. If there is a typo anywhere in this file you will also see 500 errors.
    #Options -Indexes
    no working !!!

  10. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    A 500 error can be caused by a lot of different things and does not necessarily mean the 500 error is occurring because of your .htaccess file.

    Have you put BPS in Default Mode to see if the problem is with the .htaccess file?
    http://forum.ait-pro.com/forums/topic/read-me-first-free/

    The Broken cPanel HotLink Protection Tool problem:
    http://wordpress.org/support/topic/plugin-bulletproof-security-broken-cpanel-hotlink-tool-404-errors-unable-to-edit-htaccess-files?replies=9

  11. adeelraza_786
    Member
    Posted 5 months ago #

    I am getting this error very often after installing bps ERROR 500 - INTERNAL SERVER ERROR , furthermore , I got this one also forbidden acccess to server and it was removed after I removed the .htacces file from my root

    This is th server info plz help ..

    Server Info

    Website Root URL: http://karimismail.com
    Document Root Path: /home/karim78/public_html
    WP ABSPATH: /home/karim78/public_html/
    Parent Directory: /home/karim78
    Server / Website IP Address: 174.120.61.62
    Host by Address: 3e.3d.78ae.static.theplanet.com
    DNS Name Server: ns946.websitewelcome.com
    Public ISP IP / Your Computer IP Address: 182.178.2.217
    Server Type: Apache
    Operating System: Linux
    WP Filesystem API Method: direct
    Server API: cgi-fcgi - Your Host Server is using CGI
    cURL: cURL Extension is Loaded
    Zend Engine Version: 2.2.0
    Zend Guard/Optimizer: Zend Optimizer Extension is Loaded
    ionCube Loader: ionCube Loader Extension is Loaded Version: 40202
    Suhosin: Suhosin is Not Installed/Loaded
    APC: APC Extension is Not Loaded
    eAccelerator: eAccelerator Extension is Not Loaded
    XCache: XCache Extension is Not Loaded
    Varnish: Varnish Extension is Not Loaded
    Memcache: Memcache Extension is Not Loaded
    Memcached: Memcached Extension is Not Loaded

  12. AITpro
    Member
    Plugin Author

    Posted 5 months ago #

    The error could be caused by several possible things. click the link below to go the BulletProof Security Forum read me first page that lists all the possible causes for this error.
    http://forum.ait-pro.com/forums/topic/read-me-first-free/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.