WordPress.org

Ready to get started?Download WordPress

Forums

Internal Server Error 500 only on main page (2 posts)

  1. polarbare
    Member
    Posted 3 years ago #

    Just got my WordPress blog up with the modularity lite theme and got running on Godaddy last week, no problems, everything went great. I installed 2 plug ins, Nextgen gallery and sociable; made a post using both without a problem. I made a draft of another post for today and everything was fine until I posted it. When I posted it the main page of the site gave me the dreaded 500 internal server error. I change the post from posted back to a draft, and my site worked again. (Ability to access WP control panel has been fine throughout). Thinking I had done something wrong, I made a text only post, same problem. If I change it back to a draft everything works.

    I also noticed that if I go straight to a permalinked item they display fine, even the "test" post that is killing the main page. I disabled both plugins with no effect so re-enabled them. I replaced the .htaccess with a default one, same thing.

    http:polarbarephotography.com is the address that is showing the error and
    http://polarbarephotography.com/2010/08/30/test-for-500-internal-server-error/ is a working permalinked page.

    any help is greatly appreciated..

  2. shaneharger
    Member
    Posted 3 years ago #

    a 500 error can happen for a handful of reasons.

    1. permissions are set wrong when using su_PHP. in generally, it's smart to make sure your files are not using 777. If any are and you use su_PHP, it'll give you a 500 error. the easy fix is to change the permissions for the file to 755. (prob not it in your case)

    2. your .htacess file is messed up. normally it's some messed up redirect. you can test this one really quick by just renaming it to .htaccessTEST or something. if the 500 error is gone after you do that, that something in there is wrong. (this is probably what is wrong)

    3. your directory indexing is turned off and there is no index file within that directory. (prob not it in your case)

    4. your error log hit a limit. the default limit i believe it 2Gigs. simple fix is to rename it error_logOLD or something. a new one will generate itself. if this is it, then to prevent it from happening again, check the error log to see what is filling it up and needs to be fixed.

    5. if all else fails, you can always check with your hosting company. they can see more than we can, and if they are good, they'll fix it for you. :)

Topic Closed

This topic has been closed to new replies.

About this Topic