WordPress.org

Ready to get started?Download WordPress

Forums

Internal Redirect problem (8 posts)

  1. brightstar creative
    Member
    Posted 1 year ago #

    We are building a client WP site, we were working on it today with no problems, haven't updated anything but did update Firefox.

    When we then tried to log in to the site admin we are getting:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    The holding page plugin has also disappeared.

    Our host company looked into it and have said the error log shows:

    [Mon Apr 15 14:30:07 2013] [error] [client 80.71.9.1] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://www.ifcsheffield.org.uk/

    and

    It is a scripting / content issue in regards to the index file in the /wp-login folder.

    We need to work on this site urgently t meet the deadline, can anyone offer any advice to clear this problem please :-)

    Many thanks dp

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Try:
    - switching to the default theme by renaming your current theme's folder inside wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

  3. brightstar creative
    Member
    Posted 1 year ago #

    Hi Esmi - many thanks for your advice.

    We have tried this and done exactly as your instructions (3 separate times and by 2 different designers just to be sure) and it still isn't allowing access.

    I can tell it is now defaulting to the other theme as the "jumbled files" are now not showing when we type in the domain, but when we try to log in we are still getting the same error:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Is there anything else we can try - we are desperate :-(

    Thanks dp

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Try checking your site's error logs for a more specific error message. Your hosts should be able to help you in accessing your site's error logs.

  5. brightstar creative
    Member
    Posted 1 year ago #

    Hi Esmi

    The error log was in the original question (as below):

    [Mon Apr 15 14:30:07 2013] [error] [client 80.71.9.1] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://www.ifcsheffield.org.uk/

    Our host also said: It is a scripting / content issue in regards to the index file in the /wp-login folder.

    I dont know what I need to change/remove/update to correct the above - can yu help :-)

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    I don't think that has anything to do with WordPress. Many hosts are currently experiencing problems due to mass attacks. Yours may be one of them. Try asking them about it.

    I'd also suggest reviewing http://wordpress.org/support/topic/brute-force-attacks-and-wordpress and Brute Force Attacks.

  7. brightstar creative
    Member
    Posted 1 year ago #

    Hi Esmi

    I am aware of the brute force attacks but this site doesn't use Admin as a user name and has a very strong fairly random password (as do all our WP sites).

    It also cant be our host (Fashosts) that is blocking wp admin access as all the other WP sites are hosted there and are allowing access fine.

    Any thing at all I can try?

    best wishes dp :-)

  8. brightstar creative
    Member
    Posted 1 year ago #

    Esmi - we seem to have solved it by doing this:

    Relocate method
    WordPress supports an automatic relocation method intended to be a quick assist to getting a site working when relocating a site from one server to another.

    Steps

    1. Edit the wp-config.php file.

    2. After the "define" statements (just before the comment line that says "That's all, stop editing!"), insert a new line, and type: define('RELOCATE',true);

    3. Save your wp-config.php file.

    4. Open a web browser and manually point it to wp-login.php on the new server. For example, if your new site is at http://www.mynewdomain.com, then type http://www.mynewdomain.com/wp-login.php into your browser's address bar.

    5. Login as per normal.

    6. Look in your web browser's address bar to verify that you have, indeed, logged in to the correct server. If this is the case, then in the Admin back-end, navigate to Settings > General and verify that both the address settings are correct. Remember to Save Changes.

    7. Once this has been fixed, edit wp-config.php and either completely remove the line that you added (delete the whole line), comment it out (with //) or change the true value to false if you think it's likely you will be relocating again.

    Note: When the RELOCATE flag is set to true, the Site URL will be automatically updated to whatever path you are using to access the login screen. This will get the admin section up and running on the new URL, but it will not correct any other part of the setup. Those you will still need to alter manually.

Topic Closed

This topic has been closed to new replies.

About this Topic