WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Internal 500 error (13 posts)

  1. Warrior Instinct MMA
    Member
    Posted 1 year ago #

    Just wondering if anyone else has run into this problem. Our site gets an Internal 500 error at least once to twice a week. I have gone through GoDaddy and change the name of the htaccess file and the site will be fine, but what happens is as soon as we remame the file there is another htaaccess file created. This has GoDaddy stumped saying it is a WordPress issue. If anyone know a fix we would appreciate it very much.

  2. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    What is in the htaccess file?

    And please read this, http://codex.wordpress.org/Forum_Welcome#Posting_Code

  3. Warrior Instinct MMA
    Member
    Posted 1 year ago #

    This is the one I renamed:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    This is the one that reappeared in less then 15 seconds later:
    # BEGIN W3TC Browser Cache
    <IfModule mod_deflate.c>
    <IfModule mod_headers.c>
    Header append Vary User-Agent env=!dont-vary
    </IfModule>
    AddOutputFilterByType DEFLATE text/css text/x-component application/x-javascript application/javascript text/javascript text/x-js text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon application/json
    <IfModule mod_mime.c>
    # DEFLATE by extension
    AddOutputFilter DEFLATE js css htm html xml
    </IfModule>
    </IfModule>
    # END W3TC Browser Cache
    # BEGIN W3TC Page Cache core
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteRule .* - [E=W3TC_ENC:_gzip]
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} =""
    RewriteCond %{REQUEST_URI} \/$
    RewriteCond %{HTTP_COOKIE} !(comment_author|wp\-postpass|w3tc_logged_out|wordpress_logged_in|wptouch_switch_toggle) [NC]
    RewriteCond "%{DOCUMENT_ROOT}/wp-content/cache/page_enhanced/%{HTTP_HOST}/%{REQUEST_URI}/_index.html%{ENV:W3TC_ENC}" -f
    RewriteRule .* "/wp-content/cache/page_enhanced/%{HTTP_HOST}/%{REQUEST_URI}/_index.html%{ENV:W3TC_ENC}" [L]
    </IfModule>
    # END W3TC Page Cache core
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Thank you the help it is much appreciated.

  4. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    And are you using w3tc?

  5. Warrior Instinct MMA
    Member
    Posted 1 year ago #

    Yes we are using w3tc

  6. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    So you have to have the longer one for w3tc. You renamed the shorter one . . . where did that one come from?

  7. Warrior Instinct MMA
    Member
    Posted 1 year ago #

    The shorter of the 2 came from the htaaccess folder that was renamed once we discovered the error. The longer one was for the current htaaccess folder at that time. Now once I open the current htaaccess folder this is what it contains:
    # BEGIN W3TC Browser Cache
    <IfModule mod_deflate.c>
    <IfModule mod_headers.c>
    Header append Vary User-Agent env=!dont-vary
    </IfModule>
    AddOutputFilterByType DEFLATE text/css text/x-component application/x-javascript application/javascript text/javascript text/x-js text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon application/json
    <IfModule mod_mime.c>
    # DEFLATE by extension
    AddOutputFilter DEFLATE js css htm html xml
    </IfModule>
    </IfModule>
    # END W3TC Browser Cache
    # BEGIN W3TC Page Cache core

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  8. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    I didn't know w3tc would overwrite the htaccess unless you made changes to w3tc. Compare the htaccess file you have to rename after the 500 error with the htaccess file generated later.

    And it seems it works even after the w3tc code is added but then your site randomly pops the error? Do you use cloudflare?

  9. Warrior Instinct MMA
    Member
    Posted 1 year ago #

    When compared he files are totally different and I have never made changes to W3tc. It works fine for a little while once the file is renamed. We do not use cloudflare. I was on the phone with GoDaddy today once again because it has happened 5 times today alone. The feel it may be a plugin so we will disable as many as we can. Thank you so much for all the help.

  10. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    See this post.

    You have a wp-content/cache folder like the person in the post above. I don't so it looks like the minify settings are different. I would try to make the folder non writable as soon as you put it up.

  11. pdobariya
    Member
    Posted 1 year ago #

    Hi Warrior Instinct MMA, your problem is with permalink, so goto admin -> settings -> permalinks
    and click only on save button. thanks

    same problem here http://wordpress.org/support/topic/500-error-server-side-after-copying-files-to-local?replies=1

  12. Frederick Townes
    Member
    Posted 1 year ago #

    Do you have anyother plugins installed? Like Better WP security or any others that write to htaccess?

    To see if its acutally W3TC that rewrites you can when the sites is running fine, when htaccess has been rewritten by W3TC, go to General Settings page and towards bottom you find, "Verify rewrite rules", uncheck that box and save. This will prevent W3TC from writing anything so if it still fails its not W3TC.

  13. Warrior Instinct MMA
    Member
    Posted 1 year ago #

    Thank you to all that helped us through this. After disabling all plugins and reenabling one by one Scurri Free was causing an issue with W3TC. So far all is good (fingers crossed).

Topic Closed

This topic has been closed to new replies.

About this Topic