WordPress.org

Ready to get started?Download WordPress

Forums

Ultimate TinyMCE
Interaction with WooCommerce (25 posts)

  1. daniel1009
    Member
    Posted 1 year ago #

    I'm having an apparent interaction with the woocommerce plugin. The ultimate tinymce plugin works fine in the visual mode but when I try to use the advanced html editor in a page/post or widget (blackstudio tinymce) I get this error:

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/christia/public_html/allthingswd-test.com/wp-content/plugins/ultimate-tinymce/addons/codemagic/codemagic.php:4) in /home/christia/public_html/allthingswd-test.com/wp-content/plugins/woocommerce/woocommerce.php on line 138

    Please help as I this is a great plugin and I want to keep on using it.

    http://wordpress.org/extend/plugins/ultimate-tinymce/

  2. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    Hi Daniel,

    I've seen this error a few times since the update to WP 3.5. Is the WooCommerce plugin rated for WP 3.5?

    I think you might be able to add this bit of code to the top of your woocommerce.php file:

    <?php session_start() ?>
  3. daniel1009
    Member
    Posted 1 year ago #

    Yes woocommerce is rated for WP 3.5. I just got a similar error on a different site that doesn't have woocommerce installed. The site is a markettheme site and this time I was using FF (first time I was using chrome). The error is:

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/christia/public_html/giftexpressionsonline/wp-content/plugins/ultimate-tinymce/addons/codemagic/codemagic.php:4) in /home/christia/public_html/giftexpressionsonline/wp-content/themes/mk4/functions.php on line 10

    Also when this happens, there is no save or cancel buttons in the html editor. Hope this helps.

    I actually just tried this on another site we have that doesn't use woocommerce and another similar error. I host with hostgator. Don't know if there is a connection.

  4. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    Okay, can you look at this file:

    wp-content/themes/mk4/functions.php

    and copy line 10... and paste it here for me to see?

  5. daniel1009
    Member
    Posted 1 year ago #

    All it is is this:

    session_start();

    That's the same as it is in wp-content/plugins/woocommerce/woocommerce.php on line 138.

  6. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    Okay... try adding:

    <?php session_start() ?>

    to the top of the "ultimate-tinymce/addons/codemagic/codemagic.php" file.

    Make sure it's entered on the very top line.

  7. daniel1009
    Member
    Posted 1 year ago #

    I did and still get the same error.

  8. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    Okay.

    Would you mind letting me take a look? I've tried to replicate on my test sites... and everything appears to be working fine.

    I have seen this come up before... and I think it has to do with certain plugins and themes... although I haven't yet concisely identified the problem.

    Perhaps if I can play around with the error... I can find a solution.

    Here is a thread on my forum with a similar issue:
    http://forum.joshlobe.com/showthread.php?tid=1440

    If you don't mind creating me a temp admin level account... I can test it for myself.

    If that's cool... you can use my contact form to send the info securely:
    http://joshlobe.com/contact-me/

  9. daniel1009
    Member
    Posted 1 year ago #

    I'm sorry. I entered the code wrong the first time. I just did it again and it seems to work great now. Thanks for your quick work! I will check this out lon my other sites too and let you know if there are issues.

  10. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    Thanks Daniel.

    I'll continue to look into this from my end. If you notice anything else which appears incorrect... please let me know.

    Thanks again!!

    (Can we mark this as resolved?)

  11. daniel1009
    Member
    Posted 1 year ago #

    It worked in 2 sites but I got this error on the 3rd:

    Warning: Cannot modify header information - headers already sent by (output started at /home/christia/public_html/awdol-test.com/wp-content/plugins/ultimate-tinymce/addons/codemagic/codemagic.php:5) in /home/christia/public_html/awdol-test.com/wp-content/plugins/bigcontact/BigContact.php on line 44

    Line 44 is:

    setcookie('bigcontact-email-flag', time(), time() + 3600, COOKIEPATH, COOKIE_DOMAIN, false);

    Let me know if you want me to set up the temp admin.

  12. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    Not sure about this one. I'm sure if you deactivated the "bigcontact" plugin... it would work.

    Let me do some "googling" real quick.

  13. daniel1009
    Member
    Posted 1 year ago #

    That's correct. If I deactivate it the error goes away.

  14. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    If this is the link to the 'bigcontact' plugin (http://wordpress.org/extend/plugins/bigcontact/)... then it's not yet rated for WP 3.5... and this is probably the issue.

    Is there a reason in particular why you are not updating your WP to 3.5?

  15. daniel1009
    Member
    Posted 1 year ago #

    You're right, it's not rated for 3.5 although it was just updated a few days ago. Maybe that's the issue. I am using WP 3.5 on all these sites.

  16. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    Hmmm... can you contact that author and see if he plans on releasing an update compatible with WP 3.5?

    If he is... we probably want to wait for that.

    If he is not... then we need to look for other solutions.

  17. daniel1009
    Member
    Posted 1 year ago #

    I've posted in his support area. I will let you know his response.

  18. daniel1009
    Member
    Posted 1 year ago #

    Haven't heard back from bigcontact yet but I have a similar issue on another site now that doesn't have bigcontact installed. Now when I get into the advanced html editor, I get this:

    403.php

    and no html code shows up and I have no update or cancel buttons. This time it's happening with a Genesis theme.

  19. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    Okay...

    I'm pretty sure that all 403 and 404 are either hosting permissions issues... or folder permissions issues.

    You might want to check and make sure your plugins directory has proper read/write access.

    Next, I would contact your host. Explain to them the exact nature of your issue... as well as mentioning that 403.php.... and perhaps refer them to this thread.

    I'll be on standby to hear what they say.

  20. daniel1009
    Member
    Posted 1 year ago #

    That could be, because this site is hosted by lunarpages, and most of the rest of my sites where ultimate tinymce works are with Hostgator. Lunarpages may set the permissions differently. I will check into this and let you know.

  21. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    Thank you very much! I'll be eagerly awaiting your reply!

  22. daniel1009
    Member
    Posted 1 year ago #

    Sorry about the wait. I've been swamped. I looked at the plugin folder permissions and Lunarpages and Hostgator are the same = 755. I also called Lunarpages and they checked to see if my IP was somehow being blocked by their firewall and it wasn't. They put in a ticket and will let me know if they find anything on their end.

    I'm also being ignored by the developer of the bigcommerce plugin so I don't know if anything will happen there. Just to keep you updated.

  23. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    Hmmm... well, that isn't very encouraging ;)

    Well, I've been quite swamped myself. But, I promise you I will come back to this very soon and see if we can't figure out a fix together.

  24. daniel1009
    Member
    Posted 1 year ago #

    Hi Josh - Just wanted to let you know that the last update seems to have fixed the interaction with bigcontact. I don't know if it was intended to but wanted to let you know. Thanks for all your work. Still getting the 403.php error on the lunar pages site.

  25. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    Thanks Daniel.

    Yeah, there were a few odd things happening because of a certain code I was using. Getting rid of that seems to have cleared up quite a few issues.

    Regarding the 403 error. I'm almost positive this has to do with your host and the server permissions. I would check with them first... then let me know what they say, please.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.