WordPress.org

Ready to get started?Download WordPress

Forums

Podlove Podcast Publisher
[resolved] Integration (27 posts)

  1. PPRNNews
    Member
    Posted 1 year ago #

    I have about 5,000 podcasts to import. Do you allow for RSS importing, or any form of importing?

    http://wordpress.org/extend/plugins/podlove-podcasting-plugin-for-wordpress/

  2. eteubert
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Sorry for responding so late, I just realized I have to subscribe to forum updates here.

    Right now there is no simple way to import existing podcasts/episodes. However, that's the next big thing we are going to tackle.

    Regards, Eric

  3. srudloff
    Member
    Posted 1 year ago #

    Hi,

    After I installed the current alpha on my WP site (under PHP 5.4), I got an PHP error upon logging into WP Admin: "Call-time pass-by-reference has been removed...". The error concerned line 113 in episode_asset.php.

    After googling the issue (I don't really do coding), I removed the first two instances of '&' in the line as a workaround, which seems to work for now.

    Any other suggestions?

    Regards, Sven

  4. eteubert
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Sven,

    yeah, sorry about that. It's exactly that line and will be fixed in the next patch.
    Thanks for reporting, though :)

  5. jan.jursa
    Member
    Posted 1 year ago #

    Love the plugin. :)

    Is this a bug? When I use quotation marks in the summary part the summary and the info button will not get rendered. Here is an example: episode AKW004 of my new podcast http://abendsinderkreativwirtschaft.de/

    Feature request: since I offer only MP3 download, I don't need the (ugly ;) select dropdown menu. Pure text would be just fine. Could there be a way to ommit the dropdown in such cases?

    Cheers!
    Jan

  6. eteubert
    Member
    Plugin Author

    Posted 1 year ago #

    Not sure about the web player bug, please report again here: https://github.com/gerritvanaaken/podlove-web-player/issues (I don't maintain the player).

    Download buttons: use [podlove-episode-downloads style="buttons"]

  7. supertoub
    Member
    Posted 1 year ago #

    Hi, thanks for the supercool plugin, it will do a lot of work forme. But actual it does not work. I get the following error.
    https://twitter.com/supertoub/status/303547180046745601/photo/1
    The URL for the file is the following:
    http://dj-dave.ch/wp-content/uploads/mixes/test.mp3
    I've disabled all other plugins, but this is not the fault.
    I have no idea, what im doing wrong.
    Thanks for your help.
    Cheers Tobias

  8. eteubert
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Tobias,

    Your configuration looks good.
    When you visit the dashboard (http://dj-dave.ch/wp-admin/admin.php?page=podlove_settings_handle) do you see any warnings about missing tools or something?

  9. supertoub
    Member
    Posted 1 year ago #

    Error looks like this: http://tinypic.com/r/rabxnc/6

  10. eteubert
    Member
    Plugin Author

    Posted 1 year ago #

    I updated the plugin to 1.3.25. Please upgrade, it will add some debug output when you click "update" on the media files, like this: http://cl.ly/image/0L400G0a2r0W

    If it doesn't show up, please refresh the page a couple times to clear the cache.

    Then paste the output here. Thanks!

  11. supertoub
    Member
    Posted 1 year ago #

    --- # Can't reach http://dj-dave.ch/wp-content/uploads/mixes/test.mp3
    --- # Please include this output when you report a bug
    url: http://dj-dave.ch/wp-content/uploads/mixes/test.mp3
    content_type:
    http_code: 406
    header_size: 0
    request_size: 226
    filetime: -1
    ssl_verify_result: 0
    redirect_count: 0
    total_time: 0.003367
    namelookup_time: 0.00273
    connect_time: 0.00278
    pretransfer_time: 0.002817
    size_upload: 0
    size_download: 0
    speed_download: 0
    speed_upload: 0
    download_content_length: 0
    upload_content_length: 0
    starttransfer_time: 0.003354
    redirect_time: 0
    php_open_basedir:
    php_safe_mode:
    php_curl: 1

  12. eteubert
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks, that helped.

    Not sure how tech-savvy you are but let me try to explain:

    To get some info about your file, the plugin has to ask the server about it. Your server, however, answers "406" which means "Not Acceptable". I was also able to find out why the server rejects the request: Our call identifies itself as a call by WordPress. Your server seems to reject all calls made by WordPress. If I remove the part that says "I am WordPress", your server accepts the request.

    I don't know why your server is configured that way but that's the reason. I will not fix this issue for you by essentially lying in my request header. You should fix your server settings.

  13. supertoub
    Member
    Posted 1 year ago #

    .httacces File with the following lines has solved my problems, thanks for the fast support.

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

  14. eteubert
    Member
    Plugin Author

    Posted 1 year ago #

    Glad I could help. Thanks for sharing the solution!

  15. paulnk
    Member
    Posted 1 year ago #

    I created a podcast using MP3 formats and it works well. However, when I created an MP4 it creates another feed and cannot be seen by itunes. Is there a way to combine the formats onto one feed?

  16. eteubert
    Member
    Plugin Author

    Posted 1 year ago #

    There is one feed per asset and iTunes only needs one. As far as I know, iTunes prefers the mp4 feed. There is no way to put more than one asset in one feed. However, all feeds link to each other so clients supporting the "alternate feed" specification do know about all the other feeds.

  17. paulnk
    Member
    Posted 1 year ago #

    I did see the "alternate feed" inside the feed code but it is not being recognized by itunes for some reason.

  18. eteubert
    Member
    Plugin Author

    Posted 1 year ago #

  19. paulnk
    Member
    Posted 1 year ago #

    It only sees the first feed.

  20. eteubert
    Member
    Plugin Author

    Posted 1 year ago #

    Huh? It is supposed to only validate one feed. But if it is valid, it's not your fault or ours but iTunes.

    Have you submitted the m4a feed to iTunes?
    If there is an error with iTunes, which one is it?

  21. paulnk
    Member
    Posted 1 year ago #

    I did submit it to itunes and it gives me an error that the feed seems to have all ready been submitted. It looks like it reads it from the xml file using the "alternate" but it doesn't recognize it for actually showing the files.

  22. paulnk
    Member
    Posted 1 year ago #

    I just reversed the two feed names (the MP3 to the MP4) and iTunes picked up the video file but not the audio file. So both feeds work, but not together.

  23. eteubert
    Member
    Plugin Author

    Posted 1 year ago #

    If that's the case, then that's iTunes' fault.

    However, you're the the first one with this problem. I guess you are doing something wrong, but I don't know what. And I'm pretty sure iTunes doesn't read alternate feeds.

  24. paulnk
    Member
    Posted 1 year ago #

    Is there a way to edit the XML file or make two separate feeds without using "alternate" ?

  25. eteubert
    Member
    Plugin Author

    Posted 1 year ago #

    No, and there is no reason to do so.

  26. paulnk
    Member
    Posted 1 year ago #

    So how can i have mp3 and mp4 on the same feed?

  27. eteubert
    Member
    Plugin Author

    Posted 1 year ago #

    You can't, sorry.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.