WordPress.org

Ready to get started?Download WordPress

Forums

Integrating Simple PHP Gallery (WP 1.5) (24 posts)

  1. staticvision
    Member
    Posted 9 years ago #

    I am rather lost in how I go about integrating the lastest SPG into my wordpress theme which can be found at http://www.staticdream.com -- Any direction in were to start would be appreciated.

    I read the readme and I am still rather lost, thanks!

  2. Ennis
    Member
    Posted 9 years ago #

    mine might help :)
    http://www.thisisennis.com

  3. staticvision
    Member
    Posted 9 years ago #

    I uploaded these files:

    -sp_config.php
    -sp_def_vars.php
    -sp_descriptions.ini
    -sp_getthumb.php
    -sp_helper_functions.php
    -sp_index.php
    -sp_resize.php
    -sp_styles.css

    into my /gallery/ root folder and I am getting this error:
    http://staticdream.com/wordpress/gallery/sp_index.php

  4. Ennis
    Member
    Posted 9 years ago #

    either turn the cache to false in your sp_config or chmod your gallery folder and sub folders to 777

  5. staticvision
    Member
    Posted 9 years ago #

    Thanks for the help Ennis, however, how do I get the gallery to fit into my theme and start using its style sheet?

  6. Ennis
    Member
    Posted 9 years ago #

    well you have to change the header info. and a few other things.

    whats your e-mail?

  7. staticvision
    Member
    Posted 9 years ago #

    I just sent you an e-mail via your contact form. :)

  8. Ennis
    Member
    Posted 9 years ago #

    check your e-mail

  9. staticvision
    Member
    Posted 9 years ago #

    I am updating the files to fit my site, thank you very much for you kind help Ennis! I'll post back with the results.

  10. Ennis
    Member
    Posted 9 years ago #

    lemme know if u run into any problems

  11. Ennis
    Member
    Posted 9 years ago #

    BTW: change the links under the <head> tag where it has the #body { ..... info to your own links! i forgot to do this for you.

  12. dubyah
    Member
    Posted 9 years ago #

    I'm getting close... got the gallery part working, but I'm stuck on integrating into my theme.

    If anyone can help point me in the right direction, I'll write up the full method into an idiots guide for adding a gallery to help others.

    http://www.alukeonlife.com/

  13. dubyah
    Member
    Posted 9 years ago #

    Got simple PHP gallery, working and theme'd on an ISP with Safe Mode enabled.

    If anyone else is struggling with this scenario, drop me an email.

  14. Ennis
    Member
    Posted 9 years ago #

    @ dubyah: i think your the 2nd person i've come across that has had the same idea as myself. Jinsan was the other i believe. Between the 3 of us people shouldn't have many problems integrating simple php. I've been helping the owner of http://www.elitetrackstar.com, where i have their gallery done for them. I created one for parisgv old theme, and i helped her and scott from scottsblog.org integrated the gallery using their current themes. And i've also helped the owner of http://www.staticdream.com. I got a good handle on it now, so i shouldn't have any problem integrating a theme into a gallery.

    So for those looking for help, feel free to contact myself as well.

  15. Ennis
    Member
    Posted 9 years ago #

    edit: scotts url is http://www.scottdot.org/ not scottsblog.org

  16. dubyah
    Member
    Posted 9 years ago #

    The one thing I've not mastered... getting more than one column of images! Any pointers?

  17. dubyah
    Member
    Posted 9 years ago #

    In case anyone else has this single row issue add the following to your wordpress theme style.css:

    div.imgwrapper{
    float:left;
    margin:10px;
    }
    p#credit{
    clear:both;
    }

    and a good guide to installing SPG into wordpress here: http://www.quirm.net/show.php?contentid=11

  18. TH
    Member
    Posted 8 years ago #

    dubyah, that new css doesn't give me any double rows. :(
    Could be all the other bugs and error messages that prevents it from working tho.

  19. TH
    Member
    Posted 8 years ago #

    My attempt at a gallery (on a friend's webpage) is here: http://www.pohildre.com/gallery/
    I don't know if I should use this thread to explain the strange error messages I get when entering the gallery. Or if I should start a new one. Let's try this thread.

    It says:
    "Warning: readdir(): supplied argument is not a valid Directory resource"
    and
    "Invalid argument supplied for foreach()"

    Don't understand why it's doing this to me. I have followed the instructions to the letter, except that the cache folders that were supposed to be chmodded to 755 had to be set to 775 instead, in order for the thumbnails to appear at all. Any help would be most welcome!

  20. TH
    Member
    Posted 8 years ago #

    777 I mean, not 775.

  21. TH
    Member
    Posted 8 years ago #

    Ok. Just realized that enhanced Simple PHP Gallery and Simple PHP Gallery are two different things. Since mine is enhanced and this thread is for the regular one, I have started a fresh thread on my problem here: http://wordpress.org/support/topic/42616
    Sorry about the confusion.

  22. alekone
    Member
    Posted 8 years ago #

    is it possible to actually INCLUDE the gallery inside a wordpress page? like to have a 5 images box on the homepage or something?
    thank you

  23. amory
    Member
    Posted 8 years ago #

    I had posted a thread on SPG's forum as well, but does anyone have an idea as to how I would go about integrating - "wrapping" - the administrative portion of the script into wordpress so that users wouldn't have to create two accounts? Even if that meant that something as simple as if user = logged into wordpress - then login under 'admin' in SPG....

    Any ideas let me know... I don't have the greatest knowledge of PHP but if someone can help get me started I will run with it.

  24. Mezzoforte
    Member
    Posted 8 years ago #

    I have trouble integrating SPG with my wordpress site. I get this error:
    Fatal error: main(): Failed opening required '../wp-blog-header.php' (include_path='.:/usr/local/lib/php') in .../Gallery/sp_index.php on line 3
    What do I do about this?

    And how do I do to place the gallery in a wordpress page?

Topic Closed

This topic has been closed to new replies.

About this Topic