WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Integrating Plogger with the Benevolence theme (5 posts)

  1. KSun
    Member
    Posted 8 years ago #

    Okey, here is my problem, integrating Plogger (www.plogger.org) with the Benevolence theme (http://www.thoughtmechanics.com/templates/). I have followd the guide at Phoenixrealm to the point (and I have managed to intergrate Plogger with the standard WP theme once). But I wanted another theme, and I then I chose Benevolence, but I'm having some problems. If you take a look at the site (http://www.sundal.dk/wp/plogger/index.php) you can see the probleme. I think it's a CSS problem, but now I have used five hours trying to solve the probleme, but I'm not getting anywhere. Then I thougt the probleme might be in the index.php, so heres the code I'm using:

    <?php require('../wp-blog-header.php');
    require("gallery.php"); ?>
    <!DOCTYPE html
    PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <title><?php bloginfo('name'); ?></title>

    <meta http-equiv="Content-Type" content="text/html; charset=<?php

    bloginfo('charset'); ?>" />
    <style type="text/css" media="screen">
    @import url( <?php bloginfo('stylesheet_url'); ?> );
    </style>

    <link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="<?php

    bloginfo('rss2_url'); ?>" />
    <link rel="alternate" type="text/xml" title="RSS .92" href="<?php

    bloginfo('rss_url'); ?>" />
    <link rel="alternate" type="application/atom+xml" title="Atom 0.3"

    href="<?php bloginfo('atom_url'); ?>" />

    <link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
    <?php wp_get_archives('type=monthly&format=link'); ?>
    <?php //comments_popup_script(); // off by default ?>
    <?php wp_head(); ?>
    <?php the_gallery_head(); ?>
    </head>

    <body>

    <div id="wrapper">

    <div id="masthead">
    <div id="blogTitle">
    <a href="<?php bloginfo('url'); ?>" title="<?php bloginfo('name'); ?>"><?php

    bloginfo('name'); ?></a>
    </div>
    </div>

    <div id="insideWrapper">
    <?php get_sidebar(); ?>

    <div id="content">

    <?php if (have_posts()) : ?>

    <?php the_gallery(); ?>

    <?php else : ?>

    <h2 class="center">Fant ingenting</h2>
    <p class="center">Beklager, men du leter etter noe som ikke finnes.</p>
    <?php include (TEMPLATEPATH . "/searchform.php"); ?>

    </div>
    </div>
    </div>

    <?php endif; ?>

    <?php get_footer(); ?>

    I believe the problem has something to do with the DIV-tags. The only thing I can think of is that the Gallery isn't getting inside of the <div id="insideWrapper"> -tag, and that causes the problem.

    Can anyone help me with this issue?

    KSun

  2. samspade32
    Member
    Posted 8 years ago #

    check out this link, http://www.phoenixrealm.com/2005/09/22/integrating-plogger/
    it should tell you how to do it step by step.

  3. KSun
    Member
    Posted 8 years ago #

    I have followed this tutorial step by step, but it just don't work out with the Benevolence theme.

    KSun

  4. frankpereiro
    Member
    Posted 8 years ago #

    It doesn't work with the LUSH theme either...

  5. KSun
    Member
    Posted 8 years ago #

    http://plogger.org/forum/comments.php?DiscussionID=529&page=1#Item_0

    I think I've solved the problem now, the CSS files had some of the same tags, the "wrapper" and the "insideWrapper".

    KSun

Topic Closed

This topic has been closed to new replies.

About this Topic