WordPress.org

Ready to get started?Download WordPress

Forums

Twitter Widget Pro
[resolved] Instructions for Non-Tech ppl for Twitter Authorization Issue (23 posts)

  1. ElizabethsOracle
    Member
    Posted 1 year ago #

    Hi Aaron and All,

    It looks like a number of you have figured out how to resolve the Twitter authorization issue. Would someone please be kind enough to post in non-tech terms? I don't venture into the code section of my WP site, unless I have very clear instructions.

    I see a number of code documents associated with this plugin in the editing interface of the WP Dashboard, but don't know which one to put the "callback" URL into or where. I need clear terms like username and password instead of "consumer key" and "consumer secret". I'm sure there's a logic to using such language, but for non-tech ppl it is confusing.

    Thank you to anyone who can post. Your help is sincerely appreciated.

    Elizabeth
    Ps: Aaron, hope the update goes more smoothly.

    http://wordpress.org/extend/plugins/twitter-widget-pro/

  2. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    Elizabeth:
    Log into the admin section of your site. Under settings (in the left menu) click "Twitter Widget". There should be a direct link to this page in the admin notices that tell you your consumer key isn't set up.

    Once there, you'll see several meta boxes. The top one is labeled "Authenticated Twitter Accounts" and we'll deal with that in a minute. The second is labelled "General Settings" and has two fields labelled "Consumer key" and "Consumer secret". Under those fields are step by step instructions for how to obtain the info to put into those fields. Here they are copy/pasted:

    1. Add a new Twitter application
    2. Fill in Name, Description, Website, and Callback URL (don't leave any blank) with anything you want
    3. Agree to rules, fill out captcha, and submit your application
    4. Copy the Consumer key and Consumer secret into the fields above
    5. Click the Update Options button at the bottom of this page

    Make sure to pay attention to step two and do NOT leave the callback URL field blank. Use your site address (or any other valid URL).

    Once those are saved, look back at the first box labeled "Authenticated Twitter Accounts" and click the "Authorize New Account" button. This will take you to Twitter and ask you to authorize the app that you previously created. Once you've done that, you will be forwarded back to the settings page and you'll see your Twitter account listed in the top meta box. Repeat the instructions in this paragraph to authenticate additional accounts if needed.

  3. ElizabethsOracle
    Member
    Posted 1 year ago #

    Thank you sooooo much Aaron. I am so glad that I did not have to go into the pages w code. I really appreciate your patience and clarity. Please let me know if there is anything I can do to help you/Twitter Widget Pro out.

    All the best,
    Elizabeth

    Ps: easy on those brownies.

  4. Bucephalus_Alexander
    Member
    Posted 1 year ago #

    I have tried this but the Authorize New Account button still isn't taking me to Twitter. I tried changing the callback url but it doesn't change the consumer key or consumer secret.

    Any suggestions? Any way to erase and start over?

  5. ElizabethsOracle
    Member
    Posted 1 year ago #

    Hi,

    Definitely try the erase idea. I erased the consumer key and secret, hit save at the bottom of the page and then the WP page changed and took me to Twitter. It s like it needed to start from scratch. I hope that helps you. Good luck.

  6. Corinnekc
    Member
    Posted 1 year ago #

    Good Morning Aaron:
    First of all, english is not my mother language... I'll try to understand and to make me understand the best I can...
    I am reading what you wrote to Elizabeth and i got lost with the steps in bold:

    Log into the admin section of your site. Under settings (in the left menu) click "Twitter Widget". There should be a direct link to this page in the admin notices that tell you your consumer key isn't set up.

    Once there, you'll see several meta boxes. The top one is labeled "Authenticated Twitter Accounts" and we'll deal with that in a minute. The second is labelled "General Settings" and has two fields labelled "Consumer key" and "Consumer secret". Under those fields are step by step instructions for how to obtain the info to put into those fields. Here they are copy/pasted:

    Add a new Twitter application
    Fill in Name, Description, Website, and Callback URL (don't leave any blank) with anything you want
    Agree to rules, fill out captcha, and submit your application
    Copy the Consumer key and Consumer secret into the fields above
    Click the Update Options button at the bottom of this page: I connot see an update options but a bottom called "create may access token:
    Make sure to pay attention to step two and do NOT leave the callback URL field blank. Use your site address (or any other valid URL). OK

    Once those are saved, look back at the first box labeled "Authenticated Twitter Accounts" (where: in the application for or in my blog?)and click the "Authorize New Account" button (again: where?). This will take you to Twitter and ask you to authorize the app that you previously created. Once you've done that, you will be forwarded back to the settings page and you'll see your Twitter account listed in the top meta box. Repeat the instructions in this paragraph to authenticate additional accounts if needed.

  7. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    Corinnekc: The "update options" button is at the bottom of the settings page where you pasted your consumer key.

    To find the box titled "Authenticated Twitter Accounts", just read the beginning of the instructions again (the first paragraph or two) which mentions it being just above the box where you put your consumer keys.

  8. yourlive
    Member
    Posted 1 year ago #

    I also had a problem with the authorize new account button, it gave a time out error. I solved it by copying the hyperlink behind the button and paste in directly in the browser adress window, then it works fine.

  9. kjguch
    Member
    Posted 1 year ago #

    I'm afraid this doesn't work for me. Steps 1 to 5 work perfectly, but then I get to the 'Authorize New Account' button and that doesn't do anything.

    Tried to erase all settings, tried a new key+secret, but none of it works, I simply cannot get my account authorized.

  10. Aaron Friedman
    Member
    Posted 1 year ago #

    Hey Aaron.

    I have been reading through a few of your support threads to see if there is a fix for my problem, but haven't found one.

    I just updated my plugin to the latest version today and have gone through all the initial setup steps with no issues. Where I am having a problem, is on the actual authorization process. When I click on the blue 'Authorize New Account' button in WP, I am taken to the Twitter 'Authorize App' page. When I click 'Authorize App', I am redirected to a plain page that displays the message, 'You do not have sufficient permissions to access this page.'

    I've tried numerous times to resolve this, but can' catch a break. Please advise, as to what I need to do?

    Thank you,
    Aaron Friedman

  11. swanksalot
    Member
    Posted 1 year ago #

    I am having the exact problem as Aaron Friedman describes:

    When I click ‘Authorize App’, I am redirected to a plain page that displays the message, ‘you do not have sufficient permissions to access this page.’

    ---

    edit
    update, I noticed the URL included wp-admin/admin.php?page=TweetOldPosttners.net/
    instead of twitterWidgetPro. I deactivated the plugin called “Tweet Old Posts”, and was able to successfully activate my Twitter acct. Not sure why Tweet Old Posts was interfering, but perhaps looking closely at the URL generated when you click “Authorize Account” might be useful.

  12. Aaron Friedman
    Member
    Posted 1 year ago #

    Swanksalot, good catch sir!

    I am also running that same plugin (Tweet Old Posts), and as soon as I deactivated it, Twitter Widget Pro authorized and is working good now.

    This I would say is a confirmed bug for all users that are trying to use Tweet Old Posts with Twitter Widget Pro. Aaron Campbell will need to peel back the layers on this one and see what's causing the issue.

    Thanks!

  13. kjguch
    Member
    Posted 1 year ago #

    Still no luck here. Updated to 2.5.3. Got yet another somsumer key & secret, but when I try to authorize the new account, I get the message that it "Could not recognize the response from Twitter". Tried deactivating all other plugins that have anything to do with Twitter, but no luck there.

  14. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    kjguch: Please start a new support thread. This one has been resolved and your problem is clearly not the same as the original poster.

  15. PanamaMark
    Member
    Posted 1 year ago #

    Problem solved!

  16. MarcoBe
    Member
    Posted 1 year ago #

    Auth issue solved leaving not the callback URL field blank.
    Thanks!!!

  17. Bucephalus_Alexander
    Member
    Posted 1 year ago #

    I have tried this many, many times. I have deleted everything (except the plugin) and started from scratch over and over, but clicking "Authorize New Account" does nothing for me. Ideas???

  18. mccants
    Member
    Posted 1 year ago #

    I am not a developer and am trying to update the widget. What am I supposed to put in the fields, Name, Description, Website, and Callback URL , my twitter account information? Please help/

  19. jknouse
    Member
    Posted 1 year ago #

    Hi. Having a similar issue, but when I click the 'authorize Twitter" button, and then click to authorize from Twitter page, I am simply redirected back to my WordPress login page. I login, and nothing has changed. The authorization did not take.

    I am sure I have done everything correctly, ie, filled out all fields, etc.

    Any ideas?

  20. snig27
    Member
    Posted 1 year ago #

    I have a similar problem except I'm taken back to a blank page after authorization and the authorization clearly has not taken.

    No idea to to resolve this. I have created a new app and followed every step I think.

    It used to work perfectly and then simply stopped working.

  21. lorenzodow
    Member
    Posted 1 year ago #

    like mccants, I'm a bit confused about why I'm having to create a developer profile to use this plugin now that I updated it this morning. this plugin was working fine before as it was.

  22. lorenzodow
    Member
    Posted 1 year ago #

    since this was marked as resolved, I asked my question in a new thread.
    http://wordpress.org/support/topic/why-do-i-need-to-authorize-my-twitter-account?replies=1

  23. CraigSenior
    Member
    Posted 1 year ago #

    I had the same problem. In my case, the interference was with the plugin Twitter Counter. I deactivated it, successfully authorized the account, and reactivated it.

    First try deactivating plugins related to Twitter.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic