WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] Instead a form, I get this: [contact-form-7 404 "Not Found"] (8 posts)

  1. ellenshershow
    Member
    Posted 1 year ago #

    I just installed contact form 7, and I am pasting the short code from my wordpress admin into a custom page.

    Here is the code I am pasting in:

    [contact-form-7 id="180" title="Contact form 1"]

    Instead of showing up as a form, I get this:

    [contact-form-7 404 "Not Found"]

    I have Contact Form 7 3.3 installed and wordpress 3.4

    Initially, I had 'Contact Form 7 - Customfield in mail' installed, but I de-activated that too see if that was the problem and nothing changed.

    I have also tried pasting this code into HTML, but had no luck there either....

    Any ideas on what might be causing this? How can I correct it?

    http://wordpress.org/extend/plugins/contact-form-7/

  2. ellenshershow
    Member
    Posted 1 year ago #

    So...I downgraded to 3.2 and had the same problem. Then I downgraded to 3.1. Now the form is showing up, but in my tests no emails are coming through.

    Help!

    Here is the link where I have it set up:

    http://www.jadorelechien.com/museum_collection

  3. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

  4. ellenshershow
    Member
    Posted 1 year ago #

    Takayuki,

    Yes, I saw that link already. It says. "The code [contact-form-7 404 "Not Found"] is a sign that the contact form specified by the shortcode (described above) couldn’t be found. Make sure you are using the correct shortcode.'

    I do not know how I could be using the wrong code, as I am following the directions exactly.
    IN my wordpress admin, I am going to contact>edit, then copying the code in the brown highlight. I am then pasting this code directly onto my wordpress page.

    So you see, there is no chance for anything at all to be wrong.

    As I said above, once I downgraded to 3.1, the form did show up, but this is not doing much good as none of my test emails are getting through to me.

    Can you help me to correct this?

    Thank you

  5. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    Please tell us the correct code that you have put or check the code again. The link shows that the ID of the contact form is 187, not 180 as you wrote in your first comment.

  6. oblax
    Member
    Posted 1 year ago #

    Thank you for the great plugin Takayuki.

    In my case after upgrading to v3.3 when I click the link http://www.mydomain.com/wp-admin/admin.php?page=wpcf7 it redirects me to the frontend "page not found" page.

  7. oblax
    Member
    Posted 1 year ago #

    In addition, I test using the previous WP version prior to 3.4.2 and CF7 version prior to 3.3 is working with no problem.

    It seems that CF7 stop working after WP upgrade.

  8. ellenshershow
    Member
    Posted 1 year ago #

    Hello,

    I let the bread bake in the night kitchen and now it is working! Perhaps it needed a few hours to work?

    I don't know, in any case, this morning I upgraded from 3.1 to 3.3, and the form stayed intact. I then sent myself a test email and received it immediately.

    Thank you so much for all your time and help, I am one happy girl! If anyone lives in the bay area and has a dog, I can offer you a great discount!

    Ellen

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic