WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
[resolved] Instant Payment Notifications sent to the following URL(s) are failing: (3 posts)

  1. stevebliss
    Member
    Posted 8 months ago #

    My client is getting the following error email from PayPal. We haven't changed any of the settings and it all worked fine in the past.

    Please check your server that handles PayPal Instant Payment Notifications (IPN). Instant Payment Notifications sent to the following URL(s) are failing:

    http://www.mosimann.com/index.php?wpsc_action=gateway_notification&gateway=wpsc_merchant_paypal_express

    If you do not recognize this URL, you may be using a service provider that is using IPN on your behalf. Please contact your service provider with the above information. If this problem continues, IPNs may be disabled for your account.

    Thank you for your prompt attention to this issue.

    http://wordpress.org/plugins/wp-e-commerce/

  2. CowboyFrank
    Member
    Posted 8 months ago #

    When I suddenly stopped getting notifications, I went to PayPal and changed the URL to just the base URL of my website. I still got an error email from PayPal, but the notifications started coming in again.

  3. Edward
    Member
    Plugin Author

    Posted 8 months ago #

    You should not need to enter anything in PayPal for the IPN to work properly. In some rare instances for some unknown reason due to themes that alter permlinks you may need to enter the location of your transaction results URL

    Several things you can try.

    1. reset your permalinks
    Go to Settings > Permalinks click "Save Changes"

    2. Be sure your server is not blocking IPN due to firewall settings
    The following link will show you all the IPs that require access to your server
    https://ppmts.custhelp.com/app/answers/detail/a_id/92

    Regards
    Edward

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.