WordPress.org

Ready to get started?Download WordPress

Forums

Install.php problem - "You have chosen to open... instal.php" !? (10 posts)

  1. nhtahoe
    Member
    Posted 7 years ago #

    I've been trying to get wordpress installed on my server, but I get a broken page when it tries to go to http://www.***********.com/wordpress/wp-admin/install.php?step=2. In Firefox, it asks if I want to download install.php, and in IE it just gives me a "This page cannot be displayed"

    When I change one of the settings in wp-config to a wrong setting for my mysql database, i just get a "you have done something wrong" page from wordpress. If my details are right, It crashes. Any ideas?

    Thanks!

  2. nhtahoe
    Member
    Posted 7 years ago #

    BUMP... ANYONE!?

  3. Doodlebee
    Member
    Posted 7 years ago #

    Is it asking you to download the PHP file instead of running it? Like you get a popup asking you where you want to save or open the file? That kind of thing?

    If so, your server isn't running PHP properly and you need to contact your host.

  4. nhtahoe
    Member
    Posted 7 years ago #

    Thanks for the suggestion. I had support over at rackspace upgrade php to the latest 5.2.1. Still getting the error... Check it out here:
    http://www.youdeparted.com/wordpress/wp-admin/install.php?step=1

  5. Doodlebee
    Member
    Posted 7 years ago #

    Um...I'm getting your installation page just fine.

    In fact, I think a moderator should come along and remove that link pretty quickly - it's in the middle of the installation process.

    But I'm seeing the page where you need to enter your email and weblog title just fine. (I'm not clicking the continue button to see what happens, I don't want to screw anything up.) Is that what you're seeing?

  6. nhtahoe
    Member
    Posted 7 years ago #

    Yes, getting to that page works just fine, but when I enter a title and email address and click "continue to second step" that it tries to download the install.php file instead of execute it.

  7. Doodlebee
    Member
    Posted 7 years ago #

    Do you mind if I give it a shot? If it works, you can log in and change everything to whatever you want it to be.

  8. nhtahoe
    Member
    Posted 7 years ago #

    Thanks for the help doodlebee. You are welcome to try it.

  9. Doodlebee
    Member
    Posted 7 years ago #

    Okay - here's what happened with me:

    I put in a title and my email address and clicked "continue". It took me to a blank page.

    I've seen this before, but to be sure, I went to the wordpress site (http://www.youdeparted.com/wordpress) to see if it was now visible. If so, I could have told you how to log into the admin area.

    But it's not visible, it's asking me to install WordPress.

    My guess is that you've gotten some file or another corrupted - most likely while you were uploading the files to your server. I would recommend downloading a fresh copy of the files and starting from scratch. When I run into issues like this, instead of uploading everything in one batch, I'll upload my wp-admin directory first, then the wp-content directory - and so on. When this happens to me, it's usually because the server times out on me and corrupts a file, so if you upload in smaller chunks it helps relieve the issues.

    Give that a shot and see if it helps.

  10. nhtahoe
    Member
    Posted 7 years ago #

    Thanks again for your help! I used your suggestions when interacting with the Rackspace people and they managed to get my server config working properly. Apparently there was a "segmentation fault issue" on the server which required them to do a bunch of fixing.

Topic Closed

This topic has been closed to new replies.

About this Topic