WordPress.org

Ready to get started?Download WordPress

Forums

/install.php not loading (13 posts)

  1. jonathanholt
    Member
    Posted 2 years ago #

    I've installed WP like 12 times, and I'm doing everything the same. Have tried manually uploading config.php / also deleted and setup up the config through the browser and it always gets back to domain.com/wp-admin/install.php with a blank white screen... Whats the deal?

    Finding more and more issues with these newer versions!

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Try re-uploading all files & folders from a fresh download of WordPress.

  3. jonathanholt
    Member
    Posted 2 years ago #

    i did that. even tried using a install.php from another website thats already live. still nothing....

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Perhaps it's a server issue. Have you tried contacting the hosts?

  5. jonathanholt
    Member
    Posted 2 years ago #

    talking to them now. of course they are saying everything is up and running correctly. Also I have a bunch of other wp websites on the same host, all working fine. When I open install.php in Dreamweaver it looks a little weird. I don't know anything about coding... But why would it be saying this?

    [Code moderated as per the Forum Rules. Please use the pastebin]

    As the first bit of code which reads this in the preview on dreamweaver -

    Error: PHP is not running

    WordPress requires that your web server is running PHP. Your server does not have PHP installed, or PHP is turned off.

    Again this is in DREAMWEAVER and nothing shows at all on the actual live URL

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    You can't run any PHP scripts without running your own web server.

  7. jonathanholt
    Member
    Posted 2 years ago #

    What do you mean? I have like 10 other wp sites on this same ftp with the databases all hosted there as well...

  8. esmi
    Forum Moderator
    Posted 2 years ago #

    You questioned the "PHP not running" message when you tried to open install.php on your own computer - not on a web server. The answer is - you need a web server with PHP to run install.php. You cannot run it in DreamWeaver on your own computer.

  9. frankietalks
    Member
    Posted 2 years ago #

    I got the same problem of "PHP not running"... would like someone to explain in more details for "... you need a web server with PHP to run install.php...".

    Thanks.

  10. Tim S
    Member
    Posted 2 years ago #

    Hi frankietalks,

    One of the requirements to run WordPress is to have PHP installed on the server. Most web servers come with this capability, however, if you are creating a local installation on your computer, you'll need to set up PHP to use it. There's plenty of XAMPP, MAMPP, LAMPP installation to set up a development server.

    Are you getting the error on your local computer or on your web server?

  11. frankietalks
    Member
    Posted 2 years ago #

    Hi Tim S,

    Thanks for your kind reply first.

    I am deploying WordPress in a web server that comes with a free web hosting provider, i.e. byethost. I tried to follow the steps but it failed when I pointed my Firefox browser to the URL identified by Filezilla. One thing I noticed is that when I created a new database with the hosting service, I was never asked to create username and password...

    Still looking for ways to troubleshoot this.

    Anyway, thanks again to Tim S.

  12. Tim S
    Member
    Posted 2 years ago #

    Hi frankietalks,

    You may need to contact your host. You'll need a database username and password to successfully connect to the database. This is imperative as WordPress operates from a database. As for the URL in FileZilla, I'm not sure what you mean? Have you pointed your domain to the hosting account? If so, can you provide us a link? When you say it failed, can you explain this further?

  13. frankietalks
    Member
    Posted 2 years ago #

    Hi Tim S,

    Sorry that I am not good at computing so my description on the issue would be confusing... I supposed I did point my domain to the hosting account by updating the server names in Domain Manager.

    Finishing uploading via FileZilla and editing WP-CONFIG.PHP, I "copied" the URL as below to my Firefox browser:

    ftp://b14_9767627@ftp.byethost14.com/motorbikesmith.info/htdocs/wp-admin/install.php

    (This link looks very strange but I don't have any slightest idea of what and how it can be corrected...)

    ... then FF showed the following content:

    Error: PHP is not running

    WordPress requires that your web server is running PHP. Your server does not have PHP installed, or PHP is turned off.
    >
    WordPress
    get_var("SHOW TABLES LIKE '$wpdb->users'") != null ); // Ensure that Blogs appear in search engines by default $blog_public = 1; if ( ! empty( $_POST ) ) $blog_public = isset( $_POST['blog_public'] ); $weblog_title = isset( $_POST['weblog_title'] ) ? trim( stripslashes( $_POST['weblog_title'] ) ) : ''; $user_name = isset($_POST['user_name']) ? trim( stripslashes( $_POST['user_name'] ) ) : 'admin'; $admin_password = isset($_POST['admin_password']) ? trim( stripslashes( $_POST['admin_password'] ) ) : ''; $admin_email = isset( $_POST['admin_email'] ) ? trim( stripslashes( $_POST['admin_email'] ) ) : ''; if ( ! is_null( $error ) ) { ?>

    ERROR: %s' ), $error ); ?>

    See if you could give me some advice on this. Thanks again.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags