WordPress.org

Ready to get started?Download WordPress

Forums

install.php Error establishing a database connection (7 posts)

  1. kboyd1978
    Member
    Posted 8 years ago #

    Hello,
    I seem to be having a problem with installing WordPress. I have the database set up, I have the correct username and password, and I have the correct hostname. How do I tell if the database server is running (that is a possible problem)? Are there any other possible problems?
    Thanks in advance for the help.

  2. Who is your hosting provider?

  3. kboyd1978
    Member
    Posted 8 years ago #

    Gate.com

  4. Apparently, if you have set up a MySQL database, the specific information for the wp-config.php file can be found in "the MySQL section of your Gate.com Control Panel". And, if you have not setup a MySQL database, it can be setup there. Hosting-specific problems, such as, "Is my database server running?" will have to be directed to your hosting provider's support department.

    Also, please make sure that you are editing the proper fields in the wp-config.php file.

    http://codex.wordpress.org/Editing_wp-config.php

    http://codex.wordpress.org/Installing_WordPress#Detailed_Instructions

  5. kboyd1978
    Member
    Posted 8 years ago #

    The databse is set up, that's were I got the info for the "wp-config.php" file. Looks like it's back to my hosting company to find out if the server is running.
    Thanks anyway for the help,

  6. osx001
    Member
    Posted 8 years ago #

    I am a newbie to wp and mysql - but, here is my $0.02 worth. I was having the same problem and noticed that my host provider had ALMOST identical names for the db and the db user - like the db was "db123242" and the db user was "dbo123242."

    In my excitement to get it going, I didn't even notice the "o" in the db user as I had done a CnP.

  7. tribalt
    Member
    Posted 8 years ago #

    I setup my wp-config.php file saved it. Created my database in mysql. checked it to make sure what I had in my wp-config.pfp file and the database I created matched all is good. I put the address in the browser and click enter to get password and username are alright but Can’t select database as stated some webhost use prefixs mine does my database name is contentg_wordpress can someone please show me the light at the end of the tunnel i'm at wits end.

    It ask if my database was created. I know it was cause i've even deleted it and recreated it.
    Thanks,

    Jason.S

Topic Closed

This topic has been closed to new replies.

About this Topic