WordPress.org

Ready to get started?Download WordPress

Forums

Installing WP 3.3.2 on IIS (WebCentral) problems (27 posts)

  1. ShaneJenkins
    Member
    Posted 2 years ago #

    Hi all,

    I have completed numerous WordPress installs on Unix without a problem but never IIS.

    I have a client using WebCentral for hosting and IIS is all they offer.

    I had to have PHP and MYSQL added to the account, I downloaded the latest WP install files and all was running smoothly until WP tried to create the wp-config.php file (had to do it manually), and I tried to set up a custom structure for permalinks (and got the "If your .htaccess file were writable, we could d..." message) and I tried to automatically update a plugin (I got this message "Unable to locate WordPress Content directory (wp-content).") and I tried to add a new plug in (same as previous message).

    For me, all problems pointed at permissions errors however I had WebCentral check and when they looked exactly as suggested in the documentation, I was told to ask on the WordPress forum.

    Does anyone have any suggestions? I want to exhaust all avenues before telling the client he needs to change hosting company.

    I have added a phpinfo call in the footer if it helps:
    http://svc047.wic028v.server-web.com/

    Thanks

  2. heathvogt
    Member
    Posted 2 years ago #

    Howdy,

    I've been trying for 3 hours just to get WordPress installed on a Web Central server with no luck. I waited on the phone for an hour and they said they had to update the php database to 5.1 which they did and its still not working.

    I put all the correct database details in the wp-config.php and hit go and it just times out.

    Did you have any problems with this?

    Thanks

  3. ShaneJenkins
    Member
    Posted 2 years ago #

    Ah it looks like you have had as much joy with their support staff and massive waits in queue as I have.

    There were two things that Web Central had to do to get WordPress to a position where it could be installed.

    1. Upgrade their standard PHP
    2. Tell me that I needed to add on MySQL

    Have you added MySQL?

    After that I added the

    * DB name
    * DB user
    * DB password
    * DB host

    And it installed and it does work, but it's not something I want to leave with a client when there are so many error messages.

    If you get yours working let me know if you get the same errors.

  4. heathvogt
    Member
    Posted 2 years ago #

    Yep! Have already had Database and MySQL added to the account.

    Just curious did you change the DB Host? or leave it as localhost

    This is my config setup

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', '');

    /** MySQL database username */
    define('DB_USER', '');

    /** MySQL database password */
    define('DB_PASSWORD', '');

    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

  5. heathvogt
    Member
    Posted 2 years ago #

    I also setup the phpinfo file to check and pretty sure this should be fine.
    http://www.arketype.com.au/phpinfo.php

  6. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    Heath, you should immediately change your password now and ask for the above post with that data removed. Never share this data.

  7. ShaneJenkins
    Member
    Posted 2 years ago #

    You DB_NAME looks right.

    Dont use local host for the DB_HOST, I have bne2-0001my.server-sql.com

    And the DB_user is the username that ends with _dbo, so for you it's probably vs50261_1_dbo.

    Like Swanson says, go ahead and change your password.

    Let me know how you get on.

  8. heathvogt
    Member
    Posted 2 years ago #

    Got it working now, just haven't done anything to it yet, so fingers crossed it smooth sailing with installing plugins etc.

    *Swanson: thanks have changed that my bad, just a bit desperate to fix this issue.

  9. ShaneJenkins
    Member
    Posted 2 years ago #

    Did you change the username to vs50261_1_dbo?

    You have two users they are the same except one had _dbo at the end and it's the only one to access the db with

  10. heathvogt
    Member
    Posted 2 years ago #

    yep! changed the username to have the _dbo and DB HOST to bne2-0001my.server-sql.com like your setup.

  11. ShaneJenkins
    Member
    Posted 2 years ago #

    Try adding or updating a plugin and let me know if you get messages.

    Good luck

  12. heathvogt
    Member
    Posted 2 years ago #

    Yep! just tried then.. same as you
    Unable to locate WordPress Content directory (wp-content).

  13. ShaneJenkins
    Member
    Posted 2 years ago #

    Heath, I have contacted the support crew at WebCentral, they have an open ticket that it appears someone is looking at, hopefully we'll have some answers soon.

  14. heathvogt
    Member
    Posted 2 years ago #

    O.K cool! thanks for the update Shane. After my 4 hours of frustration getting WP installed I dropped the project for a few days but will be back onto it next week.

    Thanks Heath

  15. heathvogt
    Member
    Posted 2 years ago #

    Hi Shane,

    Just curious if you had any luck fixing your permissions error messages?

    Thanks
    Heath

  16. ben_r
    Member
    Posted 2 years ago #

    Hi guys,

    Has anybody had luck with web central?

    I'm another user struggling to get wordpress going. I had the same issues with old versions of php and mysql installed on the server, but got these resolve by their helpdesk. I also had to generate the config file myself.

    I tried setting up the "pretty" permalinks, but this looks like an IIS issue as it does not support mod_rewrite. If you look at http://codex.wordpress.org/Using_Permalinks to get it to work on IIS 6.0, you need to install something on IIS which I don't like my chances of getting web central to do. So I think I'm stuck with the /index.php on all my pages.

    I'm now having similar permission issues. First the theme I have is using timthumb to generate dynamic thumbnails, which are failing. Then I just tried to upload a file to the media library and got: "test.jpg" has failed to upload due to an error. The site runs perfectly on my own linux hosting, I've just been pulling my hair out trying to migrate it to my web central as this is who my client uses.

    Ben.

  17. heathvogt
    Member
    Posted 2 years ago #

    Hi Ben,

    Yeah! I gave up in the end as I got through the setup and then had issues just simply uploading some media files. Kept saying that the folder didn't have permission to create an uploads folder etc. I changed the permissions to 755 etc but still had the same problems.

    Heath

  18. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    I changed the permissions to 755

    Such permissions apply to Apache. not IIS.

  19. heathvogt
    Member
    Posted 2 years ago #

    Ok, so updating the folder permissions will not work on IIS?. I normally don't need to toch this when setting up WordPress on other hosting environments.

    The Web Central configuration is very problematic so far.

  20. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    IIS ignores such, it uses a different set of permissions. A good IIS host will be able to assist you in setting the web (etc.) permissions required for WP (many provide you with such tools).

  21. heathvogt
    Member
    Posted 2 years ago #

    OK thanks for that. I don't usually use Web Central but having to work through it as the client has their hosting with them.

    I'm on hold now (25min) trying to get some support.

  22. ben_r
    Member
    Posted 2 years ago #

    Web Central fixed the uploads for me by adding modify/write permissions on the uploads folder. I'm still having other issues as I have plugins which also require write access to folders. I'm awaiting a response to see if I have any ability to change permissions myself or if I need to submit a request for every time I need something changed.

  23. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    You need to verify that plugins use only PHP and not Apache code. If they are calling strings to an Apache server they will fail. PHP runs fine under IIS (and has for years). Plugins running under IIS that make such calls will 'bork' your site.

  24. KLL1402
    Member
    Posted 1 year ago #

    Did you have any luck with the install in the end? I am about to attempt it. I have created a request to the Tech Support team but am yet to hear back from them. Unfortunatly we have signed up with Webcentral for the next 2 years so I have to make this work. Would love your feedback. Thanks

  25. heathvogt
    Member
    Posted 1 year ago #

    Not really, I got it all working and as reasonably happy but this had taken probably 4 hours of messing around. Then when I went to add the permalinks feature they couldn't initiate the mod_rewrite feature within the server environment which was disappointing.

    Moved to Digital Pacific and had it all up and running within an hour.

    If you need to stay with them just ask them to put you on a server that can run WordPress and allow the Mod Re_Write.

    Thanks

  26. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    This link may help sort out permalink issues on IIS7 (follow the included links also)

  27. ben_r
    Member
    Posted 1 year ago #

    I got most things working apart from the permalinks. Having to request any folder permissions changes was a pain for troubleshooting problems.

    Best tip I can give is submit the ticket then ring them quoting the ticket number. While you wait on hold for a long time I got most things fixed up over the phone. I had tickets sitting unanswered for days otherwise.

    Goodluck!

Topic Closed

This topic has been closed to new replies.

About this Topic