WordPress.org

Ready to get started?Download WordPress

Forums

Installing WP 2.7.1 on localhost (11 posts)

  1. J_25
    Member
    Posted 5 years ago #

    Hello!

    I just downloaded the latest version of wp and I can't use it. I have a Win 2003 server, the latest version of php installed and also the latest version of mysql. Still, when I can't access the blog's home page. The path would be http://localhost:8080/wp_test/ Now when I want to see the default post created the wp when installing it redirects me to http://localhost:8080/wp_test/?p=1 which displays the list of files I have on the wp's root directory (like when enabling the directory browsing). It doesn't matter if I point the browser to : http://localhost:8080/wp_test/index.php?p=1 , nothing changes.

    From what I've from other "related" threads here this could be because of the .htaccess file and the permalink structure. Well, inside the zip archive I downloaded there was no .htaccess file, so I tried to change the permalinks. When I did, at the bottom of the page there was a snippet that wp said I could use to update the .htaccess file. Well, because I don't have one, like I already said, I copy and pasted that snippet inside my default httpd.conf located in the Apache's directory. Restarted the Apache server. Still no change. Then, I read that about installing wp on different folders...this is funny :) because after I changed the first url to point to the index.php file everything has been messed up and I had to reinstall (oh my!) because I couldn't access the options page under wp admin to change that option to it's default. I was always sent to the login page. LAME!!!

    Anyway, this is serious because I just took a project, create a WP theme and I really need a working wp blog on my pc. Can anyone tell me what I have to do so I can actually see/access this blog? Please? help a sista out! :)

    Thank you in advance

  2. ClaytonJames
    Member
    Posted 5 years ago #

    I just downloaded the latest version of wp and I can't use it...

    I am 99.99% sure your issues are one of server configuration and not WordPress problems.

    Did you add the .php handler to http.conf (AddType application/x-httpd-php .php) so apache will recognize the file extension? If so, do you get output when placing a phpinfo (<? phpinfo(); ?>) test page in the site directory?

    An .htaccess file can be manually created with notepad and placed wherever you want it.

    Have you read the information on permalinks and their function (or lack thereof) in a windows environment, and how mod_rewrite affects that function? Did you bind Apache to port 8080 because IIS is using port 80? Or is IIS disabled?

    Anyway, this is serious because I just took a project, create a WP theme and I really need a working wp blog on my pc

    There is nothing wrong with the WordPress package. It is a server administration issue. If you only want a local development server, perhaps installation of a pre-configured WAMP utility would suit the job better? Less of a hassle in most cases just for theme development.

    http://codex.wordpress.org/WordPress_Installation_Techniques#Installing_WordPress_Locally

    http://www.wampserver.com/en/

    http://www.apachefriends.org/en/xampp.html

  3. figaro
    Member
    Posted 5 years ago #

    See this video for how to get a working copy of WP on your windows machine using XAMPP.

    http://educhalk.org/blog/?p=154

  4. J_25
    Member
    Posted 5 years ago #

    #1. the problem is not with my server. The problem is with WP because the guys developing WP are, of course, working under a Linux environment(This is why they think that using mod rewrite is so convenient) because if they were working under a Win environment they would've noticed how "easy" is to use an .htaccess file (you know you can't create a .htaccess file under Windows, right?) especially for a noob.
    #2. I've tried to make it work in so many ways that I don't even know what I've even changed...so yes, I've tried everything.
    #3. What made it work was that I visited some of the files under /wp-includes and manually reset every line that required wp_rewrite so it won't use it by default and then update manually every link. that made it work, I guess, 'cause now I am able to see the blog and actually browse it. This would be enough for me because I only need it to work so I can finish my theme.
    #4. please do not think I have something against the guys working on WP because I have nothing. I can't have anything but appreciation for their work. Only that they should think a little more about (noob) win users too ;)

    I really appreciate your quick and thorough reply. To be honest I didn't actually expected any replies at all, but I'm glad to see there are some men out there that actually care about a community.

    Thanks again! :)

    Julia

  5. J_25
    Member
    Posted 5 years ago #

    I don't have XAMPP. And I don't want to have it installed, thank you :)

  6. J_25
    Member
    Posted 5 years ago #

    I was just thinking...if the guys behind WP could just add an option, let's say, Don't use mod rewrite or .htaccess file in the wp-admin panel?

    this way the blog would just be displayed as it was before adding this option? wouldn't this be a nice to have feature?

    At least, if there was an option like that it would've saved me a lot of editing...

    :)

    Julia

  7. ClaytonJames
    Member
    Posted 5 years ago #

    To be honest I didn't actually expected any replies at all

    It probably wouldn't have happened, not being a WordPress issue, but I'm the sort who sometimes floors it for yellow lights, and figaro has some very good tutorials, so...

    That being said, I have installed MySQL, Apache, and PHP manually on several Windows environments without any incident. Perhaps a quick review of the process might reveal a misguided or omitted step for you.

    Best wishes.

  8. J_25
    Member
    Posted 5 years ago #

    probably so :)
    but I don't have the time now to go through this process once again :( Time is money...

    But I will, as soon as I have some spare time (though, I don't know how would this help me with using an .htaccess file anyway ?)

    Long time ago I had WP installed and working like a charm, I had XAMPP too, and there were no issues, but those version of WP didn't use a mod rewrite by default...

    what can I say... I'll try to read more about WP and how to install it successfully, but in the near future. Right now, I'm happy I have something I can work on :)

    Best wishes to you too :)

    Julia

  9. figaro
    Member
    Posted 5 years ago #

    I don't have XAMPP. And I don't want to have it installed, thank you :)

    No problem, but for future reference and for others reading this thread, XAMPP is a free download and you don't have to install it...you simply download it, unarchive it, load WP, and run it...takes all of 10 minutes.

  10. J_25
    Member
    Posted 5 years ago #

    I meant no offense there, figaro. Please accept my apologies :)

    I appreciated your reply, only that I didn't express it right. sorry

  11. figaro
    Member
    Posted 5 years ago #

    No offense taken...just clarifying for others who may read the thread and may want to use XAMPP.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.