WordPress.org

Ready to get started?Download WordPress

Forums

Installing WordPress with 1and1 issue - Can't view the site (13 posts)

  1. onespriggan
    Member
    Posted 2 years ago #

    Hello all,

    This is my first time installing WordPress and it appeared to install fine. I can log in to the WordPress dashboard and make changes to themes and everything else. The problem is I can't view the website. It comes up with the 1and1 default page. I thought it would take time for my site to be recognized by 1and1 but its been almost a week so I must've done something wrong. Maybe I have a setting wrong within my 1and1 control panel. Any help would be greatly appreciated. Thanks!

  2. timDesain
    Member
    Posted 2 years ago #

    set to default theme: twentyten
    turn off all plugins.
    check the site.
    working?
    probably your theme or some plugin doesn't compatible with your wp.

  3. onespriggan
    Member
    Posted 2 years ago #

    Hi Tim, I tried that but still nothing. Default theme set to Twentyten, all plugins off. I have never been able to see my site from the start so when I began it was already at the default settings with everything turned off. Its very strange and makes me think there is a setting within 1and1 that needs to be changed.

  4. Tim S
    Member
    Posted 2 years ago #

    Check to make sure you've set the site url and home correctly. WP is domain specific. Also, make sure your domain has fully propagated. If it's a new account, it may not be. Can you provide specifics, like the URL for the domain? And can you provide a where you installed WP?

  5. onespriggan
    Member
    Posted 2 years ago #

    Hi Tim S, I've had the domain name from 1and1 for a couple of years and just sat on it. A few months ago I purchased the hosting through 1and1. Through the 1and1 control panel I linked them together. It took about a day but the status of the domain changed from 'transferring' to 'ready'. I installed through filezilla to the root directory. The only additional folder I saw on there was the log folder. My domain is http://www.ireviewshirts.com. You will see when you go there it says 'This domain name has just been registered.'

    thanks for your help!

  6. Tim S
    Member
    Posted 2 years ago #

    Hi,

    Seems that it still displays the domain parking page. Have you checked to make sure the nameservers you are using for the domain name are the ones provided by 1and1? Typically, when you transfer a domain it does not update the nameservers. You may have to update the nameservers...

  7. k_nitin_r
    Member
    Posted 2 years ago #

    onespriggan,

    Try putting up an index.html page on your website and check if it is accessible from your browser by typing in the domain name. If it is, try putting up a simple PHP page by pasting in something like: <?php echo 'Hello'; ?> into index.php (and delete index.html). If that works fine too, troubleshoot the problem with running WordPress by ensuring that all warning messages are enabled.

  8. onespriggan
    Member
    Posted 2 years ago #

    Have you checked to make sure the nameservers you are using for the domain name are the ones provided by 1and1? Typically, when you transfer a domain it does not update the nameservers. You may have to update the nameservers...

    I think you are correct, I used the 1and1 control panel to make it my nameserver instead of 1and1 name server. I also added 2 subdomains ns1 and ns2. It said to wait up to 72 hours. Now when I go to the site it says "server not found" instead of the parking page. I cant even access the wordpress login for my site. Ftp upload does not even work anymore. Error comes up with "EAI_NODATA - No address associated with nodename" in my ftp window. I can really only access the 1and1 control panel. Thanks for your help.

  9. onespriggan
    Member
    Posted 2 years ago #

    sorry, I meant to reverse that quoting.

  10. jwinter66
    Member
    Posted 2 years ago #

    To get back to your original question.

    copy the index.php file from wordpress dir and put it in the main dir and rename or delete the index.html.

    edit the index.php file int the main dir as follows. (add the /wordpress)
    require('./wordpress/wp-blog-header.php');

    in the setting of your site.
    change the site url to
    http://YOURDOMAIN.com

  11. onespriggan
    Member
    Posted 2 years ago #

    Hello jwinter66, do I edit the index.php file in word? If so where do I add these items? You also mention to change the site url. Would I change this in the control panel somewhere on the 1and1 site? Right now I have the home directory at the root.

  12. thecoffeecompass
    Member
    Posted 1 year ago #

    Yes you must delete that dumb index.html file.

    My problem was I hadn't cleared the cache on my browser, so I kept getting the /default 1&1 page. Clear your cache or open the web address in a different browser.

  13. ALVAW3
    Member
    Posted 1 year ago #

    I see the site here now so let us know if you have resolved it. Host servers have an order of precedence that takes place when the site loads so yes if you have one that is above your index.php it will be the one that loads :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags