WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Installing WordPress at 1and1 (13 posts)

  1. falvares
    Member
    Posted 7 years ago #

    I'm trying to install WordPress at 1and1 and keep getting message "Error establishing a database connection".

    Already tried to start all over again (deleted the database, all wordpress files, created a new database, updated wp-config.php with new database information, uploaded WordPress files again) but still get the error message.

    Any help will be highly appreciated.

  2. MichaelH
    Member
    Posted 7 years ago #

    1and1.com is a vendor that shows you all the information you need where your MySQL databases are listed.

    Please check your wp-config.php file to insure it agrees with the information shown by 1and1.

    Of course your database server could also be down...

    See:
    Editing wp-config.php

  3. falvares
    Member
    Posted 7 years ago #

    Hi Michael, thanks so much for replying!

    > 1and1.com is a vendor that shows you all the information you need where your MySQL databases are listed.

    Database settings:

    Database name db209753010
    Host name db1017.perfora.net
    Port 3306 (default port)
    User name dbo209753010
    Password xxxxxxx
    Description WordPress PinkyLotusBlog
    Version MySQL4.0
    Status ready

    > Please check your wp-config.php file to insure it agrees with the information shown by 1and1.

    wp-config.php

    define('DB_NAME' , 'db209753010'); // The name of the database
    define('DB_USER' , 'dbo209753010' ); // Your MySQL username
    define('DB_PASSWORD', 'xxxxxxx' ); // …and password
    define('DB_HOST' , 'db1017.perfora.net'); // 99% chance you won't need to change this value

    >Of course your database server could also be down...

    Tried many times. There is a means to check that?

    Again, thanks!

  4. MichaelH
    Member
    Posted 7 years ago #

    >There is a means to check that?

    You bet--but I forget what 1and1 calls it! I believe they give you a link on the same line as that database information to manage/use phpMyAdmin. That would tell you the database server is running.

    Of course, if necessary, delete that database and start all over--maybe something got whacked with that user...

  5. falvares
    Member
    Posted 7 years ago #

    Michael,

    >Of course, if necessary, delete that database and start all over--maybe something got whacked with that user...

    Yes, started all over again (for the third time!). Think I'm doing something very stupid, but unfortumnatelly can't see it.

    If you (or any other fellows around here) could get some time and, please, check http://www.pinkylotusblog.com/testdocs/installation.pdf

    It's the full step-by-step routine I performed with screenshots of every step, since downloading WordPress until the error message.

    I thank you very much for your help.

  6. Root
    Member
    Posted 7 years ago #

    I think the guys who do install4free and have a lot of experience say that 1and1 is virtually incomprehensible in this regard. It is going to need specialist knowledge or a new host.

  7. MichaelH
    Member
    Posted 7 years ago #

    falvares

    Can't see a thing you are doing wrong! My next guess is that FTP is somehow corrupting your wp-config.php file.

    If you are willing, submit a request at http://install4free.wordpress.net and please refer to this forum topic, http://wordpress.org/support/topic/124616 when you enter your request.

  8. falvares
    Member
    Posted 7 years ago #

    Michael,

    >Can't see a thing you are doing wrong!

    Glad to hear that :)

    >My next guess is that FTP is somehow corrupting your wp-config.php file.

    FTPed wp-config.php back from 1and1 to my computer, openned with a text editor (notepad) and (apparently) everything was in place.

    At this point, *even* if I get WordPress running at 1and1, it showed to be so cumbersome, awkward and senseless, that I'd better start thinking in moving to another host, like Root suggested.

    I've seen some references to DreamHost (http://www.dreamhost.com). Any comments about that?

    Thanks!

  9. falvares
    Member
    Posted 7 years ago #

    Dear Fellows,

    Contacted Michael D. Pollock (http://www.solostream.com/2007/02/25/lesson-12-download-and-install-wordpress-on-your-server/#) where I found the tutorial on how to install WordPress, and he figured out the problem after I send him the wp-config.php file.

    With that file in hands he could detect the use of a faulty apostrofe.

    Also, would like to express my satisfaction with 1and1 support that, little while after I send them a message about the problem, contacted me (by mail) offering their help to support me.

    My mistake. If I did it *ALL* right, wouldn't have burdened you all with my stupid problem.

    Finnally got WordPress installed in my domain.

    Please accept my most sincere apologies.

    Fernando

  10. trinaryouroboros
    Member
    Posted 7 years ago #

    This is nonsense. After quadruple-checking and carefully setting this up on my 1and1.com host I'm getting the exact same problem.

    It would do all of us a great favor if perhaps Michael D. Pollock were kind enough to explain what the real problem is with the wp-config.php file in this regards.

  11. LarryVan
    Member
    Posted 6 years ago #

    It is important to place the required data, user name, database name, etc, within the single quotes, and not change the spacing between the single and the closing parenthesis
    I have prepared a tutorial(not yet complete) at http://discouragedblogger.com

    Larry

  12. Josephrot
    Member
    Posted 6 years ago #

    ATTEN: MichaelH

    No, no, no. 1and1 with their Blog kit that we 1and1 admins use is dead WRONG.

    1and1's WordPress Blog system forms the Blog at the SAME address as the web site(!), which is DEAD WRONG.

    I will be talking to 1and1 tomorrow (Wed Oct 31) about this.

    Prime example:

    We host for a publisher:

    http://www.samaritanpress.com/

    but 1and1's WordPress system assigns the Blog to the SAME address:

    http://www.samaritanpress.com/

    Because all 1and1 asks us is the domain name, when they should be asking us the domain name, followed by the default server directory that the blog system should start in!

    INSTEAD, 1and1 should by default, assign to something sensible like:

    http://www.samaritanpress.com/blog

    but they offer NO way to control this.

    PLEASE, we have NO intention of going through the 25 steps to alter the Blog server files and address, that's stupefying to expect people to do that, when the fault is 1and1's.

    UPDATE: 1nd1 Technical Support called, and one of the programmers said "You know, you are right! Normally, the 1and1 Blog Wizard SHOULD create the blog for http://www.samaritanpress.com as:

    http://www.blog.samaritanpress.com

    but unless that directory already exists on the server, well, it goofs and instead creates the Blog on top of the actual domain main directory, thus over-writing that directory.

    This will be fixed pronto, and the 1and1 Blog Wizard will offer to assist admins to create a sub-domain "www.blog.domainname.xxx" in the future if it does not already exist."

    Joe
    Knoxville, TN

  13. rdhuff
    Member
    Posted 6 years ago #

    Josephrot:
    I discovered the same thing, the hard way, at 1and1. After creating my blog with their easy (and it is very easy and straightforward) procedure, my web site disappeared. Fortunately, deleting the entire blog restored everything and I was invisible for only a few minutes. That was on Saturday (3 Nov) so things aren't fixed quite yet. I then ceated a sub-domain and put the blog there.
    Now, I wanted to be able to customize a bit and put my own logo on the blog. Sorry, can't do that. According to their tech support people, they don't provide FTP access to the blog sub-domain.
    Does anyone know any way around this? Could I set up WordPress on my site manually, not using their "wizard" and then have FTP access and control? Or, is there another way?

    Dana
    Madrid, Spain

Topic Closed

This topic has been closed to new replies.

About this Topic