WordPress.org

Ready to get started?Download WordPress

Forums

Installing went fine but... (8 posts)

  1. jackiefg
    Member
    Posted 10 years ago #

    Everything seemed to go well, and then, as soon as I clicked login, it took me to the log-in page to log in as admin and the password, but at the top left, it had this:
    SQL/DB Error:
    [Lost connection to MySQL server during query]
    SELECT option_name, option_value FROM wp_options
    Then I logged in anyway as admin, and got this:
    Warning: Cannot add header information - headers already sent by (output started at /mnt/web_k/d38/s32/a0004tng/www/blog/wp-includes/wp-db.php:106) in /mnt/web_k/d38/s32/a0004tng/www/blog/wp-login.php on line 122
    Warning: Cannot add header information - headers already sent by (output started at /mnt/web_k/d38/s32/a0004tng/www/blog/wp-includes/wp-db.php:106) in /mnt/web_k/d38/s32/a0004tng/www/blog/wp-login.php on line 126
    Warning: Cannot add header information - headers already sent by (output started at /mnt/web_k/d38/s32/a0004tng/www/blog/wp-includes/wp-db.php:106) in /mnt/web_k/d38/s32/a0004tng/www/blog/wp-login.php on line 129
    Warning: Cannot add header information - headers already sent by (output started at /mnt/web_k/d38/s32/a0004tng/www/blog/wp-includes/wp-db.php:106) in /mnt/web_k/d38/s32/a0004tng/www/blog/wp-login.php on line 131
    Warning: Cannot add header information - headers already sent by (output started at /mnt/web_k/d38/s32/a0004tng/www/blog/wp-includes/wp-db.php:106) in /mnt/web_k/d38/s32/a0004tng/www/blog/wp-login.php on line 132
    Warning: Cannot add header information - headers already sent by (output started at /mnt/web_k/d38/s32/a0004tng/www/blog/wp-includes/wp-db.php:106) in /mnt/web_k/d38/s32/a0004tng/www/blog/wp-login.php on line 133
    Warning: Cannot add header information - headers already sent by (output started at /mnt/web_k/d38/s32/a0004tng/www/blog/wp-includes/wp-db.php:106) in /mnt/web_k/d38/s32/a0004tng/www/blog/wp-login.php on line 134
    Warning: Cannot add header information - headers already sent by (output started at /mnt/web_k/d38/s32/a0004tng/www/blog/wp-includes/wp-db.php:106) in /mnt/web_k/d38/s32/a0004tng/www/blog/wp-login.php on line 154
    Can someone tell me WHAT to change? What about permissions - are they supposed to be changed? What is the "no connection to the database?"

  2. Mark (podz)
    Support Maven
    Posted 10 years ago #

    I'd guess that it did precisely what it said - the connection to the db was broken. (No idea how this happens though).
    Have you tried closing that window in your browser, then trying to get to the /wp-login.php address again ?

  3. jackiefg
    Member
    Posted 10 years ago #

    I went to http://www.jackiefg.com/blog/wp-login.php after your suggestion, and the page showed up fine, but once again, once I logged in, I got the same message as above.
    I'm wondering where (it seemed to me in the old version of WP) you put in your site name - like jackiefg.com. All I put in was the database stuff in the wpconfig file, but there was no place to put my site in. Is there another file I should be configuring?

  4. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Your blog shows up fine - it's the default install.
    If I go to the login address, I also see that error.
    Is there anyway you can get your mySQL checked to see if it is working okay ?

  5. Mark (podz)
    Support Maven
    Posted 10 years ago #

    *bump*

  6. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    http://www.google.com/search?q=Lost+connection+to+MySQL+server+during+query
    I would contact your hosting provider again and if they still don't help switch to a different provider. Someone was giving out free hosting accounts on the Misc forum a little while ago.

  7. jackiefg
    Member
    Posted 10 years ago #

    I just switched providers cuz my last one was pathetically slow. I don't think I can go through that again. It's the reason why right now I'm forced to use MT - I'm working and working at getting the Word Press back up and running here.

  8. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    Well, the error it's returning is a MySQL database error that has nothing to do with WordPress except WP happens to be accessing the MySQL database when this error happens. This would happen with any script you used, PHP or Perl or whatever, that accessed mysql.
    Visiting your blog now, it looks just fine. I'm guessing the error is sporadic.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.