WordPress.org

Ready to get started?Download WordPress

Forums

Duplicator
[resolved] Installing to sub-domain on localhost (10 posts)

  1. robsanders
    Member
    Posted 1 year ago #

    Have no problems when installing to a root directory (localhost), but find that i am unable to install to sub (localhost/subdomain).

    Had a read through the support, and maybe not picking up on similar conditions. The process goes through until after installation, and i get to update permalinks, and it seems to point to (localhost/subdomain/subdomain) and gives me a cannot find website error.

    Any thoughts ??

    http://wordpress.org/extend/plugins/duplicator/

  2. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    You might what to double check your .htaccess file or your httpd.conf file to see if you have a virtual directory setup possibly...

  3. robsanders
    Member
    Posted 1 year ago #

    Thanks for the response.

    Checked .htaccess file, and looks ok, as well as RewriteBase (/subdomain/) and RewriteRule (subdomain/index).

    Will check the httpd.conf file.

    The content is there, but looks like the whole theme structure has disappeared. Thankfully i backed it up, but this is really weird.

  4. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    You can open the package.zip file and validate the contents are correct. If the theme files are there but not getting extracted then the package may have gotten corrupted somehow...

  5. robsanders
    Member
    Posted 1 year ago #

    It appears as if the it trying to load the subdomain twice (localhost/subdomain/subdomain), so will look into your suggestion as well.

    Thanks for the support.

  6. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    That is a bit strange. If you want to submit your package to me I can take a look at it. Just use the help ticket system...

  7. vijayvithal
    Member
    Posted 1 year ago #

    I am facing a similar problem.
    I am migrating to
    http://techwritinglabs.com.cp-4.webhostbox.net/test
    but navigating to the url redirects to
    http://techwritinglabs.com.cp-4.webhostbox.net/test.cp-4.webhostbox.net/test/testimonials/

    I see two sets of errors here,
    1. The url redirect to a non existent subdomain
    2. testimonials is a sub page and not the main page of my website

  8. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey vijayvithal,

    Here is a helpful section on the FAQs page:
    -> Browse To: http://lifeinthegrid.com/duplicator-faq/
    -> Find Section: "2. Installer"
    -> See Area/Question: "Everything installed but I keep getting redirected to another URL or 404 errors."

    Hope that helps!

  9. vijayvithal
    Member
    Posted 1 year ago #

    Thanks for the response. I dont think it is due to .htaccess because I can access static html files in that folder e.g.
    http://techwritinglabs.com.cp-4.webhostbox.net/test/readme.html

    I tried renaming the .htaccess file with no change in status.
    So it looks like it is either a plugin issue (Seems unlikely as I have a few youtube plugins and no redirect plugins) or an issue with the two php files mentioned in the FAQ. I will check them and update on the status in the evening
    Regards
    Vijay

  10. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Check the wp-config.php thoroughly by looking at every variable sometimes plugins insert global constants that effect the URLs of the site.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic