WordPress.org

Ready to get started?Download WordPress

Forums

installing on win2k... (11 posts)

  1. mjpuczko
    Member
    Posted 10 years ago #

    i'm having some strange troubles, when i go here:file:///C:/Program%20Files/Apache%20Group/Apache2/htdocs/wp-admin/install.php
    i get all this strange code on the page! i'm using php5 & mysql 4.0.18, apache 2.0.49

  2. Beel
    Member
    Posted 10 years ago #

    At a quick glance, you have to go here you can't go directly to the file on your computer. You have to go through your server http:// whatever.com/wp-admin/intall.php

  3. TechGnome
    Moderator
    Posted 10 years ago #

    If you are doing this on your local machine, which it looks like you are, try :
    http://localhost/wp-admin/install.php
    TG

  4. mjpuczko
    Member
    Posted 10 years ago #

    okay, i got to the installation page, but when i enter in my db info:
    db name = mysql (default created upon mysql installation
    user name = name i created when starting winmysqladmin.exe
    password = same as above
    host = my pc name
    step 2 is just blank minus the wordpress banner (which links)

  5. mjpuczko
    Member
    Posted 10 years ago #

    i have another question about mysql. after i setup mysql version 4.0.18 on windows server 2003, i went and opened up winmysqladmin.exe & setup the user name & password. then went to the databases tab & there was a db there called mysql which appeared to have fields populated, unlike the test db which had nothing in it. so i used the mysql db as the db for wordpress. is that wrong?

  6. TechGnome
    Moderator
    Posted 10 years ago #

    Not sure, but I think the mysql db is kinda like the system db that's used to hold info about other databases in the system. It shouldn't be a problem, but I'd recommend creating a new DB and using that for WP.
    Also, if the web is running on the same PC/server as mySQL then you cna use "localhost" as the hostname. I do that at home and it works just fine.
    TG

  7. mjpuczko
    Member
    Posted 10 years ago #

    that's the other problem i'm having is trying to create a new db. i found directions that said to right click the top node & choose create new, but i don't see that anywhere. when i right click all i see is 'flush..' options. my website is on the same pc as mysql.

  8. Anonymous
    Unregistered
    Posted 10 years ago #

    perhaps you click on the mysql database entry. you have to click above of that. and yes, the mysql database is the system db, not for data.
    if you don't like the admin tool try phpmyadmin

  9. mjpuczko
    Member
    Posted 10 years ago #

    thanks! that's exactly what i found out somewhere else. hopefully i can get this working soon.

  10. Anonymous
    Unregistered
    Posted 10 years ago #

    you can create a database & tables through command line too. If you have MySQL installed in C drive then use the following code & execute it line by line on DOS Prompt.

    cd c:\mysql\bin
    mysql
    create database wordpress

    If you don't have MySQL installed in C then you can replace "c" in the above code with the drive letter in which MySQL is installed.
    Also, it would be better if you get a GUI to manage your MySQL databases. It'll be easier. You can get phpMyAdmin from http://www.phpmyadmin.net for FREE. Its a web based app for managing MySQL & is written in PHP.

  11. Anonymous
    Unregistered
    Posted 10 years ago #

    I don't know but it seems that miniBB is parsing the forward slashes etc. the code is here again.
    [code]
    cd c[colon][backslash]mysql[backslash]bin
    mysql
    create database wordpress
    [/code]

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.