WordPress.org

Ready to get started?Download WordPress

Forums

Installing on localhost (2 posts)

  1. s7uar7
    Member
    Posted 11 years ago #

    I succesfully ran the install on my remote (hosted) webserver without a hitch, and decided to also install on my PC so I could edit and test locally. When I run wp-install i get an error:
    Warning: main(//b2-include/wp-db.php): failed to open stream: Invalid argument in c:\inetpub\wwwroot\b2config.php on line 337
    Fatal error: main(): Failed opening required '//b2-include/wp-db.php' (include_path='.;c:\php4\pear') in c:\inetpub\wwwroot\b2config.php on line 337
    The root is c:\inetpub\wwwroot and I'm running php4.3.2 on Windows 2000.
    Any help gratefully accepted
    Stuart

  2. Mike Little
    Member
    Posted 11 years ago #

    Hi Stuart,
    It looks like you are also using IIS. I'm not sure that WordPress runs under IIS.
    But you actual error seems to be related to the calculated include path. This is governed by settings and version of PHP you are running.
    Try setting $abspath to an absolute value in the bottom of b2config.php
    Mike

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.