WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] installing new 2.8 theme on 3.0 (14 posts)

  1. jilljonline
    Member
    Posted 3 years ago #

    The theme that I purchased will not download, is it because my WP version is higher? Or do I need more memory?

  2. conorp
    Member
    Posted 3 years ago #

    What error message do you get?

  3. jilljonline
    Member
    Posted 3 years ago #

    Let me clarify, it downloads, but will not install. It appears to be installing then, it ends with a WP Failure screen notice. The author was real attentive to me when he thought it was a download problem, now I can't get him to respond to me.

  4. Can you quote the "WP Failure screen notice?"

  5. jilljonline
    Member
    Posted 3 years ago #

    I have a screen shot of the screen, but I can't figure out how to add it to this message box to show you. It's basically a blank screen with a box in the middle that reads:

    "are you so you want to do this? Please try again"

    You would think there would be a link to confirm that you want to do this, but there is not. There is no option for letting me try again. At the top in the menu bar, the tab indicates, WP Failure Screen notice.

  6. jilljonline
    Member
    Posted 3 years ago #

    oops, are you "so" you want to do this s/b "sure"

  7. conorp
    Member
    Posted 3 years ago #

    Do other WordPress themes install? Is it just this one? Try installing one from: http://wordpress.org/extend/themes/

  8. jilljonline
    Member
    Posted 3 years ago #

    Yes, other themes do install. The one I'm having trouble with is a theme I bought from themeforest.net. The dashboard admin directory implies that I should be able to install a zip file. It will not install zipped. The author tells me I need to open it and find the theme. I have done that and see the folder of the files I need to install (according to him), but it does not allow me to just install those files or all of the unzipped files. When I browse for the files they will not populate to the open box for an install?!

  9. jilljonline
    Member
    Posted 3 years ago #

    The theme is now in my directory, but as a "broken link" installed, but incomplete. It needs a template and style sheet. I'm told from the support forum where I bought the theme that it is because the theme is for WP version 2.8 and I have 3.0.

    I understand from the forum that downgrading is laborious task, but not impossible. The good news is I have no content yet. I understand I need to deactivate plug ins and delete wp-admin? I'm not sure how to delete the admin. The other question is that there are 15 versions of 2.8, how do I now which one to choose? The first or the latest one?

    Thank you,
    Jill

  10. It needs a template and style sheet.

    It must have templates and a stylesheet, otherwise it isn't a theme for any version of WordPress.

    I'm told from the support forum where I bought the theme that it is because the theme is for WP version 2.8 and I have 3.0.

    I doubt that has anything to do with it. Shame on them, really. They want you to use a publicly insecure version of WordPress because they, the ones you paid for this theme, are unwilling to even attempt to help you install it. Thank goodness this free volunteer-staffed forum is here to pick up when they're too busy counting their money to continue.

    Make sure that the style.css file exists in a directory structure as such:

    /wp-content/themes/theme-name/style.css

    Most premium themes come as:

    /theme-product-folder/theme-name/style.css

    If your theme currently exists as:

    /wp-content/themes/theme-product-folder/theme-name/style.css

    That's why you're seeing it as broken. Just move the /theme-name/ directory up so you have:

    /wp-content/themes/theme-name/style.css

  11. jilljonline
    Member
    Posted 3 years ago #

    There are 4 theme folders and each have a css folder. Here is how the directory for folder 2 exists:

    /wp-content/themes/imaxell-premium-corporate-theme-wordpress-source/www/imaxell-02/style/css

    Do I need to replace all the hyphens with "/"? Also, should it end with .css rather than /css?

    Also, I was told from the author early on (when he still replied to my emails) that I needed to download the "theme only" from the zip file. Since several days passed since he told me that and I actually figured out how to do it, I forgot and downloaded everything from the unzipped file. The rest is index and credits etc, could this be a problem and do I need to remove the whole file and start over? I'm not sure how to change anything through FileZila, but hopefully they can assist.

    I appreciate your time and assistance.

    Jill

  12. That's one screwed up structure. If there isn't a style.css file, then it's not a WordPress theme. I guess you could try changing style/css into style.css , but I've never seen that before, so I don't even know if it's possible.

    Honestly, since you purchased the theme from these guys, and its structure is completely fowled up to the point that it's not a WordPress theme, I'd demand a refund if they can't help you solve the problem that they created.

  13. jilljonline
    Member
    Posted 3 years ago #

    The problem was not the version of WP or the directory structure, it was me and the fact that I downloaded everything instead of just the theme. Works fine now!

    Thanks,
    Jill

Topic Closed

This topic has been closed to new replies.

About this Topic