WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Installing 2.8.4 on Earthlink, which only supports 2.0.4 (8 posts)

  1. Z_Everson
    Member
    Posted 5 years ago #

    A friend of mine has a website hosted by Earthlink. I am volunteering to update his website for him and install WordPress. Earthlink, however, only supports up to WordPress 2.0.4.

    Does anyone know of a workaround? I tried to follow the advice on this thread, but had no luck.

    Thanks!

  2. Zulfikar Nore
    Member
    Posted 5 years ago #

    That problem can only be solved by Earthlink themselves.

    They do run php5 so the code from the previous thread is not necessary.

    Anyother workaround? Yes, change your host.

  3. Z_Everson
    Member
    Posted 5 years ago #

    Thanks! I called Earthlink but was just told our engineers are looking into upgrading, but they had no estimate about when.

    As it's a friend's site, I'm kind of stuck with Earthlink, although now I hope I can convince him to switch.

    Thanks for your help!

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Do they run PHP version 4.3 or greater? Do they have MySQL version 4.0 or greater? Do you have FTP access to your site?

    If so, then what they "support" is irrelevant. Just install the version you want to run.

    Installing WordPress

  5. Z_Everson
    Member
    Posted 5 years ago #

    -PHP is 5.0.5.
    -MySQL appears too be 4.1.20
    -Yes, I have FTP access to my site.

    That being said, I performed a manual install (or at least tried to) before coming here, but you can see the error message I got at the wp-login page.

    And I did verify the database info that goes in wp-config with Earthlink.

    Thanks for all of your help!

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    That's not an error message, that's the login page itself. Your account is not set up to run PHP files.

  7. Z_Everson
    Member
    Posted 5 years ago #

    Ah...thanks Otto42!

    Turns out that I did need to add AddHandler php5-script .php to the .htaccess file in the main folder.

  8. firecatsue
    Member
    Posted 4 years ago #

    I was shocked to hear that Earthlink doesn't support WordPress beyond 2.0.4 - I'm having various problems with plugins and they track back to Earthlink and the way they handle granting permissions.

    They suggested I run the autoinstall and then upgrade; anyone know if that will have any effect?

    All I can do is complain, and threaten to move my client off EarthLink hosting. But it's a big business disruption for a small office.

    At any rate - thanks for sharing your experiences. It helps!

Topic Closed

This topic has been closed to new replies.

About this Topic