WordPress.org

Ready to get started?Download WordPress

Forums

installed wp ok -> won't publish (10 posts)

  1. mrbloggr
    Member
    Posted 8 years ago #

    When i try to post it resolves to the ?posted=true "Post Saved" page ok, but the page that is supposed to be published does not exist on the server (../2006/04/24/xxx/) so I get a 404 error.

    My database and database users are all ok. Versions of php and mysql are all ok. chmod of .htaccess in blogging folder ok at 666.

    WP is just not publishing despite showing the posts in the 'Manage' tab, etc.

  2. djpappas
    Member
    Posted 8 years ago #

    Still sounds like a permalink issue (not withstanding the access permisions on the .htaccess file).

    Can you go to the Options -> Permalinks tab and make certain you have configured your web site to use permalinks? The default behaviour sets up a URL with this pattern: http://www.example.com/?p=123
    If you append the ?p=1 to the back end of your URL base you ought to be able to check out whether you have the defaults being used.

  3. mrbloggr
    Member
    Posted 8 years ago #

    I've selected 'Date and name based' permalinks. Nothing is being published in my Blog address (URI). WordPress reports it has made the post/page but it's 404 coz the reported URL of the post/page does not really exist (not being published on my Web server).
    I'll try working with my Web host and see what that turns up.

  4. carbontwelve
    Member
    Posted 8 years ago #

    Could be that your webhost doesnt allow permalinks?

  5. mrbloggr
    Member
    Posted 8 years ago #

    The basic problem is nothing is getting published.

    The data is in the mySQL database ok.
    The wp software is installed and working ok.
    The wp software reports new posts and pages created ok (but they don't exist coz no actual publish - 404).

    Is there any diagnostic tracing that can determine where the process is getting derailed?

    My host doesn't seem to have a clue.

    The following has appeared in my .htaccess file in my publish folder:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    But, strangely, my chmod for the publishing folder's .htaccess file won't seem to stay on 666. Keeps removing write permissions for 'groups' and 'others'. I've asked my host about that.

  6. Samuel B
    moderator
    Posted 8 years ago #

    Is the .htaccess in your WP root? Is that what you're calling your "publish" folder?
    .htaccess must be in the WP root to work.

  7. mrbloggr
    Member
    Posted 8 years ago #

    The .htaccess file I refer to is in the root of my server. I have instructed wordpress to publish to my server root.

    The wordpress software is in a lower directory and doesn't have an .htaccess file.

  8. mrbloggr
    Member
    Posted 8 years ago #

    Can anyone tell me if i should an .htaccess file in both the root of my publishing folder -and- in the root of my wordpress installation? What should be included in those files? This bit:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Many thanks. Still not publishing. Any help would be grateful. AllowOverride directive is enabled. That's all I can think of. I guess I'll have to switch Web hosts.

  9. Samuel Wood (Otto)
    Tech Ninja
    Posted 8 years ago #

    First, let's figure out what exactly you mean by "publish".

    Up at the top of the thread, you said this:
    "the page that is supposed to be published does not exist on the server (../2006/04/24/xxx/) so I get a 404 error."

    That's sorta the whole point here. You're expecting it to create a file on your webserver for that directory structure. But it's not going to do that. Those are not real files anywhere, they are permalinks. The permalink is converted to something else by the WordPress software.

    "Publish" means to put the post into your database and then to do the necessary stuff to show it on your blog. But it doesn't create any new files anywhere or anything like that.

    You posted your .htaccess file above, and it's correct, if you have your wordpress installed at the root of your website. If the blog is in a subdirectory of your website, then you need to set some options in the admin panel correctly and it will change that .htaccess file to match.

    What is the exact structure of the files in your website directory? This is crucial information and you need to set things up correctly for things to work correctly.

  10. mrbloggr
    Member
    Posted 8 years ago #

    To all,

    This problem has been resolved.

    The problem was the location to 'wp-blog-header.php' in the index.php file in my blog directory (in this case the root server) was incorrect. I'm deeply embarrassed that I did not understand this before but it is my first wp install.

    Many thanks thanks for your gracious help and commendable patience. Onward!

    mrbloggr

Topic Closed

This topic has been closed to new replies.

About this Topic