WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Installed WordPress in a subdirectory - displays Index of... (17 posts)

  1. Steve@316
    Member
    Posted 5 years ago #

    Ok, I'm sure this has been discussed and I did read several post's here in the Forum that cover similar content although did not address the problem I'm having. I hope its a minor one.

    1) I was able to install WP in a sub directory fine, get to the login page, login, and instead of displaying the index.php, it displays Index of /newsite/wp-admin. If I click o the index.php page, it displays index.php (the dashboard)

    2) If I click on View site from the dashboard, it displays Index of /newsite. (I suspect if I fix #1, this will also solve this problem.)

    Any help is most appreciated
    Thx in advance

  2. Samuel B
    moderator
    Posted 5 years ago #

    put this in your .htaccess file
    DirectoryIndex index.php index.html
    then refresh browser cache - ctrl + F5
    go to site normally

  3. sannoble
    Member
    Posted 5 years ago #

    I used fantastico to create blog. I actually had it created one but decided to re-do in order to get the adsense (ads.php) file activated.
    I had this problem with the index before, but got it corrected by re-installing.

    1) I now have the same problem with the index displaying. I've deleted everything and re-installed three times today. Still a problem.

    Have no idea where to find .htaccess file and don't understand what you say to add. I am very low tech.

    2) I notice that duplicate folders were created:
    wp-admin, wp-content and wp-includes
    followed by the same 3 folders again.

  4. Steve@316
    Member
    Posted 5 years ago #

    samboll - Does it matter where in the htaccess I put this?

    sannoble - You will have to use an FTP program that will display the invisable files. I'm on a Mac and use FileZilla

  5. Steve@316
    Member
    Posted 5 years ago #

    samboll - Does it matter where in the htaccess I put this?

    sannoble - You will have to use an FTP program that will display the invisable files. I'm on a Mac and use FileZilla

  6. sannoble
    Member
    Posted 5 years ago #

    still lost.

    I was able to find the htaccess file a couple places in hosting system file manager.

    and at times can see it in ftp software.

    still don't know what i'm supposed to do with it.
    cannot double click the file and open it.

    Very frutstrated. I've literally re-installed six times.
    As I said, that did the trick a month ago. I could login to wp-admin. and the url displayed the blog.

    now I've regressed.

    Sandra

  7. Steve@316
    Member
    Posted 5 years ago #

    Sannoble - I'm fairly new to WP and I apologize I have not been much help. I'm not familiar with fantastico. The htaccess file you are looking for should be in the httpdocs.

  8. Steve@316
    Member
    Posted 5 years ago #

    As for my problem, I have tried adding the code samboll mentioned to several locations in my htaccess file. I'm still having the same results.

    Can anyone else please help?
    Steve

  9. Samuel B
    moderator
    Posted 5 years ago #

    hi,
    sorry been away

    anywhere in .htaccess not inside the wp stuff will work - just put it at the top

    if that doesn't work, you may need to talk to your host about it

  10. sannoble
    Member
    Posted 5 years ago #

    I guess you're not understanding that I do not understand.

    As I said, htaccess is multiple places. So not sure where to put it.

    #1
    Is it supposed to be under root directory or public_html, or under www or under the blog folder?
    And once I figure that out, should htaccess be under private or one of the vti folders?

    #2
    the following makes no sense to me
    put this in your .htaccess file
    DirectoryIndex index.php index.html

    What is that? A line of code

    #3
    And since I said I haven't found a way to open the file,
    don't know how to put anything in it.

    and if I need to ftp. It means I am moving something from 1 place to another. So where would I get that stuff from.

    to answer Steve,
    fantastico is a utility that automatically creates wordpress blogs and other things. Most hosting companies offer it in cpanel.

    Sandra

  11. Samuel B
    moderator
    Posted 5 years ago #

    @ sannoble
    I wasn't answering you

    1 - the .htaccess in your wordpres folder (wherever you have it installed

    2 - open your ftp client - download .htaccess and c & p the above line into the top of your .htaccess - upload it

  12. Steve@316
    Member
    Posted 5 years ago #

    @ sannoble, if I may suggests you start a separate thread.

    @ samboll,
    Here is what I have in the htaccess file. Is this correct?

    DirectoryIndex index.php index.html
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

  13. Steve@316
    Member
    Posted 5 years ago #

    @ sambol,
    I tried that and still get the same result.

    Also, "you may need to talk to your host about it."
    It's not my host. It's the clients and unfortunately they are really no help at all. Hosting is not there business. (friend of a friend, free, etc.) Yes, I have already tried to get them to move to my servers where this would not be a problem. It may be our last option.

    If anyone has any other suggestions...?

    Thx,
    Steve

  14. Steve@316
    Member
    Posted 5 years ago #

    Any assistance here would be appreciated.

  15. Steve@316
    Member
    Posted 5 years ago #

    Just an FYI - The htaccess file is in the subdirectory. Is this the correct location?

  16. Steve@316
    Member
    Posted 5 years ago #

    OK, I have found the solution elsewhere. I hope this will help anyone else having same or similar problem.

    1) I did as suggested by sambol above; added "DirectoryIndex index.php index.html" to the htacess file.

    2) Sent this request to the hosting provider.
    "Have the host admins edit the Apache httpd.conf file to ensure that index.php is in the list of "index" files."

    I'm not sure If it was both or just #2.

    Thx,
    Steve

  17. sannoble
    Member
    Posted 5 years ago #

    from my hosting company:

    The reason why the domain was not showing up, was because of your .htaccess file in the public_html folder. I went and moved that to .htaccess.bak and now the blog loads fine.

    It now works!!

    Sandra Noble

Topic Closed

This topic has been closed to new replies.

About this Topic