WordPress.org

Ready to get started?Download WordPress

Forums

Disable Comments
Installed on 2 WP Sites, and half script/media don't load now even after Uninsta (11 posts)

  1. aakifshamsi
    Member
    Posted 1 year ago #

    I am frustrated now. I just thought it would resolve the issue of automatic trackbacks.

    But, what it gave me was a broken Website :((
    Why do you create such creepy scripts :(((

    http://wordpress.org/extend/plugins/disable-comments/

  2. solarissmoke
    Member
    Plugin Author

    Posted 1 year ago #

    I have spent many hours of my free time developing and supporting this plugin, to make sure it works for the tens of thousands of people that use it. It's pretty irritating when someone comes along and throws about stupid comments like "why do you write creepy scripts".

    Please try and be a little considerate and polite, and you might even find that people are more willing to help you. You are also free to inspect the code yourself, if you feel it is so creepy.

    As regards your problem, the plugin does NOT arbitrarily make permanent changes to your WordPress installation. I suggest you try the following:

    • If you have a caching plugin installed, clear the cache. This is important, and the most common problem people have.
    • Check if you installed any other plugins at the same time that could have caused the problem. This may sound silly but it happens very frequently.
    • If none of the above works, share some more meaningful information about what is wrong, e.g., a link to your site and explain exactly what doesn't load.

    Finally, you should always back up your site before installing new plugins, because there is always a small possibility that plugins may create conflicts. This is basic good practice.

  3. aakifshamsi
    Member
    Posted 1 year ago #

    I am sorry but it was out of frustration.

    Actually I tried the plugin on a client's website. And now, his website isn't working.

    The problem is, NO MEDIA items load. Or I must say that the attached images in the /wp-content/uploads aren't showing up.

    Actually on further inspection, I find Error 403.

    I wonder how it happened, but both my sites are sick Now. :(

  4. solarissmoke
    Member
    Plugin Author

    Posted 1 year ago #

    403 sounds like a server config issue - either htaccess or file permissions, or (with many hosts this is a problem) mod_sec. If both your sites are on the same host, then it is very likely to be one of these, and you should ask your host whether mod_sec is preventing access to the wp-content folder.

  5. aakifshamsi
    Member
    Posted 1 year ago #

    I have both sites on different servers.

    I've checked for File Permissions, and it is fine.

    Did you write anything to change in the .htaccess file?

    Prior to the installation of the plugin, things were fine. So I believe mod_sec isn't an issue, but it could be htaccess file if you can check/confirm.

  6. solarissmoke
    Member
    Plugin Author

    Posted 1 year ago #

    The plugin doesn't modify any files, including htaccess.

    What other plugins are installed?

  7. aakifshamsi
    Member
    Posted 1 year ago #

    All other plugins have existed for over two years.
    I've never had issues with any of them.

  8. solarissmoke
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, but one of them may have created a conflict with Disable Comments.

  9. Christian Foellmann
    Member
    Posted 1 year ago #

    I had the same issue.
    The install killed my WP MU off completely. Never test a new function on the production site!!

    Will do some more testing...

  10. solarissmoke
    Member
    Plugin Author

    Posted 1 year ago #

    Absolutely - making changes on a production site is asking for trouble.

    If you do track down a reproducible conflict with this plugin, let me know and I'll try to fix it.

  11. Christian Foellmann
    Member
    Posted 1 year ago #

    It was totally my fault.
    Nothing wrong with your plugin as far as I can tell.

    I thought it killed my .htaccess file but since I set up a new batch of dev installations after a longer pause I forgot to add a .htaccess on them. My production system runs on nginx and does use .htaccess for rewrites.

    Sorry for the false alarm

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic