WordPress.org

Ready to get started?Download WordPress

Forums

Installed new 2.3.2 and ... problems ... (11 posts)

  1. bszuta
    Member
    Posted 6 years ago #

    Guys,
    I hope I am not the only one with this one. I've installed brand new version of wordpress 2.3.2. Everything is find and dandy, except ... I cannot add any widgets. The famous drag and drop features is broken and that's about it.
    There are 2 errors. First points to ../jquery/intefrace.js ?ver 6124 ("unterminated string literal"). The second error says: "JQuery("#pagescontrol").Draggable is not a function" and points to the widgets.php file in wp-admins. That goes for both IE7 and Firefox 2.0.

    It seems that this is not a new problem, so my question is: if the drug and drop does not work, what one has to do in order to put a widget visual element onto the page?
    Is there a table to update, which would add these elements?

  2. mgoldsworthy
    Member
    Posted 6 years ago #

    i'm having the same problem. did you come up with a solution?

  3. kyral
    Member
    Posted 6 years ago #

    Same problem with 2.3.2. Happens in both Safari 3.0.4 and Firefox 2.0.0.11 on OS X 10.5.1. Javascript console with Safari dumps a crapton of

    Value undefined (result of expression jQuery.iDrop.highlighted[i].get) is not object.
    undefined

    errors.

    Thing is one of my friends has an older version of WP and this doesn't happen. So maybe someone can see if they can get an older version of that function and see if it works?

  4. bszuta
    Member
    Posted 6 years ago #

    Well, my solution was to test 2.4x beta and .. no problems there. 2.3.2 is buggy. the widget drag-and-drop does NOT work due to the interface.js and jQuery.js incompatibility. I noticed that there is no ture source code for interface.js (the Romanian guy who wrote it does not release uncompressed version), and this surprise the heck out of me - why would open source folks used code that cannot be debugged? Yes, AJAX is sexy, but it has to work, and this one does not.
    BTW, all of the "bs" about ISP's blocking. using mod_security is just that. The source code is running and crapping out inside the existing javascript programs.
    I am still waiting for a new version, but my patience is running out, and am I thinking to move to something else (with great regret to be sure).

  5. KirkM
    Member
    Posted 6 years ago #

    Now this is strange. I have no problem with widgets in 2.3.2 in fact this is the first time I've heard this complaint since 2.3.2 came out and I've upgraded several people to this latest version. Unfortunately I have no idea what might cause this to be broken in your particular cases. Worth looking into though. If I find an answer I'll post back here.

    There's no database upgrade for 2.3.2 but you might want to use phpMyAdmin to go in and run a "check" on your database tables. This usually shows up any problems you might be having such as the one you describe if it's DB related. Also, you might try yet another update by downloading 2.3.2 again and making sure you delete the "wp-admin" and the "wp-includes" online directories completely before uploading (via FTP) the new ones you downloaded and extracted. Then you can copy over and overwrite the WordPress root files safely enough since doing it that way won't affect your "wp-config.php" file.

    I don't mean to be basic here but sometimes a redundancy check is needed just to say you did. I've fixed more strange problems with just this sort of thing. :)

  6. bszuta
    Member
    Posted 6 years ago #

    Krik,
    Thanks for the suggestion. I will give it a try, since nothing else works :)

  7. mgoldsworthy
    Member
    Posted 6 years ago #

    Kirk -
    deleting those directories did the trick. thanks for thinking basic for us. i used the automatic upgrade plugin, and something about using that must have messed this up.

    thanks again. makes me feel a lot better about the upgrade.

    Mike

  8. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    the widget drag-and-drop does NOT work due to the interface.js and jQuery.js incompatibility

    This is incorrect and also a bit of a silly statement to make. Widget drag and drop *does* work in 2.3.2. People are using it. I use it. It works. No question about it.

  9. KirkM
    Member
    Posted 6 years ago #

    Mike,

    Glad it worked but that raises another question about the WordPress Automatic Upgrades Plugin (WAUP). This plugin has always worked fine for me as well. Must be something to do with your host and permissions thereof (or lack of for that matter). My host offers no restrictions of any kind unless I invoke them myself. Perhaps if I get the time I'll try to find out what's up with this but this is the wrong thread for it.

  10. bszuta
    Member
    Posted 6 years ago #

    Kirk -

    I did as you recommended and it ... worked!
    I am SO happy! I have not idea what was wrong with the other file. This time I used the linix version *.tar.gz (last time it was *.zip)
    I guess, the mystery has been solved. I don't know how one tags this thread as [solved]. I know that there are other threads that deal with the exact problem.
    BTW, my installation was NEW (no upgrades).

    Thank you Kirk.

  11. KirkM
    Member
    Posted 6 years ago #

    You're very welcome. There's always a chance that a single download might be corrupted, uploading to your install might drop a bit or two on the way or (usually) an overwrite just doesn't work properly. It's always wise during an upgrade to backup up your database first and then delete those 2 directories I mentioned before uploading the new ones. Overwriting the root files with the new updated ones is safe enough but trying to overwrite the "wp-admin" and "wp-includes" directories is always asking for problems.

    And to mark a topic resolved is easy (you have to be logged in of course). If you began the thread, like you did this one, at the top of the thread in the information box that contains your title you'll see a drop down menu that has "This topic is" to the left of it. Just select "Resolved" from the drop down list and then hit the "Change" button.

    Happy blogging then...

Topic Closed

This topic has been closed to new replies.

About this Topic