WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Installed in one directory, want to move to root (8 posts)

  1. keydet86
    Member
    Posted 6 years ago #

    OK, I followed the instructions in http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory but I still cannot get it to work.

    My front page displays correctly, but all other pages generate errors. Tried everything I could think of to no avail.

    sportsphotoguy.com is my site.

  2. Charles Frees-Melvin
    Member
    Posted 6 years ago #

    it looks as if you .htacess is the issue.

    1. Make it CHMOD 777
    2. Turn of Pemalinks in you wp settings
    3. Re-enable them it should work.

  3. keydet86
    Member
    Posted 6 years ago #

    OK, I think I figured out the CHMOD 777 thing, but how do I turn 'off' permalinks?

  4. Charles Frees-Melvin
    Member
    Posted 6 years ago #

    In you wp-admin > settings (options) > Permalinks

    (your url)/wp-admin/options-permalink.php

    is the file if you just want to type the url to get there.

  5. keydet86
    Member
    Posted 6 years ago #

    Well, yes. But there is no 'off' setting that I can see. So what do you mean by 'off'? I tried resetting to the default, updating permalinks, then resetting to my custom structure, but it doesn't work.

    I followed Chris Pearson's (Cutline nee Neoclassic theme author) advice to set my permalink structure to /%postname%/. This worked when WordPress was in its default location but perhaps that needs to be changed?

  6. Charles Frees-Melvin
    Member
    Posted 6 years ago #

    in your general tab did you change the wordpress address to the new location?

  7. keydet86
    Member
    Posted 6 years ago #

    Yep, sure did. WordPress location actually never changed; it was always http://sportsphotoguy.com/wordpress so I just left it. Web site location I changed to http://sportsphotoguy.com. I moved index.php and .htaccess from http://sportsphotoguy.com/wordpress to http://sportsphotoguy.com as described in the support article.

    You were correct about CHMOD, because one of the things I found was that previously the .htaccess file was not being updated. Now it gets written correctly.

  8. keydet86
    Member
    Posted 6 years ago #

    OK, well...I changed Permalinks back to default, updated, tried it and it worked. So then I reset my custom tag, updated, and it still works. So...problem solved. Must have missed a step somewhere along the way.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic