WordPress.org

Ready to get started?Download WordPress

Forums

Google Language Translator
[resolved] installed, flags show, in widget sidebar (20 posts)

  1. tangerine3
    Member
    Posted 6 months ago #

    Hello,

    I have the latest version of WP installed and have downloaded, installed and activated google translate plug in. I put the shortcode in text widget '[google-translator]' and show language box is checked. the flags show up but not the language box and when I click on any flag it does not translate?? https://www.chromehorserentals.com

    Any help would be appreciated, thank you.

    http://wordpress.org/plugins/google-language-translator/

  2. apostlepoe
    Member
    Posted 6 months ago #

    Hi,

    After your site has loaded I see just the flags. About 5 or so seconds later an URL with the address "ct1.adthis.com" loads, after which the translator box appears.

    For me, after the translator box appears, the plugin works perfectly.

    Maybe your site is waiting for outside content to load before loading the remainder of your site. Just a guess...

  3. apostlepoe
    Member
    Posted 6 months ago #

    Correction.

    I left out a "d" in the previous post. It should be "ct1.addthis.com".

  4. tangerine3
    Member
    Posted 6 months ago #

    still nothing for me I am using Mozilla Firefox. what do you mean by "you see ct1.addthis.com loading"? Are you looking in the background somewhere? This is another widget at the bottom of my widgets for sharing???

  5. apostlepoe
    Member
    Posted 6 months ago #

    Hi,

    After your site loads, the address "ct1.addthis.com" appears on the address line in place of your website address. The progress bar in the address line then appears as if it is accessing the "ct1" address. Once the progress bar gets all the way to the right, your original website address appears again on the browser's address line.

    I visited your site using Safari, Chrome and a browser called Atomic. They were all able to access the Translator bar. I don't have Firefox or IE handy.

    First thing you may wish to do is to try a different browser (or two).

    If that doesn't do anything, can you easily disable the "addthis" service?

  6. tangerine3
    Member
    Posted 6 months ago #

    i removed the addthis widget by dragging it over to the left hand side and the translator widget is still not working

  7. apostlepoe
    Member
    Posted 6 months ago #

    Hi,

    I am seeing the same behavior. The flags appear, your site loads the following URL, then the box appears. Were you able to test your site with a different browser?

    This is the "ct1.addthis.com" URL that is loading in the background. It's kind of long.

    https://ct1.addthis.com/static/r07/sh138.html#iit=1380919393366&tmr=load%3D1380919389345%26core%3D1380919390798%26main%3D1380919393338%26ifr%3D1380919393376&cb=0&cdn=1&chr=UTF-8&kw=&ab=-&dh=www.chromehorserentals.com&dr=&du=https%3A%2F%2Fwww.chromehorserentals.com%2F&dt=Chrome%20Horse%20Harley%20Rentals%20Tampa%20Florida%20Daytona%20and%20Sturgis%2C%20SDChrome%20Horse%20Harley%20Rentals&dbg=0&md=0&cap=tc%3D0%26ab%3D0&inst=1&irt=1&jsl=1&prod=undefined&lng=en-us&ogt=image%2Csite_name%2Curl%2Cdescription%2Ctitle%2Ctype%3Darticle%2Clocale&pc=wpp&pub=chromehorse&ssl=1&sid=524f285e9529f32d&srpl=1&srcs=1&srd=1&srf=0.02&srx=1&ver=300&xck=0&xtr=0&og=locale%3Den_US%26type%3Darticle%26title%3DChrome%2520Horse%2520Harley%2520Rentals%2520Tampa%2520Florida%2520Daytona%2520and%2520Sturgis%252C%2520SD%26description%3DChrome%2520Horse%2520offers%2520Harley%2520rentals%2520in%2520Florida%2520in%2520the%2520Tampa%2520bay%2520area%252C%2520Daytona%2520and%2520Sturgis%252C%2520SD.%2520We%2520have%2520been%2520renting%2520motorcycles%2520since%25201999.%26url%3Dhttps%253A%252F%252Fwww.chromehorserentals.com%252F%26site_name%3DChrome%2520Horse%2520Harley%2520Rentals%26image%3Dhttps%253A%252F%252Fwww.chromehorserentals.com%252Fwp-content%252Fuploads%252F2011%252F09%252Fchrome-horse-harley-rentals-300x168.jpg&aa=0&rev=123733&ct=0&xld=1&xd=1
  8. tangerine3
    Member
    Posted 6 months ago #

    that's weird i removed the addthis widget. I guess i'll have to completely uninstall it. in the meantime the whole household used firefox so . . . .is there a simple way to use another browser without replacing firefox? That way I can see if it is just firefox

  9. WPyogi
    Volunteer Moderator
    Posted 6 months ago #

    is there a simple way to use another browser without replacing firefox?

    You can certainly have more than one browser at a time installed on your computer - http://browsehappy.com/

  10. tangerine3
    Member
    Posted 6 months ago #

    i opened internet explorer and it is there! So it is a Firefox problem. I went to their support forum and they had a couple of other ppl asking the same thing. It says to clear the cache by going to firefox/tools, options and . . .or starting firefox in safe mode blah blah blah so thank you I will have to get help from firefox support forum now.

  11. apostlepoe
    Member
    Posted 6 months ago #

    You might also wish to try accessing your site using a copy of Firefox on a different computer. To see if the problem is perhaps limited to just your computer.

  12. apostlepoe
    Member
    Posted 6 months ago #

    Hi again :)

    I have an old Dell Inspiron here at home running Firefox version 3.6.25 and Internet Explorer version 8.0.6001.18702IC . Both loaded the Translator box and translated your site without any problem.

    I came across a few links concerning possible issues between Firefox and "addthis". Hope it helps :)

    http://www.google.com/search?q=addthis.com%20Firefox%20problem

  13. apostlepoe
    Member
    Posted 6 months ago #

    Glad to hear you've worked it out!

    =0)

  14. tangerine3
    Member
    Posted 6 months ago #

    addthis is disabled, addthis was coming up fine it was the translator that i couldn't see correctly in firefox. Internet explorer shows both just fine. I did go to my laptop that also has firefox and translator did now show correctly there also. When I tried to open IE on the laptop it kept crashing so I have to find out if there is a setting in firefox that I have to change to allow the transltor to show up correctly. I can't find where to clear the cache that was suggested by others that were having the same problem with the translator and firefox.

  15. apostlepoe
    Member
    Posted 6 months ago #

  16. tangerine3
    Member
    Posted 6 months ago #

    after reading some support pages in mozilla i found out that if you click on the gray shield in the address bar it allows you to select disable protection for this page and then the full translator box will show up. But does that then mean that information on the page is subject to being seen by third parties if a form is submitted over the internet?

  17. apostlepoe
    Member
    Posted 6 months ago #

    Hi Tangerine3,

    I have Firefox (FF) 3.6 so am unfamiliar with the latest FF "protection features". From my understanding of the feature it is designed to block known "bad guys" from accessing your browser and using your browser to exploit sites which you regularly visit. That is, taking you to "spoofs" of sites you regularly visit.

    In that sense

    Using GoogleTranslator does not play into this At All.

    If you wish to have a "secure financial transaction" option for your site you really need to contact the service whom you have hired to secure financial transactions and discuss the best way to provide secure financial transactions through your site and your visitors.

    Best recommendation based on my personal opinion and NOT experience, contact the service whom you have hired to process financial transactions and see what they recommend.

    Given what information you have so far shared, neither Firefox or Google Translate have anything, on this level, to do with secure financial transactions.

    Namasté

    ap

  18. tangerine3
    Member
    Posted 6 months ago #

    my whole site is https so when choosing the option to unblock unsecure items by clicking on the gray shield in the address bar it allows the whole google translator toolbar to drop down, that is all i'm saying.

  19. Rob Myrick
    Member
    Plugin Author

    Posted 6 months ago #

    Hi guys, thanks for posting this conversation. I just updated the plugin to version 2.7 which is more stable. There were definitely some previous issues. Please update and report any good/bad findings here. I want to make sure the plugin is working for you guys.

    It sounds like some other issues here though - but at least you will have most up to date plugin.

    Thanks for posting!

    Rob Myrick

  20. Rob Myrick
    Member
    Plugin Author

    Posted 6 months ago #

    I'm going to assume all is good here. Thanks for posting your issue. Let me know if there's more I can do to help.

    Rob Myrick

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.