WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Installed WP-Super-Cache, no love :( (3 posts)

  1. incursio
    Member
    Posted 6 years ago #

    Hey Donncha - great idea for a plugin!

    I've just spent several hours trying to get it to work, but I'm getting 0 cached pages. Everything checks out - install is fine as far as I can tell.

    No safe mode (PHP5/Linux/Apache/WP 2.31)
    mod_mime, mod_rewrite, fancy permas on
    .htaccess looks good (both)
    WP_CACHE defined as true
    I even made all dirs 777 for shits and grins - still no love

    Have tried compression on/off to no avail. Compression not currently enabled in WP.

    I am hitting pages with IE (not logged in), and another window in Firefox reloading the cache stats in wp-admin. 0 cached pages.

    Any ideas?

    Thanks!

  2. ateam
    Member
    Posted 6 years ago #

    To incursio et al:

    I just spent several hours working this as well! After I double checked everything, reread this forum and all related links - I STILL COULDN'T GET IT TO WORK.

    I'm not an idiot - so clearly I was missing something obvious because other people got it to work. So, I started to debug it.

    Then I found out... This line in wp-config.php
    define( 'WP_CACHE', true );

    must come before this line:
    require_once(ABSPATH.'wp-settings.php');

    Hope that helps...

  3. incursio
    Member
    Posted 6 years ago #

    ateam - thx. Great minds think alike - I just spent some more debugging time and came to the same conclusion - was just about to come post the solution here as well - lol.

    Donncha - great plugin, mate!

    Cheers.

Topic Closed

This topic has been closed to new replies.

About this Topic