WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Installed, changed directory, now not working (7 posts)

  1. nmeyer
    Member
    Posted 1 year ago #

    (I'm using 1and1 as my host) So I successfully installed WordPress at my /blog directory, but then decided that I would rather just have wordpress at the root directory. I tried moving the files over, but that caused problems (which I can't remember specifically at the moment), but anyway, I ended up completely deleting the /blog directory and using a fresh copy of wordpress in my root directory.

    I now see the login page when I go to mydomain.com/wp-login.php, but the images don't load and any of the links (lost your password?, login, etc) go to an "Error 404 page not found" error.

    Any ideas on what I need to do next?

  2. graphicgeek
    Member
    Posted 1 year ago #

    Do you know if you're using the same database from the first install? You may need to update the site url and home options in the database. Or you may need to look at your .htaccess file, and see if it is causing some kind of redirect.

  3. Karun
    Member
    Posted 1 year ago #

    search all your database tables and find yoursite.com/blog and rename it to yoursite.com

  4. nmeyer
    Member
    Posted 1 year ago #

    I'm using the same database. I can delete and create a new one, if necessary. At my hosting site's control panel, I changed the database from pointing to "/blog" to "/"

    For the .htaccess file, I have one in the "/" folder that says:

    Action x-mapp-php3 /system-bin/php5exe
    Action x-mapp-php4 /system-bin/php5exe

    Although it doesn't have a .php file extension. I didn't put it there, so I think it's a result of making sure that PHP 5 was used in my hosting website's control pannel.

    I have one more .htaccess file in my /log folder:

    Options +Indexes
    RemoveHandler .html
    RemoveType .html
    AddType text/html .html
    Satisfy any
    Order Deny,Allow
    Allow from 212.227.112.228
    Deny from all
    AuthType Basic
    AuthName "Access to /logs"
    AuthUserFile /kunden/homepages/19/d429180378/htpasswd
    Require user u000000

    How would I go about changing my database tables? I'm using Filezilla, is there a file in my /log directory I can change? Sorry I'm so clueless!

  5. Karun
    Member
    Posted 1 year ago #

    You cannot alter your database tables from Filezilla.

    First login to your control panel and look for phpmyadmin.

    When you go inside phpmyadmin, it will sometimes ask for your mysql username and password.

    After the authentications, you can access your database.

    Then select the database and use the inbuilt search function to search for yoursite.com/blog and then when you find them, edit them to yoursite.com

  6. nmeyer
    Member
    Posted 1 year ago #

    Ah, perfect, thank you. I went in to myPHPadmin deleted all the references and it works perfectly now! Thanks once again for all your help! You all are a huge lifesaver.

  7. Karun
    Member
    Posted 1 year ago #

    Glad I could help. Please mark the topic as resolved if the problem is now solved :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.