WordPress.org

Ready to get started?Download WordPress

Forums

Installed 3.4 and now cannot log into site (13 posts)

  1. JGray1988
    Member
    Posted 2 years ago #

    Last night I was prompted to upgrade to wordpress 3.4.... So I did, all of my background has disappeared and there is now an error message at the top of my website when anybody tries to view it

    http://www.jgrayphotography.co.uk

    To make things worse then I go to jgrayphotography.co.uk/wp-admin I do not get the option to log in but instead I get this message:

    "Notice: get_theme_data is deprecated since version 3.4! Use wp_get_theme() instead. in /customers/c/1/b/jgrayphotography.co.uk/httpd.www/wp-includes/functions.php on line 2705 Notice: get_theme_data is deprecated since version 3.4! Use wp_get_theme() instead. in /customers/c/1/b/jgrayphotography.co.uk/httpd.www/wp-includes/functions.php on line 2705"

    I can no longer even log into the wordpress support forum and have had to create this username etc just to post this message!

    Many Thanks,

    Joseph Gray

  2. govpatel
    Member
    Posted 2 years ago #

    Your website opens fine for me may be is theme problem you will need to update your theme.

  3. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Revert to the default theme Twenty Eleven and see if you experience the same problem.

  4. smartlook
    Member
    Posted 2 years ago #

    Well I have the same problem but I can not login the site, them its difficult to revert to the default theme Twenty Elven. What do I do?

    Thx David

  5. smartlook
    Member
    Posted 2 years ago #

    When I try to login I receive this:

    Notice: get_theme_data is deprecated since version 3.4! Use wp_get_theme() instead. in /customers/d/6/7/smartlookoptikk.no/httpd.www/wp-includes/functions.php on line 2705 Warning: Cannot modify header information - headers already sent by (output started at /customers/d/6/7/smartlookoptikk.no/httpd.www/wp-includes/functions.php:2705) in /customers/d/6/7/smartlookoptikk.no/httpd.www/wp-includes/pluggable.php on line 881

    ??? Help :(

  6. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    @smartlook,

    Try replacing this
    get_theme_data
    with
    wp_get_theme()

    in your functions.php file.

    The second warning relates to presence of while space either before or after the opening and closing php tags in functions.php file.

  7. govpatel
    Member
    Posted 2 years ago #

    Well I have the same problem but I can not login the site, them its difficult to revert to the default theme Twenty Elven. What do I do?

    Using ftp rename the theme folder so that default twenty eleven theme opens.

  8. smartlook
    Member
    Posted 2 years ago #

    Okey thx I will giv it at try :)

  9. smartlook
    Member
    Posted 2 years ago #

    Hi again
    I found functions.php in wp-includes folder and I made a search in notepad and did not find wp_get_theme()?? Why?

  10. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Do you find get_theme_data ? If so replace it with wp_get_theme()

  11. smartlook
    Member
    Posted 2 years ago #

    No I did not find get_theme_data

  12. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    @smartlook,
    Can you open a separate topic? It creates confusion when you post to someone else's thread.

  13. smartlook
    Member
    Posted 2 years ago #

    Okey sorry :)

Topic Closed

This topic has been closed to new replies.

About this Topic