WordPress.org

Ready to get started?Download WordPress

Forums

Installed 2.7.1 - photos do not upload!! (21 posts)

  1. rapidreasoning
    Member
    Posted 5 years ago #

    Help! I uploaded 2.7.1 - TWICE! to try and fix the problem. I go to upload a photo and after it is finished "crunching", I see a "blank" preview and a "broken icon" link in the post itself. I went so far as to clear out my entire blog and start from scratch. It still is not working! Any assistance would be greatly appreciated!!

  2. blythelight
    Member
    Posted 5 years ago #

    I, too, am having this problem with upgrading from 2.6.3 to 2.6.5. I have searched the help forums to no avail. A suggested solution was to go to Settings- Miscellaneous- "Store Uploads in this folder" (should be wp-content/uploads). This did not work for me. Mine was already correctly directed. I am not computer-savvy enough to mess with the phpMyAdmin tables. I could not find a line to edit in the theme pages. I did notice that in the html view, the pathway to the images was in all lowercase, whereas my image files were uploaded with both upper and lowercase letters, plus the jpg extension was JPG. I renamed them to all lowercase to match the html path, but that also did not work. My site relies on pictures a lot. I hope I can figure this out. Version 2.6.3 worked fine for me - and I see they are up to 2.7.1 already. I usually only do the upgrade when it's a one-click process available through Fantastico.

  3. david123657
    Member
    Posted 5 years ago #

    I'm also having this problem. I installed a WordPress 2.7.1 for a client and while everything else works, we can't upload any images. And after searching Google for a solution it seems that problems with image uploading in WordPress have been pretty widespread (and go back many versions)

  4. blasr
    Member
    Posted 5 years ago #

    I had the same problem in IE7. Change the file permissions to 777. That should fix it. Best thing to do is to stop using IE.

    How to Change File Permissions

  5. missingrid
    Member
    Posted 5 years ago #

    I was having the same problem w/ 2.7.1. with images not showing when uploading from computer -- made one change and now it works! I went to Settings > Misc > Full URL path to files and deleted the file path here. I left the file path in the field Store uploads > wp-content/uploads. Saved, went back to new post and voila! Image uploaded from computer and fully showing, yay!

  6. martynmoore
    Member
    Posted 5 years ago #

    Tried that but it didn't work for me. Tried every combination of upload directories and various paths, tried .htaccess files in wp-admin, tried resetting permalinks and have had my host confirm permissions set to 755.

    Nothing allows me to insert an image via the text editor, apart from FTP direct to folder then choosing "link to URL".

    I'm surprised by the number of people who have had this type of problem and the range of solutions offered. None worked for me and I'm getting desperate.

    Any other suggestions out there?

  7. pcuk
    Member
    Posted 5 years ago #

    I just upgraded to 2.7.1 and had the same issue. I deleted the (oddly spurious) entries in "Miscellaneous", "Settings", "Store Uploads in this Folder", and then had no problems.

  8. Usman Latif
    Member
    Posted 5 years ago #

    I had the same problem and tried the deleted the path in the box "Store Uploads in this Folder" as explained by 'pcuk' above and it is working fine now.

  9. dandyeric
    Member
    Posted 5 years ago #

    Well, I had no funny entries in the folder, they mapped correctly to the files on the ftp, and I changed to 777 and still nothing.

    Any new ideas?

  10. mommaschoice
    Member
    Posted 5 years ago #

    Same problem as everyone else when I updated to 2.7, but did the suggestion of missingrid (settings > misc > store uploads in this... and deleted what was there. Both fields are blank, saved and now it works! Thanks!! It didn't restore all the old pictures, but at least I can put them back in.

    Next time I'm waiting AWHILE before I upload a new version! So they get the kinks out first.

  11. srdato
    Member
    Posted 5 years ago #

    Guys:

    I have been grappling with this wp 2.71 issue since inception (new blogger so only since early April) but thank you soooo very much for this info...I did what you all recommended above and it worked!! To all who take the time to visit and share solutions...it's truly wonderful!

    This really is a great community and I'm so glad to be a part of it!

    Best to you all!

  12. Chilaxnanananananana
    Member
    Posted 5 years ago #

    Same here, It's because of people taking the time to discuss these issues that solutions can be reached and further waste of time avoided. Thank you all. Having said that I had the same issue and followed the advice of missingrid and mommaschoice and the issue seems to be resolved. I don't know how the both of you arrived to that solution but thanx for the tip.

  13. lccoach
    Member
    Posted 5 years ago #

    Hi folks

    I just joined the forum because I have been having difficulty uploading new photos too. I'm not sure if my problem is the same as everyone else. Months ago, I started having trouble with IE. Now Firefox won't upload new photos when I click on media. Anything already in my media gallery inserts just fine.

    When I click on Choose files to upload, nothing happens. No window opens up at all.

    I still have wp 2.5.1 and I am not a techie on this stuff. My web person handles it all and she can insert photos just fine.

    Does Norton have anything to do with all this? Should I try the things suggested to everyone else?

    Help!
    lccoach

  14. tigersydney
    Member
    Posted 5 years ago #

    Hi everybody,

    I' ve got no solution - facing the similar problem. I'm using version 2.7.1 and now I can't upload any images. First I thought it's a problem linked to the upgrade of the next-gen gallery. But reading all the trouble here I doubt it't. Same problem a martynmoore mentions...

    On any media-upload I always get the message:
    Das Verzeichnis /wp-content/uploads konnte nicht erstellt werden. Ist das darüberliegende Verzeichnis für den Webserver schreibbar?
    In English something like
    "Could not establish directory /wp-content/uploads. Make sure that the webserver can write on the directory above."...

    Any new solutions. Already checked the pathe in the settings - is ok. Tried different file attributes - even 777. Error is still there.

    Please - help me anyone!
    Thanks a lot in advance!

    tigersydney

  15. webjunk
    Member
    Posted 5 years ago #

    Try disabling plugins. It might be that. Have seen it before.

  16. justinratwebtek
    Member
    Posted 5 years ago #

    Either change the settings to dump everything into wp-content/uploads (with 777 permissions) or you may have to create the sub-folders it wants to create manually. I had one picky install where I had to create the folders for it manually. Ended up just telling it to use the uploads dir.

    Typically, this is due to the permissions that your "user" account runs on the web server - nothing to do with wordpress. This account is typically your FTP username. Some companies set these user accounts with little permissions on the server, sometimes it causes problems.

  17. tigersydney
    Member
    Posted 5 years ago #

    hi there,

    back from holiday - tried the hints you gave - thank you for that. Unfortunately it didn't help.
    In the meantime I upgraded to WP2.8 - didn't make it any better.
    Any other ideas?

    I keep searching...

  18. bh_WP_fan
    Member
    Posted 5 years ago #

    For the error in creating /wp-content/uploads, just go into your admin section, to Settings > Miscellaneous, and make sure that the path is wp-contents/uploads and NOT /wp-conent/uploads. The extra slash / in front of it will break it. If that doesn't work, check that all of your directories to the uploads directory have working permissions on them. Generally 755 will work, but depending on your host it may need to be changed to 777.

    If you are using Firefox and gears, disable gears.

    If you're using the flash loader and it won't work for you, try the browser uploader... or vice-versa.

  19. tigersydney
    Member
    Posted 5 years ago #

    @bh_WP_fan:

    a million thanks! it was the leading slash! No idea where it came from - I was sure I didn't overright anything there. After your hint I checked it again and removed the leading slash - and it works!!

    cheers,
    tigersydney

  20. jhazzi
    Member
    Posted 4 years ago #

    Thanks to EVERYONE. I'm 3 days old with WP. Moved site from subdirectory to a new domain root. Images wouldn't show. I was able to troubleshoot through this thread and solve the problem.

    I didn't tell you that I was at wordpress.com, initially with the problem, did I? LOL

    Be well,
    Jhazzzzzzi

  21. divakay
    Member
    Posted 4 years ago #

    I have read all the posts - didn't understand most of them ;}
    This is what I have done for 5 years and now it does not work!!! [I use Internet Explorer because my Firefox is funky - never had a problem before]
    1. click on add image icon 2. choose browser upload [flash does not seem to work] 3. browse and choose photo from folder 4. Upload 5. wait, and wait and wait 6. Sometimes it uploads fine [YEA!] sometimes I get a red message saying that it can't do it OR an IE message that says that they can't do it because I am not on line, wrong address or WP has a problem 7. Sometimes I try again and again and it works, but more often it doesn't work - of course I am on line and the address is a WP link so is the problem WP [yes I did upgrade to 2.8.4 AND cleared the cache AND checked the settings]

    H-E-L-P!!!!

Topic Closed

This topic has been closed to new replies.

About this Topic