WordPress.org

Ready to get started?Download WordPress

Forums

Installation Problems... (21 posts)

  1. benn213
    Member
    Posted 2 years ago #

    Hi there,

    This is my first time posting and im sure its wont be my last!
    Was hoping for some help with setting up wordpress.

    This is what ive completed so far...

    Created a MySQL database on the server

    Downloaded wordpress

    Changed the relevant info on wp-config-sample.php file in text edit
    and re saved it as wp-config.php

    Uploaded wordpress to my server* (into a wordpress folder inside of
    public_html folder)
    *i had to use dreamweaver to do this as for some reason filezilla
    will not let me connect to the server.

    And thats everything ive done so far but i get the feeling that i may be doing
    something wrong as my friend says i should be seeing wordpress on my website now.

    i have a holding page up for my site (www.squeakyhill.com), do i have to
    take this down?

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you run the install process yet?

  3. ChristiNi
    Member
    Posted 2 years ago #

    Hi benn213,

    I noticed you said you uploaded your wp-config.php file to a WordPress folder inside of public_html. Did you install the rest of your WordPress files into that folder as well?

    Normally, the standard way is to simply install WordPress into your public_html folder (including the wp-config.php file). If you wanted to put WordPress in it's own directory but still have it running on your main site you'll want to follow the following instructions to set it up that way:

    Giving WordPress it's own Directory

    If you're not able to connect to your hosting account with FileZilla, I would recommend getting that issue resolved. Are you seeing any errors in FileZilla? Have you asked your hosting company to help you resolve those errors?

    Finally, yes, you will need to take down your holding page in order for WordPress to show up properly.

    Hope this helps!

  4. benn213
    Member
    Posted 2 years ago #

    Esmi- Ive not seen any options to run a wordpress install yet.

    ChristiNi - I have uploaded the entire content of wordpress into its own folder. The reason i did this was because i wanted a holding page to appear whilst the site was under construction. I'll sort out the filezilla issue and see what happens when i move the wordpress files into the root folder.

    Thanks for your responses!

    Benn

  5. esmi
    Forum Moderator
    Posted 2 years ago #

  6. ChristiNi
    Member
    Posted 2 years ago #

    Hello again Ben,

    The install script is something you bring up by going to yourdomainname.com/FolderWordPressIsIn/install.php in your browser.

    Let us know how this works out.

  7. PaulineF
    Member
    Posted 2 years ago #

    Hiya, I'm having the same problem. I've removed and reloaded all the files about three times now, and when I try to open the install.php file (using the domain and subfolder as above) it just comes up with code.

    While the code is nice and pretty, it isn't really very helpful. :-) (to me, anyway). I'm trying to run this installation concurrently with my html site (which is still up and running, which is great) while I develop the wp site, which I'll then move over to the main directory (hopefully)

    However, in the meantime, how do I get my code to actually turn into little boxes and things (technical term lol) I'm running firefox on windows 7, if that's any help?

  8. PaulineF
    Member
    Posted 2 years ago #

    Actually, I can now report success!! Apparently I had already installed it, and now when I just open http://www.domainname/wordpress it comes up. Yay. Take the simple approach, I guess. Now I just have to make it go. Love having the key in the ignition, though, that's a bonus!!

    Thanks for the help I'm sure you would have given, though!! :-)

  9. benn213
    Member
    Posted 2 years ago #

    Hi ChristiNi,

    Am i right in thinking i should be going to this web address (as my site is http://www.squeaky hill.com) -
    http://www.squeakyhill.com/squeaky_hill/install.php

    It just displays the message error 404 - not found

    In side my squeaky hill root folder where exactly should the wordpress files be stored? Ive tried within public_html and out. Really feel like ive hit a dead end with this now!

    Is there any other vital part i may have missed out?

    Thanks for all the help so far.

    Benn

  10. benn213
    Member
    Posted 2 years ago #

    By the way the only things i changed on the wp-config.php where -

    DB name
    DB user name
    DB password
    DB host

    Authentication Unique Keys and Salts (by copy and pasting the new info from - https://api.wordpress.org/secret-key/1.1/salt/)

    Should anything else have been changed on this file or any other wordpress file?

  11. benn213
    Member
    Posted 2 years ago #

    Ive also tried this path and get the same error 404 message.

    http://www.squeakyhill.com/squeaky%20hill/public_html/install.php

    My wordpress files are currently in this folder path...

    Squeaky hill - public_html - then all the wordpress files are lose in here

    So lost with this...

  12. benn213
    Member
    Posted 2 years ago #

    I seem to have placed the wordpress files in the correct place but now im faced with this message ; Error establishing a database connection

    Link - http://www.squeakyhill.com/squeaky%20hill/

    If anyone can help id be eternally grateful

    Cheers

    Benn

  13. ChristiNi
    Member
    Posted 2 years ago #

    Hi Benn,

    I'm glad you were able to reach the install script. Just a quick note about public_html (your document root directory). When you upload files or install software that you want to use for your domain squeakyhill.com you would normally want to put those files in public_html because it's your document root. When you want to access your site in a browser, you do not put public_html in your URL, you just go to your domain name squeakyhill.com and it will automatically pull up the files in your public_html directory. If you want some more info on the document root directory, please see: Your Document Root Directory

    Now, onto the Database Error you are seeing. This is caused by one of the following:

    • Incorrect Hostname
    • Incorrect Database Name
    • Incorrect Database Username
    • Incorrect Password
    • Check your wp-config.php file for the above information. Note that the hostname is usually localhost, the database name and database username are the ones you created when you created your database. The password should be the password for that database username.

      Hope this helps!

  14. benn213
    Member
    Posted 2 years ago #

    Hi ChristiNi

    Thanks for your response!

    Ive double checked all of the info in wp-config.php and changed the host to 'local host'

    I understand what your saying about the public_html folder but by typing in the address- http://www.squeakyhill.com/public_html/ im able to see some sort of confirmation that wordpress is being regognised, even though it doesnt apprea to be working.

    I know have a different message....

    Warning: require_once(/homepages/36/d126298906/htdocs/squeaky hill/public_html/wp-settings.php) [function.require-once]: failed to open stream: No such file or directory in /homepages/36/d126298906/htdocs/squeaky hill/public_html/wp-config.php on line 90

    Fatal error: require_once() [function.require]: Failed opening required '/homepages/36/d126298906/htdocs/squeaky hill/public_html/wp-settings.php' (include_path='.:/usr/lib/php5') in /homepages/36/d126298906/htdocs/squeaky hill/public_html/wp-config.php on line 90

    I have literally no idea what this means though!!

  15. ChristiNi
    Member
    Posted 2 years ago #

    Hi benn213,

    If you are having to put public_html in your url, you should check to see if you've created a second public_html directory underneath the original public_html. I'm concerned there may be too many changes going on at once. Why don't we get your WordPress install up and running and then look into adding the Authentication Unique Keys and Salts to your wp-config.php? It's best to take things one step at a time so problems are easier to identify and fix.

    Instead of trying to chase down all the possible issues, it might be easier to start with a fresh install. You already have your database and database username. So, how about removing all the WordPress files and folders previously uploaded. Next, upload your WordPress files and folders (or the zip file and then extract it on the server). If you want WordPress to power your entire site, upload to public_html. Make just the necessary changes to wp-config.php so that you can connect to your database. Remove or rename your holding page and see if your WordPress site is now up and running.

    Please let me know how this goes.

  16. benn213
    Member
    Posted 2 years ago #

    Ok thanks ChristiNi

    I'll start by deleting everything besides the squeaky hill root folder

    Should i put all of my new wordpress files into a public_html folder on my computer? The problem ive been having is i cant uploaded a group of files in filezilla unless they are already in a folder so ive been uploading all of wordpress to the server as the public_html folder?

    Sorry if im being extremely dumb with this, i really do appreciate your help.

    Cheers

    Benn

  17. ChristiNi
    Member
    Posted 2 years ago #

    Hi benn213,

    All of your WordPress files and folders should be just inside the public_html directory on your server.

    You can upload multiple files with FileZilla. Multi-select files and folders on the left side of the screen in FileZilla (your local computer) by holding down the CTRL key and clicking on each file or folder. Then simply right click and choose Upload or drag them over to the right side of the FileZilla screen (your server).

    Hope this helps!

  18. benn213
    Member
    Posted 2 years ago #

    Ok, just selected the files individually and uploaded them. All files are now directly in the squeaky hill rot folder but im still getting this message ; http://www.squeakyhill.com/

    Ive been researching what the problem may be and its led me to a couple of questions...

    Firstly a cause of the problem may be that it is a windows platform and not linux. I have emailed one and one to ask which platform it is as its not my account so i wasnt part of the set up.

    Apparently when you use 1and1.co.uk for wordpress you must change the host name in wp-config from locl host to the mySQL database host name given to you in the setup.

    Secondly, in the servers control panel there is a local php settings option and everything is turned to 'off'. Is that how it should be?

    Could any of these things be causing the database error?

    Ive spent about 13 hours in total trying to get this installed now and i have no idea what im doing wrong.

  19. ChristiNi
    Member
    Posted 2 years ago #

    Hi benn213,

    Thanks for the update. That information changes things a bit. I'm sorry but I'm not going to be your best resource as my experience is with Linux hosting. I was able to find these tutorials in my research that are specifically about installing WordPress on 1&1:

    http://antbag.com/how-to-install-wordpress-with-1-and-1-hosting/

    http://faq.1and1.co.uk/scripting/php/23.html

    Good luck with the install!

  20. benn213
    Member
    Posted 2 years ago #

    Thanks so much for all of your help. Ive managed to get it working somehow!

    Cheers

    Benn

  21. ChristiNi
    Member
    Posted 2 years ago #

    Glad to hear that. Good luck with your new site Benn!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.